Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Users and developers helping users with generic and technical Pale Moon issues on all operating systems.

Moderator: trava90

Forum rules
This board is for technical/general usage questions and troubleshooting for the Pale Moon browser only.
Technical issues and questions not related to the Pale Moon browser should be posted in other boards!
Please keep off-topic and general discussion out of this board, thank you!
User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 742
Joined: 2015-08-01, 18:33
Location: California

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Post by stevepusser » 2020-09-07, 07:04

OK, the extensions issue seems to be fixed now with new 28.13.0-2 packages in my repo.

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 742
Joined: 2015-08-01, 18:33
Location: California

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Post by stevepusser » 2020-09-29, 19:17

28.14.0 now building on the OBS. The Pale Moon developer page didn't show any extra configs necessary with this updated build. First local build on a Buster base for MX Linux also was successful and runs well.

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 9680
Joined: 2012-10-09, 19:37
Location: Seriphia Galaxy

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Post by New Tobin Paradigm » 2020-09-29, 21:28

You will want to halt your builds and stand by for a point release to fix a crash introduced in the new ResizeObserver.
The universe is driven by the complex interaction between three ingredients: matter, energy, and enlightened self-interest.
Image

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 742
Joined: 2015-08-01, 18:33
Location: California

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Post by stevepusser » 2020-09-29, 22:51

That'll have to wait for tomorrow for the rebuild, but I'll switch off the package publishing so nobody gets 28.14.0.

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 742
Joined: 2015-08-01, 18:33
Location: California

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Post by stevepusser » 2020-09-30, 11:57

28.14.1 sources now loaded in the OBS, and publishing switched back on.
Last edited by Moonchild on 2020-09-30, 12:36, edited 1 time in total.
Reason: You meant 28, not 2 ;)

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 742
Joined: 2015-08-01, 18:33
Location: California

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Post by stevepusser » 2020-10-05, 17:19

Uploaded 28.14.2 sources, and packages are building.

User avatar
Pentium4User
Astronaut
Astronaut
Posts: 676
Joined: 2019-04-24, 09:38

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Post by Pentium4User » 2020-10-23, 18:41

Ubuntu 20.10 is out now, please provide the repo for it.

Thanks.
Powerline adapters (dLAN) hardly interfere shortwave radio, so stop using them.

Yes, I still use a 64 bit capable Pentium 4 670 processor with Pale Moon.

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 9680
Joined: 2012-10-09, 19:37
Location: Seriphia Galaxy

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Post by New Tobin Paradigm » 2020-10-23, 20:11

Wow, that was way more demanding than I would expect from a user. If I were Steve I'd take my sweet fuckin time satisfying that directive.

Hey, Pentium2User, don't give him orders. That is MY order to you, is that understood?
The universe is driven by the complex interaction between three ingredients: matter, energy, and enlightened self-interest.
Image

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 742
Joined: 2015-08-01, 18:33
Location: California

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Post by stevepusser » 2020-10-24, 01:27

Well, it's a moot point, since the OBS hasn't added support for 20.10 builds yet, though usually they do in a day or so. I'll announce it here when they do and the builds are successful. This might take several tries, since currently Debian Sid builds have to be handled carefully, and that's closest to 20.10. I'll try a standard build first before going the single-threaded build route that Sid requires.

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 742
Joined: 2015-08-01, 18:33
Location: California

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Post by stevepusser » 2020-10-25, 03:52

Just checked--no 20.10 support yet.

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 742
Joined: 2015-08-01, 18:33
Location: California

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Post by stevepusser » 2020-10-26, 11:20

Still no support. :(

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 29954
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Post by Moonchild » 2020-10-26, 12:41

I guess it'd be more useful to let people know when it changes? i doubt daily reports of it still not being supported really help. ;-)
"Son, in life you do not fight battles because you expect to win, you fight them merely because they need to be fought." -- Snagglepuss
Image

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 742
Joined: 2015-08-01, 18:33
Location: California

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Post by stevepusser » 2020-10-28, 08:16

The OBS support for 20.10 was enabled. First builds failed with the same error as Debian Sid used to, so am trying the same workaround.

Sources for Pale Moon 28.15.0 also uploaded.

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 742
Joined: 2015-08-01, 18:33
Location: California

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Post by stevepusser » 2020-10-29, 11:38

Most builds succeeded for 28.15.0, including all for Ubuntu 20.10. In addition to known build problems with old i386 distros and older gccs (Jessie, Xenial), armv71 (32-bit Pi) builds now are failing on Debian Testing and Unstable after over 40,000 seconds building, no doubt due to some problem with gcc 10 there.

https://build.opensuse.org/package/show ... r/palemoon

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 742
Joined: 2015-08-01, 18:33
Location: California

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Post by stevepusser » 2020-11-24, 22:55

Builds for 28.16.0 are finishing up. i386 builds for Ubuntu 16.04 and Debian 8 are still failing.

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 742
Joined: 2015-08-01, 18:33
Location: California

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Post by stevepusser » 2020-12-18, 22:58

Uploading the source files for 28.17.0 build now.

User avatar
RoestVrijStaal
Moonbather
Moonbather
Posts: 67
Joined: 2019-06-19, 19:18
Location: Dependency Hell

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Post by RoestVrijStaal » 2021-02-08, 13:55

@steveplusser
Did your (or the repository's) GPG key change between now and september 2020?
Because last weekend I updated my 32-bit Kubuntu 18.04 Bionic laptop and got GPG Key errors during running apt.

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 742
Joined: 2015-08-01, 18:33
Location: California

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Post by stevepusser » 2021-02-08, 23:25

RoestVrijStaal wrote:
2021-02-08, 13:55
@steveplusser
Did your (or the repository's) GPG key change between now and september 2020?
Because last weekend I updated my 32-bit Kubuntu 18.04 Bionic laptop and got GPG Key errors during running apt.
Yes, on Feb 3. See this thread to see how to remove the expired key anf get the new one: viewtopic.php?f=37&t=26106

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 742
Joined: 2015-08-01, 18:33
Location: California

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Post by stevepusser » 2021-02-09, 17:36

Pale Moon 29.0.1 should now be available in the repo, except, as usual now, for 32-bit versions for Ubuntu 16.04 and Debian 8, which fail to build because of a really old gcc.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 29954
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Post by Moonchild » 2021-02-09, 20:46

stevepusser wrote:
2021-02-09, 17:36
except, as usual now, for 32-bit versions for Ubuntu 16.04 and Debian 8, which fail to build because of a really old gcc
Really time for those people to upgrade their OS.
"Son, in life you do not fight battles because you expect to win, you fight them merely because they need to be fought." -- Snagglepuss
Image

Post Reply