Custom toolbar disappearing bug in PM for Linux v25.8.1

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderator: trava90

Locked
IronGiant350

Custom toolbar disappearing bug in PM for Linux v25.8.1

Post by IronGiant350 » 2015-12-05, 04:32

I'm running Linux Mint 17.2 Mate 64 bit and I was running PM for Linux v25.8.1 64 bit. The bug concerns a custom toolbar not only disappearing from sight but the custom toolbar entry also disappears from View --> Toolbars as well. The original name was "Lower Deck" but when I manually re-added the toolbar and icons I changed the name to "Lower_Deck" thinking that Linux didn't like the space.

As soon as I closed PM and re-opened it the toolbar was gone again. After uninstalling v25.8.1 and reinstalling v25.8.0 the custom toolbar and menu entry automatically reappeared. This seemed a viable workaround since v25.8.1 didn't introduce any new security fixes.

If this is not the proper place to post a bug report please let me know. I can post screenshots simulating the issue if it would help.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 27072
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Custom toolbar disappearing bug in PM for Linux v25.8.1

Post by Moonchild » 2015-12-05, 04:33

Using ublock Origin by any chance?
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

IronGiant350

Re: Custom toolbar disappearing bug in PM for Linux v25.8.1

Post by IronGiant350 » 2015-12-06, 08:57

Yes I am using Ublock Origin. Would a list of all my extensions be helpful?

User avatar
trava90
Contributing developer
Contributing developer
Posts: 1600
Joined: 2013-05-20, 18:19
Location: Earth
Contact:

Re: Custom toolbar disappearing bug in PM for Linux v25.8.1

Post by trava90 » 2015-12-06, 10:29

Hi IronGiant,

It's currently a known issue when using ublock Origin.

Please see these threads: viewtopic.php?f=3&t=10334, viewtopic.php?f=15&t=10352, and viewtopic.php?f=13&t=8266#p71296

racorbin2010
Hobby Astronomer
Hobby Astronomer
Posts: 20
Joined: 2013-09-07, 19:59
Location: Warrenton, MO

Re: Custom toolbar disappearing bug in PM for Linux v25.8.1

Post by racorbin2010 » 2015-12-06, 16:17

I have had custom toolbars disappearing for many releases of PM4L. The culprit is the extension Dragit 3.2.1.1-signed. When it is active, custom toolbars ALWAYS disappear after restart. When the extension is inactive, the custom toolbars re-appear. Is anyone else having the same problem?

This is not PM4L's fault because I had the same problem in pre-Australis Firefox also. (Not sure about FF now since I no longer use it.) The thing is that the functionality of dragging a link Up to open it in foreground and dragging a link Down to open it in background is so useful to me that I have learned to live without extra toolbars, but now I would like a custom toolbar. So far I havent found another extension with same feature as Dragit.

Any thoughts or recommendations, assuming I am not the only person with this problem?

User avatar
LimboSlam
Board Warrior
Board Warrior
Posts: 1029
Joined: 2014-06-09, 04:43
Location: USA

Re: Custom toolbar disappearing bug in PM for Linux v25.8.1

Post by LimboSlam » 2015-12-06, 19:26

racorbin2010 wrote:So far I havent found another extension with same feature as Dragit.....

........Any thoughts or recommendations, assuming I am not the only person with this problem?
I just searched for drag and whole bunch of results poop-up, here: https://addons.mozilla.org/en-us/firefox/search/?q=drag+&appver=24.9platform=windows
With Pale Moon by my side, surfing the web is quite enjoyable and takes my headaches away! :)
God is not punishing you, He is preparing you. Trust His plan, not your pain.#‎TrentShelton #‎RehabTime

IronGiant350

Re: Custom toolbar disappearing bug in PM for Linux v25.8.1

Post by IronGiant350 » 2015-12-07, 05:59

Hello trava90

Thank you for the links. I didn't know that browser themes(skins) were also known as personas. In my case I never saw any graphical glitches or miscoloration in my custom browser theme. I'm running a PCIe Geforce 7300 GT with proprietary driver nvidia-304.

It was as though my custom toolbar had completely collapsed in on itself.

Locked