Pale Moon 28/29 localization

The l10n of Pale Moon. Rawr.
User avatar
Alex654
Newbie
Newbie
Posts: 5
Joined: 2019-04-23, 23:58

Re: Pale Moon 28/29 localization

Post by Alex654 » 2020-03-15, 18:17

Hello guys, may I ask a question. It seems that the translations (at least the Russian one) miss some strings from the Tools -> Web Developer submenu. I have only 2 items instead of 10-12 when I turn on the Russian language pack. Can I help improving the translation? How can I do this?

User avatar
JustOff
Localization Coordinator
Localization Coordinator
Posts: 1994
Joined: 2015-09-03, 19:47
Location: UA
Contact:

Re: Pale Moon 28/29 localization

Post by JustOff » 2020-03-15, 18:33

Alex654 wrote:
2020-03-15, 18:17
Hello guys, may I ask a question. It seems that the translations (at least the Russian one) miss some strings from the Tools -> Web Developer submenu. I have only 2 items instead of 10-12 when I turn on the Russian language pack. Can I help improving the translation? How can I do this?
I can't confirm that. Could you please open a separate topic about your issue here or there and provide more details about your environment, screenshots and messages from the error console.
Here are the add-ons I made in a spare time. That was fun!

User avatar
Alex654
Newbie
Newbie
Posts: 5
Joined: 2019-04-23, 23:58

Re: Pale Moon 28/29 localization

Post by Alex654 » 2020-03-18, 00:11

I forgot to tell that I am using New Moon for Windows XP (version 28.8.0a1), which is a fork and officially is not supported. Is it allowed to open issues here about the translations in this case? The Russian translation pack info page says it is compatible with Pale Moon 28.8.0a1 to 28.8.*, so I guess it should work OK with 28.8.0a1.

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 7538
Joined: 2012-10-09, 19:37
Location: Just beyond the Lament Configuration

Re: Pale Moon 28/29 localization

Post by New Tobin Paradigm » 2020-03-18, 00:31

No.
Image
- Welcome to the worst nightmare of all... reality! -

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 27292
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Pale Moon 28/29 localization

Post by Moonchild » 2020-03-18, 01:00

Alex654 wrote:
2020-03-18, 00:11
Is it allowed to open issues here about the translations in this case?
Our translations and language packs only target (and only support) our official builds.
If you run into issues on unsupported third party builds of the browser then that's too bad, but we won't accept reports for it.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

User avatar
Alex654
Newbie
Newbie
Posts: 5
Joined: 2019-04-23, 23:58

Re: Pale Moon 28/29 localization

Post by Alex654 » 2020-03-19, 20:34

Checked in official Pale Moon 28.8.4, and the issue is not reproducable. I will submit a bug to author of New Moon then, thanks.

User avatar
JustOff
Localization Coordinator
Localization Coordinator
Posts: 1994
Joined: 2015-09-03, 19:47
Location: UA
Contact:

Re: Pale Moon 28/29 localization

Post by JustOff » 2020-03-20, 21:30

Here is the third beta build that is targeted to the upcoming Pale Moon 29. Based on it, the language packs for Pale Moon 28 will also be updated in a few days, so I ask all contributors to complete the translation as soon as possible. This primarily concerns the Czech, Slovak and Spanish (Argentina) language packs.
2020-03-20_23-14-55.png
Thanks all for feedback and contributions, new participants are always welcomed!
Here are the add-ons I made in a spare time. That was fun!

pietb
Newbie
Newbie
Posts: 3
Joined: 2018-03-12, 14:01

Re: Pale Moon 28/29 localization

Post by pietb » 2020-06-04, 20:59

Latest/current version is 28.9.3. Currently available language packs are all for 28.10 and therefore incompatible with 28.9.3. How/where to get langpacks for 28.9.3? Or is PM 28.10 release around the corner?

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 7538
Joined: 2012-10-09, 19:37
Location: Just beyond the Lament Configuration

Re: Pale Moon 28/29 localization

Post by New Tobin Paradigm » 2020-06-04, 21:11

Yes, language packs for new versions get released ahead a time so the first launch of a new version will pick them up.

All language packs ARE treated like other add-ons on the Add-ons Site so they do have previous versions all the way back to when they were shifted to the Add-ons Site.
Image
- Welcome to the worst nightmare of all... reality! -

pietb
Newbie
Newbie
Posts: 3
Joined: 2018-03-12, 14:01

Re: Pale Moon 28/29 localization

Post by pietb » 2020-06-05, 08:11

New Tobin Paradigm wrote:
2020-06-04, 21:11
All language packs ARE treated like other add-ons on the Add-ons Site so they do have previous versions all the way back to when they were shifted to the Add-ons Site.
Thanks. That saved the digital life of my wife. ;-)

User avatar
JustOff
Localization Coordinator
Localization Coordinator
Posts: 1994
Joined: 2015-09-03, 19:47
Location: UA
Contact:

Re: Pale Moon 28/29 localization

Post by JustOff » 2020-07-30, 16:44

Here is the next beta build that is targeted to the long awaited Pale Moon 29. Please note that several strings were added since the latest release, so the translations require updates. Those translators who have already done this, please check the results using the unstable releases.

2020-07-30_19-32-23.png
:!: Based on the beta build above, the language packs for Pale Moon 28 will also be updated in a few days, so I ask all contributors to complete the translation as soon as possible. This primarily concerns the Chinese Simplified, Czech, Dutch, Polish, Slovak, Spanish (Argentina) and Turkish language packs.

Thanks all for feedback and contributions, new participants are always welcomed!
Here are the add-ons I made in a spare time. That was fun!

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 27292
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Pale Moon 28/29 localization

Post by Moonchild » 2020-07-30, 18:30

Dutch is done.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

User avatar
JustOff
Localization Coordinator
Localization Coordinator
Posts: 1994
Joined: 2015-09-03, 19:47
Location: UA
Contact:

Re: Pale Moon 28/29 localization

Post by JustOff » 2020-07-30, 18:34

Perfect, thank you! Let's hope other translators are as quick as Dutch and Polish 8-)
Here are the add-ons I made in a spare time. That was fun!

User avatar
JustOff
Localization Coordinator
Localization Coordinator
Posts: 1994
Joined: 2015-09-03, 19:47
Location: UA
Contact:

Re: Pale Moon 28/29 localization

Post by JustOff » 2020-08-01, 15:11

:!: Dear translators, I would like to draw your attention once again that direct use of results obtained from automatic translation engines such as Google Translate or similar is unacceptable. You can use machine translation as a guide when working on a translation into a language you speak, but in no other way. It's better to have language packs with untranslated strings than those that are not translated properly.
Here are the add-ons I made in a spare time. That was fun!

User avatar
Behemot
Newbie
Newbie
Posts: 4
Joined: 2020-08-03, 20:56

Re: Pale Moon 28/29 localization

Post by Behemot » 2020-08-03, 21:03

Yo guys think it's like a, wise, to put a language pack compatible with version which is not public yet not only to the website, but into the repository for automatic download by the browser in case of update?

Had to reinstall manually cause the installation on one of my laptops was broken (more like mostly missing, dunno, maybe update went wrong, haven't used it for ages), it did the check for pack automatically. Upon startup, I see it's still english. Checking the pack manually, not compatible with your version! The hell? Its for 28.12! Where do I get that? :wtf:

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 7538
Joined: 2012-10-09, 19:37
Location: Just beyond the Lament Configuration

Re: Pale Moon 28/29 localization

Post by New Tobin Paradigm » 2020-08-03, 22:38

The thing is that we have to put language packs out before release day so that it will be picked up for the new version.

Since all of the versions are marked as minVersion 28.12.0a1 and maxVersion 28.12.* you should NOT have gotten an update for 28.11.0 or older. I just checked and no update is served.. So what are you running?
Image
- Welcome to the worst nightmare of all... reality! -

User avatar
Behemot
Newbie
Newbie
Posts: 4
Joined: 2020-08-03, 20:56

Re: Pale Moon 28/29 localization

Post by Behemot » 2020-08-03, 22:52

Well, somehow happened :wtf: :D

And if I, like, download 28.11 right now and then go to language packs and download current version which states it supports 28.12 only, isn't that broken somehow as well? :geek: I know there are archived as well as beta versions, somewhere, got there once to get pack for unofficial builds based upon some alpha so I had to get the pack for that, but I remember it was hellish to find in after like a year, burried under ton of other things :cry:

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 7538
Joined: 2012-10-09, 19:37
Location: Just beyond the Lament Configuration

Re: Pale Moon 28/29 localization

Post by New Tobin Paradigm » 2020-08-03, 23:22

No it is exactly as it should be as far as not being able to install language packs that are newer than the application. HOWEVER, the rest of your post is an unintelligible mess of thought. Please organize it.
Image
- Welcome to the worst nightmare of all... reality! -

User avatar
loxodont
Astronaut
Astronaut
Posts: 615
Joined: 2014-07-26, 23:03
Location: Mare Serenitatis

Re: Pale Moon 28/29 localization

Post by loxodont » 2020-08-04, 07:38

JustOff wrote:
2020-08-01, 15:11
:!: Dear translators, I would like to draw your attention once again that direct use of results obtained from automatic translation engines such as Google Translate or similar is unacceptable. ...
thx for the information and my excuses (here, again) for touching other translations - I just did not not know the "native-speakers only" rule.
Off-topic:
For the record, my translations were in the first line based on what others already had translated for the language packs, which means by several comparisons of confirmed translations, on a second level compared to the suggestions on crowdin (which I already knew, can't be trusted) and in the two unclear cases of "Enable" in Chinese and Hardverko/u in Romanian(?) PM translations I only looked up in DeepL and Google Translate on a 3rd level check, just to see what they would give me (which ended in no applicable results anyway), so nothing from those machines has made it to the suggestions. Sorry for unnecessarily wasting time - I promise, it will not happen again. :oops:

User avatar
Behemot
Newbie
Newbie
Posts: 4
Joined: 2020-08-03, 20:56

Re: Pale Moon 28/29 localization

Post by Behemot » 2020-08-04, 08:25

New Tobin Paradigm wrote:
2020-08-03, 23:22
No it is exactly as it should be as far as not being able to install language packs that are newer than the application. HOWEVER, the rest of your post is an unintelligible mess of thought. Please organize it.
Simply put, I've never seen something as stupid as having a stable program version listed on the official website and incompatible plugins for the stable program at the same time at the same website. If some user comes now to get the latest PM and than to download the latest language pack for it, IT WON'T WORK TOGETHER! :wtf:

That's just wrong, how can you list LP only compatible with unstable version of the browser? I wonder how many ppl will run away in fear from PM seeing this :crazy:

Post Reply