German language pack is there ...but weird Topic is solved

The l10n of Pale Moon. Rawr.
Quorx
Moon lover
Moon lover
Posts: 85
Joined: 2016-11-28, 16:58
Location: Munich

German language pack is there ...but weird

Unread post by Quorx » 2022-03-18, 17:54

The "de" language pack 30.0.1 for PM 30 seems to fall back on an old, unfinished package or has been only improvised using dictionary translations:

Familiar items have been replaced by linguistically correct, but not common ones, e.g. "add-ons" are now called "Erweiterungen".
Keyboard shortcuts are now often appended in parentheses after menu items – clumsy. "Lesezeichen" became "Einträge aus den Lesezeichen (V)" – much too long and spongy for a menu entry.
It is particularly confusing that in the add-on overview for active add-ons the button says "Deaktiviert" (= disabled) instead of "Deaktivieren" (= disable).
On closer searching, one surely will see more errors.

The description lists the names of the five developers who created the previous language pack which worked absolutely well. I can't believe that even one of them was involved in this new (provisional) language pack.
With this one, Pale Monn is hard to use. For this reason alone I have to postpone the update (before I even face the problems with incompatible themes/extensions).

User avatar
ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2728
Joined: 2012-06-28, 01:20

Re: German language pack is there ...but weird

Unread post by ron_1 » 2022-03-18, 20:26

The issue is known and being worked on. (The search function of the forum website is your friend.)

https://forum.palemoon.org/viewtopic.php?f=30&t=27963#p224841

User avatar
Kand_in_Sky
Moon lover
Moon lover
Posts: 97
Joined: 2013-01-02, 18:22
Location: DE

Re: German language pack is there ...but weird

Unread post by Kand_in_Sky » 2022-03-19, 08:46

Key shortcuts errors language pack German 30.0.1

STRG+C opens print menu instead of copy marked text
STRG+G does nothing (should be print)
STRG+L does nothing (should be add bookmark)
STRG+X works normal (cut marked text)
STRG+Z works normal (reverse last change)

no further testing...
error appears on all my system Win7 + 10 (64-Bit), deactivating the language pack helps and everything is normal then
30.0.1.png
- PM 31.0.0 on 2014 i5-4210M Notebook 8GB Win7 64Bit
- PM 31.0.0 on 2014 Athlon 5350 16GB PC Win7 64Bit
- PM 31.0.0 on 2018 Athlon200GE 32GB PC Win10 64Bit

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 31996
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: German language pack is there ...but weird

Unread post by Moonchild » 2022-03-19, 16:28

Unfortunately this has been a problem due to the structural reorganization of the browser. I had to re-translate from translation memory in CrowdIn on a freshly uploaded batch of source text and although I asked for help getting these verified, apparently the access keys and key combinations ended up being incorrect, apparently. Although I did use the Pale Moon translation memory for matching, apparently it still favoured older translations? That would be a shortcoming of the tool in that case but not something I can really do anything about at this point in time.

If you want to help, please head over to CrowdIn and correct shortcut/access keys in the language packs. You may have to use Chrome or Edge to perform translations since they recently broke a few things in Pale Moon.
It seems like I'm even more on my own than usual in this respect and I honestly only have so much time in a day to do things.
"You will observe with concern how long a useful truth may be known and exist before it is generally received and practiced on." -- Benjamin Franklin
"Compromise and collaboration lie at the heart of all great endeavours" -- Kassandra
Image

Bito_MUC
Moonbather
Moonbather
Posts: 69
Joined: 2015-06-17, 10:03
Location: Munich (Germany)

Re: German language pack is there ...but weird

Unread post by Bito_MUC » 2022-03-19, 16:36

Kand_in_Sky wrote:
2022-03-19, 08:46
Key shortcuts errors language pack German 30.0.1

STRG+C opens print menu instead of copy marked text
STRG+G does nothing (should be print)
STRG+L does nothing (should be add bookmark)
STRG+X works normal (cut marked text)
STRG+Z works normal (reverse last change)
If you have got a backup of the language pack for PM v. 29, then you can take the "good old" menu Items with functioning shortcuts from there and transfer it to the new language pack v. 30.0.1. Normally the file langpack-de@palemoon.org.xpi is found in your PM profile folder/extensions.
Open the xpi (v.29) with e.g. 7zip, go to browser/chrome/de/locale/browser
copy the file browser.dtd from there to the respective folder in langpack-de@palemoon.org.xpi, v. 30.0.1 (strangely, here the path is chrome/de/locale/de/browser)
Safe the changes and close langpack-de@palemoon.org.xpi (v. 30.0.1)
Install the changed langpack-de@palemoon.org.xpi (v. 30.0.1) via the Add-ons window (install from file)
Pale Moon 31.0.0 (64-bit), German locale, on Windows 10 pro (21H2)

Quorx
Moon lover
Moon lover
Posts: 85
Joined: 2016-11-28, 16:58
Location: Munich

Re: German language pack is there ...but weird

Unread post by Quorx » 2022-03-19, 18:06

Ok, that looks like a simple trick, as we are used to from add-on patching "housewife style". But I don't think it's that simple, otherwise the developers would have done it themselves. Presumably, some translations for newly added texts are missing.

However, the creation of the language packs seems ineffective to me: As it stands, already existing translations are not simply used, but everything has to be retranslated. Of course, this makes a lot of work (which would not be necessary at all).
From my experience with .lng files, it is not so easy to translate individual terms if you cannot see in what context they appear in the program.
Off-topic:
@ ron_1:
Yes, I did look for similar topics. But I don't think the issue with the Slovenian lagnuage pack is comparable to this one.

User avatar
loxodont
Astronaut
Astronaut
Posts: 707
Joined: 2014-07-26, 23:03
Location: Mare Serenitatis

Re: German language pack is there ...but weird

Unread post by loxodont » 2022-03-20, 23:09

Sorry for this.
With the new difficulties working on crowdin I was already happy to get the text strings done. I only checked the pre-translated text/labels strings and there was almost nothing to correct, so I didn't check the plenty of acces keys, after I found the first ones were correct and then assumed the others would be also correct and not completely different from 29.x versions.

My bad. For time reasons I would appreciate very much if more german translators would join crowdin and have a look on the (newer) translations. The "history" overview on crowdin might be helpful to find the related files.

User avatar
loxodont
Astronaut
Astronaut
Posts: 707
Joined: 2014-07-26, 23:03
Location: Mare Serenitatis

Re: German language pack is there ...but weird

Unread post by loxodont » 2022-03-21, 14:56

On a closer look on the above example "Einträge für Lesezeichen" in the browser.dtd file on crowdin, I've seen that there are two suggestions listed now as "Pale Moon 100% match", so I assume crowdin just took the newer one and replaced the older "Lesezeichen" from 29.10-de language pack.

A comparison of 29.10-de and 30-de browser.dtd files shows that also most of the old keys assignments have been replaced.

If there's no objection, I'll start to reset with the here mentioned browser.dtd settings to those valid in PM 29.10, later today. Those would be updated with the next language pack build.

struppi
Hobby Astronomer
Hobby Astronomer
Posts: 24
Joined: 2016-11-30, 08:28

Re: German language pack is there ...but weird

Unread post by struppi » 2022-04-27, 07:59

Actually I am not able to install this language pack. I tried some others (like dutch) they work, but after installation of the german language pack I can't choose this with the language switcher.

May it's cause because I first installed the language pack before I installed the switcher?

struppi
Hobby Astronomer
Hobby Astronomer
Posts: 24
Joined: 2016-11-30, 08:28

Re: German language pack is there ...but weird

Unread post by struppi » 2022-04-27, 08:11

Sorry, my fault.

The problem was, that I tried something because the youtube page wasn't loaded anymore, so I guessed it is because of an addOn and I started in the private mode an deactive everything without knowing that this will reset all my settings also in the normal mode. So here the problem was just that the language switcher was deactivated.

Post Reply