Update failed; can't seem to recover now Topic is solved

Users and developers helping users with generic and technical Pale Moon issues on all operating systems.

Moderator: trava90

Forum rules
This board is for technical/general usage questions and troubleshooting for the Pale Moon browser only.
Technical issues and questions not related to the Pale Moon browser should be posted in other boards!
Please keep off-topic and general discussion out of this board, thank you!
User avatar
Posts: 6
Joined: 2018-08-26, 16:21

Update failed; can't seem to recover now

Unread post by iborg » 2021-12-22, 15:59

The other day I tried to update PM to the latest version by responding to the "Update Available" popup that came up while browsing. I had just installed PM a few weeks ago; it was a clean install done after removing the prior PM install (removed .palemoon & moonchild productions directories)
So this update failed for some reason, and now every time I start (or restart) the browser, I get a message saying that the update can't be installed, and to make sure that there is only one instance of PM running (and there is only one instance running):
The update could not be installed. Please make sure there are no other copies of Pale Moon running on your computer, and then restart Pale Moon to try again.
The system shows a pale moon zombie process as well as the normal pale moon process while it's running as well, strange...

Code: Select all

icb@Fussbudget:~/.palemoon> ps -ef|grep pale
icb      16258  2748  8 10:30 ?        00:01:40 /home/icb/.palemoon/palemoon
icb      16259 16258  0 10:30 ?        00:00:00 [palemoon] <defunct>

What would be the best way to deal with this? BTW, the system is OpenSUSE Leap 42.3 running KDE. Thanks,

Troubleshooting info:

Code: Select all

Application Basics

Name: Pale Moon
Version: (64-bit)
Build ID: 20211110234709
Update Channel: release
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Goanna/4.8 Firefox/68.0 PaleMoon/
OS: Linux 4.4.180-102-default
Safe Mode: false


Name: ABPrime
Version: 3.1.7770
Enabled: true
ID: abprime@projects.binaryoutcast.com

Name: GetEmAll!
Version: 1.1
Enabled: true
ID: {4f45ab64-73d7-4bde-b9e6-0922abe8e11a}

Name: Greasemonkey for Pale Moon
Version: 3.31.4
Enabled: true
ID: greasemonkeyforpm@janekptacijarabaci

Name: HTTPS Always
Version: 5.2.26
Enabled: true
ID: https-always@hyperbola.info


Compositing: Basic
GPU Accelerated Windows: 0/1 Basic (OMTC)
Asynchronous Pan/Zoom: none
WebGL 1 Driver WSI Info: GLX 1.4 GLX_VENDOR(client): Mesa Project and SGI GLX_VENDOR(server): SGI Extensions: GLX_ARB_create_context GLX_ARB_create_context_profile GLX_ARB_fbconfig_float GLX_ARB_framebuffer_sRGB GLX_ARB_get_proc_address GLX_ARB_multisample GLX_EXT_import_context GLX_EXT_visual_info GLX_EXT_visual_rating GLX_EXT_fbconfig_packed_float GLX_EXT_framebuffer_sRGB GLX_EXT_create_context_es2_profile GLX_EXT_create_context_es_profile GLX_MESA_copy_sub_buffer GLX_MESA_multithread_makecurrent GLX_MESA_query_renderer GLX_MESA_swap_control GLX_OML_swap_method GLX_OML_sync_control GLX_SGI_make_current_read GLX_SGI_swap_control GLX_SGI_video_sync GLX_SGIS_multisample GLX_SGIX_fbconfig GLX_SGIX_pbuffer GLX_SGIX_visual_select_group GLX_EXT_texture_from_pixmap GLX_INTEL_swap_event
WebGL 1 Driver Renderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) G33
WebGL 1 Driver Version: 2.1 Mesa 17.0.5
WebGL 1 Driver Extensions: GL_ARB_multisample GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_copy_texture GL_EXT_polygon_offset GL_EXT_subtexture GL_EXT_texture_object GL_EXT_vertex_array GL_EXT_compiled_vertex_array GL_EXT_texture GL_EXT_texture3D GL_IBM_rasterpos_clip GL_ARB_point_parameters GL_EXT_draw_range_elements GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_separate_specular_color GL_EXT_texture_edge_clamp GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_ARB_multitexture GL_IBM_multimode_draw_arrays GL_IBM_texture_mirrored_repeat GL_3DFX_texture_compression_FXT1 GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_transpose_matrix GL_EXT_blend_func_separate GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_secondary_color GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_INGR_blend_func_separate GL_NV_blend_square GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_S3_s3tc GL_SUN_multi_draw_arrays GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_EXT_framebuffer_object GL_EXT_texture_compression_s3tc GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_MESA_window_pos GL_NV_packed_depth_stencil GL_NV_texture_rectangle GL_ARB_depth_texture GL_ARB_occlusion_query GL_ARB_shadow GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_window_pos GL_EXT_stencil_two_side GL_EXT_texture_cube_map GL_APPLE_packed_pixels GL_APPLE_vertex_array_object GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_vertex_program GL_ARB_vertex_shader GL_ATI_draw_buffers GL_ATI_texture_env_combine3 GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_MESA_pack_invert GL_MESA_ycbcr_texture GL_ARB_half_float_pixel GL_ARB_point_sprite GL_ARB_shading_language_100 GL_ARB_sync GL_ARB_texture_non_power_of_two GL_ARB_vertex_buffer_object GL_ATI_blend_equation_separate GL_EXT_blend_equation_separate GL_OES_read_format GL_ARB_pixel_buffer_object GL_ARB_texture_rectangle GL_EXT_pixel_buffer_object GL_EXT_texture_compression_dxt1 GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_ARB_framebuffer_object GL_EXT_framebuffer_blit GL_EXT_packed_depth_stencil GL_APPLE_object_purgeable GL_ARB_vertex_array_object GL_ATI_separate_stencil GL_EXT_gpu_program_parameters GL_EXT_texture_sRGB_decode GL_OES_EGL_image GL_ARB_copy_buffer GL_ARB_map_buffer_range GL_ARB_ES2_compatibility GL_ARB_debug_output GL_ARB_draw_elements_base_vertex GL_ARB_explicit_attrib_location GL_ARB_provoking_vertex GL_ARB_sampler_objects GL_EXT_provoking_vertex GL_ARB_get_program_binary GL_ARB_robustness GL_ARB_separate_shader_objects GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ARB_compressed_texture_pixel_storage GL_ARB_internalformat_query GL_ARB_map_buffer_alignment GL_ARB_texture_storage GL_AMD_shader_trinary_minmax GL_ARB_clear_buffer_object GL_ARB_explicit_uniform_location GL_ARB_invalidate_subdata GL_ARB_program_interface_query GL_ARB_vertex_attrib_binding GL_KHR_debug GL_ARB_multi_bind GL_ARB_get_texture_sub_image GL_KHR_context_flush_control
WebGL 1 Extensions: EXT_blend_minmax EXT_frag_depth EXT_texture_filter_anisotropic MOZ_debug_get OES_element_index_uint OES_standard_derivatives OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc MOZ_WEBGL_depth_texture
WebGL 2 Driver WSI Info: -
WebGL 2 Driver Renderer: WebGL creation failed: * Error during native OpenGL init. * Error during native OpenGL init. * Error during native OpenGL init. * Error during native OpenGL init. * Error during native OpenGL init. * Exhausted GL driver caps. * Exhausted GL driver options.
WebGL 2 Driver Version: -
WebGL 2 Driver Extensions: -
WebGL 2 Extensions: -
Hardware H264 Decoding: No
Audio Backend: pulse
GPU #1
Active: Yes
Description: Intel Open Source Technology Center -- Mesa DRI Intel(R) G33
Vendor ID: Intel Open Source Technology Center
Device ID: Mesa DRI Intel(R) G33
Driver Version: 2.1 Mesa 17.0.5

AzureCanvasAccelerated: 0
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
CairoUseXRender: 1
Decision Log
disabled by user: Disabled by pref
unavailable by default: Hardware compositing is disabled

Important Modified Preferences

browser.cache.disk.capacity: 307200
browser.cache.disk.smart_size.first_run: false
browser.download.importedFromSqlite: true
browser.download.useDownloadDir: true
browser.places.smartBookmarksVersion: 4
browser.search.update: false
browser.startup.homepage_override.buildID: 20211110234709
browser.startup.homepage_override.mstone: 4.8.3
browser.tabs.warnOnClose: false
dom.disable_window_move_resize: true
dom.event.contextmenu.enabled: false
general.useragent.updates.lastupdated: 1640129744292
network.cookie.prefsMigrated: true
places.database.lastMaintenance: 1639981963
places.history.expiration.transient_current_max_pages: 80987
privacy.donottrackheader.enabled: true
privacy.sanitize.migrateFx3Prefs: true
services.sync.engine.greasemonkey: true
services.sync.engine.prefs.modified: false
services.sync.lastPing: 1640132908
services.sync.lastSync: Wed Dec 22 2021 10:19:53 GMT-0500 (EST)
services.sync.numClients: 5
storage.vacuum.last.index: 2
storage.vacuum.last.places.sqlite: 1639421908
storage.vacuum.last.queue.sqlite: 1639508306
toolkit.startup.recent_crashes: 1

Important Locked Preferences

Places Database


Incremental GC: true


Activated: false
Prevent Accessibility: 1

Library Versions

Expected minimum version: 4.25
Version in use: 4.25

Expected minimum version: 3.52.2
Version in use: 3.52.2

Expected minimum version: 3.52.2
Version in use: 3.52.2

Expected minimum version: 3.52.2
Version in use: 3.52.2

Expected minimum version: 3.52.2
Version in use: 3.52.2

Board Warrior
Board Warrior
Posts: 1072
Joined: 2012-06-08, 12:14

Re: Update failed; can't seem to recover now

Unread post by Blacklab » 2021-12-22, 22:20

Hi iborg,

I'm not a Linux user at present... maybe again in the near future. :) Anyway, here are a few suggestions:

i) Possible your recent 'clean' reinstall might not have been as clean as you'd hoped? Logic suggests the quickest fix may be another fresh install rather than struggling with recalcitrant updater? Check Moonchild's Windows-based reinstall instructions with a view to your Linux installation: viewtopic.php?f=19&t=662&p=3094. (Could your "pale moon zombie process" just be the failed updater?)

ii) Another possibility is that the 'parent.lock' file ("lock" and ".parentlock" in Linux) in your profile was not deleted when you exited Pale Moon last time... some sort of abnormal shutdown... see: http://kb.mozillazine.org/Profile_in_us ... _lock_file and https://support.mozilla.org/en-US/kb/fi ... responding.

iii) Check your 'directory ownership and permissions' as Moonchild suggests in forum thread Palemoon thinks it's already running when it isn't.: viewtopic.php?f=3&t=25071&p=197728#p197729. Also note in Pale Moon's Linux FAQs 'for the updater to work properly Pale Moon must be extracted to a user-writable location' see: https://linux.palemoon.org/help/faq/#updater.

iv) Search forum for other Linux OS update-related threads e.g: viewtopic.php?f=3&t=24828, viewtopic.php?f=3&t=27309&p=219578, and viewtopic.php?f=3&t=25457&p=201983.

User avatar
Posts: 6
Joined: 2018-08-26, 16:21

Re: Update failed; can't seem to recover now

Unread post by iborg » 2021-12-24, 13:57

Thanks for the reply. A few of these were already looked at, but I'll go over them again and if I can't find anything obvious I'll just reinstall again. Thanks for the link to the other thread btw.

User avatar
Board Warrior
Board Warrior
Posts: 1601
Joined: 2018-06-08, 17:02

Re: Update failed; can't seem to recover now

Unread post by therube » 2021-12-27, 16:06

Perhaps something here, Profile in use.

Not being sure of the ps output, but is <defunct> the parent to palemoon (as in the one spawned the other)?