Music site doesn't play anymore

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderator: trava90

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
Post Reply
User avatar
MRCS4
Apollo supporter
Apollo supporter
Posts: 43
Joined: 2015-06-09, 23:36
Location: Pacific

Music site doesn't play anymore

Post by MRCS4 » 2020-03-27, 13:11

radiotunes.com play button doesn't work (which I pay for). I tried several of the suggestions in the Pornhub thread and they didn't work or I didn't do it quite right. Anybody have any ideas? You don't need a subscription to check it out. Works fine with PM 28.8.4 on my backup and IE11.
"If it ain't broke, don't fix it."
-- unknown

coffeebreak
Moon Magic practitioner
Moon Magic practitioner
Posts: 2186
Joined: 2015-09-26, 04:51
Location: U.S.

Re: Music site doesn't play anymore

Post by coffeebreak » 2020-03-27, 14:36

Confirmed.
Play buttons were inert for PM 28.9.0.2 and Basilisk-2020.03.11, Win 7 x86
Tried some other user agents, which didn't help.

However it did play on PM 28.8.4 (and on FF68 and Chromium).


Error Console, PM 28.9.0.2, new profile:
(1st item was also in console for PM 28.8.4, which played)

Code: Select all

Warning: Media resource data:audio/mpeg;base64,SUQzBAAAAAAAI1RTU0UAAAAPAAADTGF2ZjU2LjQwLjEwMQAAAAAAAAAAAAAA//tUAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAASW5mbwAAAA8AAAACAAABgADAwMDAwMDAwMDAwMDAwMDAwMDAwMDAwMDAwMDAwMDAwMDAwMDAwMDAwMDAwMDAwMDA//////////////////////////////////////////////////////////////////8AAAAATGF2YzU2LjYwAAAAAAAAAAAAAAAAJAAAAAAAAAAAAYDQzVfV//sUZAAP8AAAaQAAAAgAAA0gAAABAAABpAAAACAAADSAAAAETEFNRTMuOTkuNVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVV//sUZB4P8AAAaQAAAAgAAA0gAAABAAABpAAAACAAADSAAAAEVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVV could not be decoded.
Source File: https://www.radiotunes.com/cafedeparis
Line: 0

Error: uncaught exception: undefined

Warning: An unbalanced tree was written using document.write() causing data from the network to be reparsed. For more information https://developer.mozilla.org/en/Optimizing_Your_Pages_for_Speculative_Parsing
Source File: https://tpc.googlesyndication.com/safeframe/1-0-37/html/container.html
Line: 8

User avatar
Cassette
Fanatic
Fanatic
Posts: 239
Joined: 2015-05-08, 14:30
Location: Wichita, KS

Re: Music site doesn't play anymore

Post by Cassette » 2020-03-28, 21:07

coffeebreak wrote:
2020-03-27, 14:36
(1st item was also in console for PM 28.8.4, which played)
I see both items in the console of 28.8.4. PM 28.9.0.2 has a couple of "Error: uncaught exception: undefined" in addition which do not show in 28.8.4.

User avatar
MRCS4
Apollo supporter
Apollo supporter
Posts: 43
Joined: 2015-06-09, 23:36
Location: Pacific

Re: Music site doesn't play anymore

Post by MRCS4 » 2020-04-10, 15:55

Pale Moon 28.9.1 - Music site still doesn't play.
"If it ain't broke, don't fix it."
-- unknown

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 7195
Joined: 2012-10-09, 19:37
Location: Insulting you on the internet.

Re: Music site doesn't play anymore

Post by New Tobin Paradigm » 2020-04-10, 20:23

Why did you expect it to?
Image
- thEre iS No wAY oUt of HErE.. iT'll bE DArK sOON.. -
https://binaryoutcast.com/ | Freenode #binaryoutcast | http://thereisonlyxul.org/

User avatar
MRCS4
Apollo supporter
Apollo supporter
Posts: 43
Joined: 2015-06-09, 23:36
Location: Pacific

Re: Music site doesn't play anymore

Post by MRCS4 » 2020-04-10, 20:57

New Tobin Paradigm wrote:
2020-04-10, 20:23
Why did you expect it to?
I thought it might because we just had an update. And, if they were expecting one of their fixes to fix it, I would be just letting them know that, at least for me, it didn't.
"If it ain't broke, don't fix it."
-- unknown

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 7195
Joined: 2012-10-09, 19:37
Location: Insulting you on the internet.

Re: Music site doesn't play anymore

Post by New Tobin Paradigm » 2020-04-10, 23:17

Well was a cause ever determined? Did the release notes mention it? Did anyone ever say that it would be fixed in X version or next release?

In fact no one has responded in any way that would indicate this has even been looked at by someone doing code. So why did anyone expect it to be magically fixed, hmm?
Image
- thEre iS No wAY oUt of HErE.. iT'll bE DArK sOON.. -
https://binaryoutcast.com/ | Freenode #binaryoutcast | http://thereisonlyxul.org/

rereser
Hobby Astronomer
Hobby Astronomer
Posts: 22
Joined: 2019-08-02, 12:49

Re: Music site doesn't play anymore

Post by rereser » 2020-05-04, 05:46

test done with NM28XP (New Moon) on XP.
last working version:
Saturday, December 21, 2019
Weekly browser binaries (20191221)
NM28XP build:
https://o.rths.ml/palemoon/palemoon-28. ... c-xpmod.7z
radiotunes working. (connecting green bar showing and music auto-plays)

first "broken" version:
Saturday, January 4, 2020
Weekly browser binaries (20200104)
NM28XP build:
https://o.rths.ml/palemoon/palemoon-28. ... 0-xpmod.7z
radiotunes not working. (not connecting or green bar)
error console : Error: uncaught exception: undefined
error not present in 20191221 version.

changes in "broken" version.

Official UXP changes since my last build:
- Issue #1118 Part 1: Split out part of nsDocShell::AddState into a separate method. (027fbae80)
- Issue #1118 Part 2: Allow UpdateURLAndHistory to work even if mOSHE is null, if we're doing a replace. (f5c848aa9)
- Issue #1118 Part 3: Add a public RemoveAllListeners method on EventListenerManager. (80e4577e3)
- Issue #1118 Part 4: Allow UpdateURLAndHistory to work even if there's no root session history. (c1013e912)
- Update README (492624a71)
- Forward to new tree structure. (54091ecab)
- Issue #1118 - Part 5: Change the way document.open() works (dfa7af70c)
- Bug 1341238 - Don't hang on to pointer from temporary NS_LossyConvertUTF16toASCII. (4e6294b24)
- Issue #1118 - Part 6: Fix various tests that are no longer correct. (f71108680)
- Issue #1118 - Part 7: Remove no-longer-used mWillReparent debug code. (b1c7cc07c)
- Issue #1118 - Part 8: Remove no-longer-used mDidDocumentOpen and CheckForOutdatedParent() (e0f0b3492)
- Merge pull request #1334 from g4jc/bug1333 (84f4806b4)
- Issue #1118 - Part 9: Don't allow reuse of unlinked CallbackObjectHolder. (8b8862346)
- Issue #1332 - Backport promise-based media playback (735418fa3)
- Fix typo. (c3ed7420f)
- Merge pull request #1336 from athenian200/html-media-hack (f60bbaf9e)
- Merge pull request #1335 from MoonchildProductions/document_open (357405f63)
- Bug 1176399 - Multiple requests for master password when GMail OAuth2 is enabled. (0395a076c)
- Bug 1453643 - Enable proper retry on oauth2 authenication failure. (a4ab8fd19)
- Bug 1597933 - clean up OAuth2 code: remove responseType which is always code. (3dae851d2)
- Bug 1597933 - improve OAuth2 params parsing. (f532cec97)
- Bug 1597933 - don't pass string constants to determine OAuth refresh token or not. (fd9d39ac9)
- Bug 1597933 - use fetch + URLSearchParms instead of Http.jsm to request OAuth2 access token. (8fdd883f7)
- Bug 1597933 - Use URLSearchParams for setting params for OAuth2 authorization request. (fb7de243f)
- Bug 1599054 - allow callers to ommit sending OAuth2 client_secret parameter. (12eb1554f)
- Merge pull request #1340 from g4jc/mailnews_enhance (26b297510)
My changes since my last build:
- patch from Sami: Lowered mMaxTextureSize from 4096 to 2048 to allow older graphic cards (04671d8d6)
- patch from Sami with pref guard: Enable skipping loop filter and allow non spec compliant speedup tricks. to enable, create new boolean pref "media.ffmpeg.skip_loop_filter" and set it to true. (dd094ae55)
- update NSPR to 4.24 and keep NSPR Bug 1586070 and win64 patch intact. (0b9855b84)
- Update NSS to 3.48 while keeping vc2013 hackfix and no-sslkeylogfile intact. (171849c8e)
- import NSS tip revs: bug1594965, bug1593167, bug1603027, bug1600144, bug1590001, bug1603257, bug1605545, bug1513586 (9778f15c7)

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 26648
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Music site doesn't play anymore

Post by Moonchild » 2020-05-04, 09:52

There is no point in testing with or posting about a non-supported build on a non-supported O.S. -- what you are looking at is not Pale Moon. Nobody here can do anything with it.
If you are using New Moon on XP, please go post wherever you got it from. If you want to help with this topic, please go use an official version on a supported O.S. first.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

User avatar
MRCS4
Apollo supporter
Apollo supporter
Posts: 43
Joined: 2015-06-09, 23:36
Location: Pacific

Re: Music site doesn't play anymore

Post by MRCS4 » 2020-05-04, 12:38

Nice try, rereser. If you can apply any of what you've done to PM 28.9.2.0 Win7 x86, that would be great.
"If it ain't broke, don't fix it."
-- unknown

Post Reply