28.9.0 and YouTube

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderator: trava90

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
User avatar
JoeyG
Lunatic
Lunatic
Posts: 460
Joined: 2017-06-12, 13:27
Location: How can you be in two places at once when you're not anywhere at all?

28.9.0 and YouTube

Post by JoeyG » 2020-03-24, 14:33

With the new PM version, it's the same old YouTube yellow-banner warning.

If anyone's interested, this is the user string I used to get rid of it:

Code: Select all

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:62.0) Gecko/20100101 Firefox/62.0 (Pale Moon)
Pale Moon x64 28.9.3, 29.0.0a3 (portable 2020.05.10), and Basilisk x64 2020.05.08 - all on Win7 SP1 x64 (English). Lenovo S20, Xeon X5670, 12gb RAM. NEC PA272W on Matrox C420. NEC SpectraView 241 and PA241W on Matrox M9120. Thanks to the devs.

groundhog2
Fanatic
Fanatic
Posts: 109
Joined: 2012-08-30, 04:22
Location: USA

Re: 28.9.0 and YouTube

Post by groundhog2 » 2020-03-24, 15:18

My YouTube was actually the new dark theme which I grew used to over the last month or so, and with this update it's back to the old style, which looks outdated now and I actually prefer the new dark version. How do I switch back, is it possible with a UA?

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 26648
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: 28.9.0 and YouTube

Post by Moonchild » 2020-03-24, 15:18

BS. it's fine.
Attachments
FireShot Pro Screen Capture #223 - 'YouTube' - www_youtube_com.jpg
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

User avatar
ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2178
Joined: 2012-06-28, 01:20

Re: 28.9.0 and YouTube

Post by ron_1 » 2020-03-24, 15:25

Moonchild wrote:
2020-03-24, 15:18
it's fine.
I don't get the banner or old layout either. Fine for me too.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 4225
Joined: 2011-10-03, 10:19
Location: Texas, USA

Re: 28.9.0 and YouTube

Post by Night Wing » 2020-03-24, 15:46

Well, I'm getting the banner of "not supporting this browser" in linux along with the old classic look.

So I went into (about:config) and looked up the user agent and this is what it is for YouTube:

Code: Select all

Mozilla/5.0 (%OS_SLICE% rv:60.0) Gecko/20100101 Firefox/60.0 PaleMoon/28.9.0
I haven't the foggiest idea what "%OS-SLICE%" is, but I'm suspecting this is the problem in linux. After I post this message, I'm going over to my old Windows 7 experimental hard drive and see if the problem is there too.
Linux Mint 19.3 (Tricia) Xfce 64 Bit with 64 Bit linux Pale Moon

groundhog2
Fanatic
Fanatic
Posts: 109
Joined: 2012-08-30, 04:22
Location: USA

Re: 28.9.0 and YouTube

Post by groundhog2 » 2020-03-24, 15:53

ron_1 wrote:
2020-03-24, 15:25
Moonchild wrote:
2020-03-24, 15:18
it's fine.
I don't get the banner or old layout either. Fine for me too.
I'm sure you're right, but somehow I'm getting the old layout. I tried various UAs for recent Chrome versions and still nothing. Very strange. Does compatibility with Firefox do anything or does the UA override, uh override that?

User avatar
Kathuluforz
Fanatic
Fanatic
Posts: 229
Joined: 2019-06-13, 13:42
Location: Montana

Re: 28.9.0 and YouTube

Post by Kathuluforz » 2020-03-24, 15:55

I am also experiencing ZERO problems since updating=Perfect.
Off-topic:
BTW @Moonchild, Thank you very much for this update chock full of goodies! OMG how the heck you find the time?! IDK :shock:
*Seriously
Pale Moon 28.9.3 (64) Win7 pro (64)

"People will come to love their oppression, to adore the technologies that undo their capacities to think." ~ Aldous Huxley
"Complete Safety is Illusory" ~ Me

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 4225
Joined: 2011-10-03, 10:19
Location: Texas, USA

Re: 28.9.0 and YouTube

Post by Night Wing » 2020-03-24, 16:00

I'm on my old 64 bit Windows 7 hard drive and I've got the same problem with YouTube with the yellow banner and the update your browser prompt. So checking the user agent for YouTube in about config, I come up with the same odd user agent code which is the same as in 64 bit linux Pale Moon.

Code: Select all

Mozilla/5.0 (%OS_SLICE% rv:60.0) Gecko/20100101 Firefox/60.0 PaleMoon/28.9.0
Since some people are getting the new interface and some of us are not, I'm thinking there is a snafu someplace.
Linux Mint 19.3 (Tricia) Xfce 64 Bit with 64 Bit linux Pale Moon

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 4225
Joined: 2011-10-03, 10:19
Location: Texas, USA

Re: 28.9.0 and YouTube

Post by Night Wing » 2020-03-24, 16:10

I'm back on my 64 bit linux Mint hard drive now.

I would like to ask if anyone is using a 64 bit linux distro, what default user agent are you using to get the new YouTube interface which would also make the yellow banner and "not supporting this banner" prompt disappear?

And I could also use the default user agent code for 64 bit Windows 7 too.
Linux Mint 19.3 (Tricia) Xfce 64 Bit with 64 Bit linux Pale Moon

User avatar
JustOff
Localization Coordinator
Localization Coordinator
Posts: 1952
Joined: 2015-09-03, 19:47
Location: UA
Contact:

Re: 28.9.0 and YouTube

Post by JustOff » 2020-03-24, 16:15

It seems I'm the one who f*cked the things up.
Here are the add-ons I made in a spare time. That was fun!

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 4225
Joined: 2011-10-03, 10:19
Location: Texas, USA

Re: 28.9.0 and YouTube

Post by Night Wing » 2020-03-24, 16:23

JustOff wrote:
2020-03-24, 16:15
It seems I'm the one who f*cked the things up.
Thanks for your heads up. ;)

Now comes the 64 dollar question. Can you fix it?
Linux Mint 19.3 (Tricia) Xfce 64 Bit with 64 Bit linux Pale Moon

User avatar
JustOff
Localization Coordinator
Localization Coordinator
Posts: 1952
Joined: 2015-09-03, 19:47
Location: UA
Contact:

Re: 28.9.0 and YouTube

Post by JustOff » 2020-03-24, 16:30

Well, we have dynamic SSUAO. This should help, I will try to check it now.
Here are the add-ons I made in a spare time. That was fun!

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 4225
Joined: 2011-10-03, 10:19
Location: Texas, USA

Re: 28.9.0 and YouTube

Post by Night Wing » 2020-03-24, 17:03

JustOff wrote:
2020-03-24, 16:30
Well, we have dynamic SSUAO.
What is the above because I understand what that stands for?
Linux Mint 19.3 (Tricia) Xfce 64 Bit with 64 Bit linux Pale Moon

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 26648
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: 28.9.0 and YouTube

Post by Moonchild » 2020-03-24, 17:14

I've dropped a dynamic update in.
Clearing the pref general.useragent.updates.lastupdated -should- trigger a dynamic update.

We'll still need a point release because it obviously does the wrong thing for every Linux OS_SLICE at the moment, but that should take care of youtube.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

User avatar
JoeyG
Lunatic
Lunatic
Posts: 460
Joined: 2017-06-12, 13:27
Location: How can you be in two places at once when you're not anywhere at all?

Re: 28.9.0 and YouTube

Post by JoeyG » 2020-03-24, 17:39

Moonchild wrote:
2020-03-24, 15:18
BS. it's fine.
I guess this was a typo. :roll:
Pale Moon x64 28.9.3, 29.0.0a3 (portable 2020.05.10), and Basilisk x64 2020.05.08 - all on Win7 SP1 x64 (English). Lenovo S20, Xeon X5670, 12gb RAM. NEC PA272W on Matrox C420. NEC SpectraView 241 and PA241W on Matrox M9120. Thanks to the devs.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 26648
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: 28.9.0 and YouTube

Post by Moonchild » 2020-03-24, 17:43

JoeyG wrote:
2020-03-24, 17:39
Moonchild wrote:
2020-03-24, 15:18
BS. it's fine.
I guess this was a typo. :roll:
No it wasn't. It's a linux-only thing.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

groundhog2
Fanatic
Fanatic
Posts: 109
Joined: 2012-08-30, 04:22
Location: USA

Re: 28.9.0 and YouTube

Post by groundhog2 » 2020-03-24, 17:47

I'm on Windows 10, not seeing the yellow banner but instead getting the old layout. Didn't change any settings, just the update. YouTube was using the dark theme before and now I can't figure out what to change to switch back. The old layout works a bit faster, yes, but I visually prefer the new.

User avatar
LAR Grizzly
Fanatic
Fanatic
Posts: 195
Joined: 2017-08-11, 16:49
Location: Ohio, USA
Contact:

Re: 28.9.0 and YouTube

Post by LAR Grizzly » 2020-03-24, 17:56

I'm on Win7 and I'm getting the old page layout along with the banner.
Win7 Pro SP1 64 Bit
Comodo Internet Security
Pale Moon 28.9.3, Interlink Mail 52.9.7433, Firefox 52.9.0esr, Thunderbird 52.9.1 and SeaMonkey 2.48

User avatar
JoeyG
Lunatic
Lunatic
Posts: 460
Joined: 2017-06-12, 13:27
Location: How can you be in two places at once when you're not anywhere at all?

Re: 28.9.0 and YouTube

Post by JoeyG » 2020-03-24, 18:19

Moonchild wrote:
2020-03-24, 17:43
JoeyG wrote:
2020-03-24, 17:39
Moonchild wrote:
2020-03-24, 15:18
BS. it's fine.
I guess this was a typo. :roll:
No it wasn't. It's a linux-only thing.
LAR Grizzly wrote:
2020-03-24, 17:56
I'm on Win7 and I'm getting the old page layout along with the banner.
Apparently at least one other Win 7 user experienced the same thing I did.
Last edited by JoeyG on 2020-03-24, 18:35, edited 1 time in total.
Pale Moon x64 28.9.3, 29.0.0a3 (portable 2020.05.10), and Basilisk x64 2020.05.08 - all on Win7 SP1 x64 (English). Lenovo S20, Xeon X5670, 12gb RAM. NEC PA272W on Matrox C420. NEC SpectraView 241 and PA241W on Matrox M9120. Thanks to the devs.

User avatar
ky331
Moongazer
Moongazer
Posts: 11
Joined: 2018-08-16, 18:44

Re: 28.9.0 and YouTube

Post by ky331 » 2020-03-24, 18:21

I encountered the yellow banner on Youtube, on my (32-bit) Win8.1 HP Stream7 tablet. Additionally, Yahoo Mail forced me back to "classic" mail from the modern/enhanced version.

(In contrast, everything is working normally on my (64-bit) Win10 system [on which I'm running 32-bit PaleMoon].)

Post Reply