Mouser.com parametric search 100% broken in Pale Moon Topic is solved

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderators: trava90, satrow

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
Post Reply
User avatar
hackkitten
Moongazer
Moongazer
Posts: 7
Joined: 2019-03-26, 23:03

Mouser.com parametric search 100% broken in Pale Moon

Post by hackkitten » 2019-11-12, 18:44

For the past months now, attempting to do a parametric search on the Mouser site (using the filters in a category to narrow down the number of components shown) always results in an error page with "An unexpected error has occurred." as the title. Mouser support has shown no interest in the issue, ergo I'm opening a topic here.

This functionality used to work in PM. These days it only works in other browsers, including the Internet Explorer in Windows 7.

User avatar
adesh
Keeps coming back
Keeps coming back
Posts: 801
Joined: 2017-06-06, 07:38

Re: Mouser.com parametric search 100% broken in Pale Moon

Post by adesh » 2019-11-12, 18:52

Works for me! I selected a category from the left side bar and then entered something in the search box, hit Enter and I got some 10,000 results.

Pale Moon 28.7.2 on Linux

Sessh
Moonbather
Moonbather
Posts: 73
Joined: 2018-01-11, 18:43

Re: Mouser.com parametric search 100% broken in Pale Moon

Post by Sessh » 2019-11-12, 19:37

Site seems fine to me as well. However, if I don't select my location in that annoying overlay or try to add filters to uBlock to block those elements, the site acts like I don't have js installed and won't let me get out of the notification screen. Reverting those actions solves the issue, though. Even getting rid of it with the "Dismiss the overlay" add-on causes those issues if I do it enough times. That doesn't seem to be the issue you're describing, though.

If I affirm my VPN location, the site seems to work just fine though. I hate sites that force you to disclose your location just to use their site. Also using version 28.7.2 64-bit for Windows.

Edit: If I block cookies, I can reproduce your issue. Do you have some sort of cookie blocking in place? That site does not like it at all if I restrict cookie interaction. I get the "An error has occurred" or I get that screen that checks the browser for js and won't proceed until I enable cookies, return back to the page I did the search from, reload that page and then the search seems to work fine.

User avatar
hackkitten
Moongazer
Moongazer
Posts: 7
Joined: 2019-03-26, 23:03

Re: Mouser.com parametric search 100% broken in Pale Moon

Post by hackkitten » 2019-11-12, 20:49

I am using uBlock Origin, which may block cookies? I also block much of the JavaScript with uBlock Origin (most third-party URLs), but when I disable uBlock Origin on Mouser, it still fails to work.

Say, I go to this category: https://eu.mouser.com/Connectors/Headers-Wire-Housings/

When I then try to filter on 40 positions, 2 rows and then hit the apply filters button, I get the error. I cannot quite figure out how this would even happen, as when I use UBO to completely block all JavaScript on Mouser, I still get the error. It's rather frustrating and I'm not sure where to look at this point.

I should also note that I'm getting this error across two systems, one a Windows 7-based PC and one a Windows 10 laptop (fresh install earlier this year).

coffeebreak
Moon Magic practitioner
Moon Magic practitioner
Posts: 2031
Joined: 2015-09-26, 04:51
Location: U.S.

Re: Mouser.com parametric search 100% broken in Pale Moon

Post by coffeebreak » 2019-11-12, 21:49

Searching and filtering work fine for me too.
hackkitten wrote:
2019-11-12, 20:49
I am using uBlock Origin, which may block cookies?
No, uBO does not block cookies.

Check your cookie settings under Preferences -> Privacy -> History tab.
And you might try the site in safe mode to see if one or more of your extensions is causing the problem.
(Help -> Restart in Safe Mode... , then follow the prompts)

ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2111
Joined: 2012-06-28, 01:20

Re: Mouser.com parametric search 100% broken in Pale Moon

Post by ron_1 » 2019-11-12, 23:26

I'd suggest trying it in a new profile; even in safe mode extensions can still mess things up.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25409
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Mouser.com parametric search 100% broken in Pale Moon

Post by Moonchild » 2019-11-13, 00:06

If it's a cookie problem and they were previously blocked, confusing the state on the site, then try first to clear your cookies before going for a whole new profile.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
hackkitten
Moongazer
Moongazer
Posts: 7
Joined: 2019-03-26, 23:03

Re: Mouser.com parametric search 100% broken in Pale Moon

Post by hackkitten » 2019-11-13, 12:00

Okay, I cleared all Mouser cookies and things seem to be working again now.

Not sure which of the cookies was a problem, but I guess it remains a good first (or second) step in troubleshooting such issues.

Much obliged, everyone :)

Post Reply