DeviantArt - New UA overrides needed

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderators: trava90, satrow

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
User avatar
Tomaso
Board Warrior
Board Warrior
Posts: 1264
Joined: 2015-07-23, 16:09
Location: Norway

DeviantArt - New UA overrides needed

Unread post by Tomaso » 2019-07-03, 14:24

Pale Moon v28.6.0 now gets served a new interface @ https://www.deviantart.com/, and it performs terriby!
By tweaking the existing UA overrides (for deviantart.com and deviantart.net), the old interface gets restored.
This is what I used:

Code: Select all

Mozilla/5.0 (Windows NT 6.3; rv:52.0) Gecko/20100101 Firefox/52.0

Octopuss
Lunatic
Lunatic
Posts: 490
Joined: 2015-01-26, 13:58

Re: DeviantArt - New UA overrides needed

Unread post by Octopuss » 2019-07-03, 15:17

It stil looks the same as in previous versions to me.
Can you provide a screenshot of the supposedly old interface?

User avatar
Isengrim
Keeps coming back
Keeps coming back
Posts: 916
Joined: 2015-09-08, 22:54
Location: 127.0.0.1
Contact:

Re: DeviantArt - New UA overrides needed

Unread post by Isengrim » 2019-07-03, 15:19

They've been A/B testing it for a while, and I've gotten it on occasion. The new UI is much darker, more bloated, less performant, and some functions appear broken.
Linux Mint 19.2 Cinnamon (64-bit), Windows 7 (64-bit), Windows 10 build 1803 (64-bit)
JavaScript is not Java
"As long as there is someone who will appreciate the work involved in the creation, the effort is time well spent." ~ Tetsuzou Kamadani, Cave Story

User avatar
Tomaso
Board Warrior
Board Warrior
Posts: 1264
Joined: 2015-07-23, 16:09
Location: Norway

Re: DeviantArt - New UA overrides needed

Unread post by Tomaso » 2019-07-03, 15:34

Looks like you're right, Isengrim.
I get the old interface again now, without having to modify the UA overrides.

Wonder what the hell webmasters are thinking these days?
Has anyone EVER seen an example of a UA change actually being an improvement?
Why do they always have to turn things into bloated crap!?

User avatar
Isengrim
Keeps coming back
Keeps coming back
Posts: 916
Joined: 2015-09-08, 22:54
Location: 127.0.0.1
Contact:

Re: DeviantArt - New UA overrides needed

Unread post by Isengrim » 2019-07-03, 16:28

Tomaso wrote:
2019-07-03, 15:34
Why do they always have to turn things into bloated crap!?
Because it's The Future!
Linux Mint 19.2 Cinnamon (64-bit), Windows 7 (64-bit), Windows 10 build 1803 (64-bit)
JavaScript is not Java
"As long as there is someone who will appreciate the work involved in the creation, the effort is time well spent." ~ Tetsuzou Kamadani, Cave Story

yereverluvinuncleber
Fanatic
Fanatic
Posts: 241
Joined: 2017-12-06, 21:25

Re: DeviantArt - New UA overrides needed

Unread post by yereverluvinuncleber » 2019-07-03, 18:55

I'm not seeing it and I'm not using any overrides. All looks normal to me.
My skills technical and otherwise: VMS system manager 20 years. Fault Tolerance, clustering, Vax, Alpha and ftSparc. DCL, Javascript, VB6, PHP programming. Graphic Design, Technical Project Management, CMS Web Design. DOS and Windows admin since inception. Quad Audio Electronics update and repair. Rebuilding classic cars and motorcycles. Artist in watercolours. Historian. There's more.

User avatar
Utnapishtim
Moonbather
Moonbather
Posts: 64
Joined: 2018-07-12, 02:42

Re: DeviantArt - New UA overrides needed

Unread post by Utnapishtim » 2019-07-03, 21:19

I'm getting something weird on there with eMatrix. If I have all scripts disabled and all CSS and images enabled except wixmp.com images I get a green page, but if I enable wixmp.com images only (no CSS) it switches to a black background with a different layout. I wonder how is that possible without CSS?

User avatar
Tomaso
Board Warrior
Board Warrior
Posts: 1264
Joined: 2015-07-23, 16:09
Location: Norway

Re: DeviantArt - New UA overrides needed

Unread post by Tomaso » 2019-07-03, 22:52

I'm getting the nasty new interface again now, and the UA overrides which I posted before does nothing to prevent it!
The fact that I got the old interface back, after adding those overrides earlier, must indeed have been by pure coincidence.

--

EDIT:
In their new UI, all elements seems to use dynamic IDs too, making annoyances very difficult (if not impossible) to block!
:(

User avatar
Utnapishtim
Moonbather
Moonbather
Posts: 64
Joined: 2018-07-12, 02:42

Re: DeviantArt - New UA overrides needed

Unread post by Utnapishtim » 2019-07-04, 04:08

Tomaso wrote:
2019-07-03, 22:52
In their new UI, all elements seems to use dynamic IDs too, making annoyances very difficult (if not impossible) to block!
:(
If you're using Stylem or a similar addon you can use nth-child notation, for example:

Code: Select all

#post_content170084 > div:nth-child(4) { display: none }
Edit:
You can get it from the Inspect Element box by right clicking the element and selecting Copy > CSS Selector.

Post Reply