Washington Post detects as "Private"

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderators: trava90, satrow

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
User avatar
[TMac]
Hobby Astronomer
Hobby Astronomer
Posts: 16
Joined: 2019-06-29, 21:18

Washington Post detects as "Private"

Post by [TMac] » 2019-07-02, 12:07

Any articles on the Washington Post claim I'm using Private Mode and won't let me view. I have this problem on two different computers, with Pale Moon only. What might be causing it? E.g. https://www.washingtonpost.com/world/20 ... -pray-rain

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25409
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Washington Post detects as "Private"

Post by Moonchild » 2019-07-02, 12:55

The Washington Post does a lot of things wrong with browser detection and their team responsible for such things take literally months to reply.
I'm afraid there's little you can do but complain and be patient.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
billmcct
Astronaut
Astronaut
Posts: 672
Joined: 2012-09-04, 15:19
Location: Atlanta Georgia USA

Re: Washington Post detects as "Private"

Post by billmcct » 2019-07-02, 13:13

Install this add-on, click button to dismiss the private browsing warning.
https://addons.palemoon.org/addon/behin ... verlay-me/
Windows 8.1 (x64) - Current Pale Moon Release (x86)

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 6488
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: Washington Post detects as "Private"

Post by New Tobin Paradigm » 2019-07-02, 13:31

Off-topic:
Moonchild wrote:
2019-07-02, 12:55
The Washington Post does a lot of things wrong
Yes. Yes they do.

coffeebreak
Moon Magic practitioner
Moon Magic practitioner
Posts: 2031
Joined: 2015-09-26, 04:51
Location: U.S.

Re: Washington Post detects as "Private"

Post by coffeebreak » 2019-07-02, 13:42

No "private browsing" warning here when the browser uses Native user agent mode.
However this only seems to work if the setting is global: making an override for Washington Post with the native UA doesn't similarly work.

User avatar
adesh
Keeps coming back
Keeps coming back
Posts: 801
Joined: 2017-06-06, 07:38

Re: Washington Post detects as "Private"

Post by adesh » 2019-07-02, 13:58

A website should not be able to detect private browsing mode. Making guesses on part of the site is fine but if a browser happily tells about the current mode, I'd consider that a serious issue.

But what do the websites want to accomplish with that? How does it matter whether I'm at my work desk or sitting in a lawn chair?

User avatar
gepus
Lunatic
Lunatic
Posts: 386
Joined: 2017-12-14, 12:59

Re: Washington Post detects as "Private"

Post by gepus » 2019-07-02, 15:50

adesh wrote:
2019-07-02, 13:58
A website should not be able to detect private browsing mode.
Fully agreed.

BTW, I assume that other browsers have the same shortcoming if not in native mode.

User avatar
Isengrim
Board Warrior
Board Warrior
Posts: 1039
Joined: 2015-09-08, 22:54
Location: 127.0.0.1
Contact:

Re: Washington Post detects as "Private"

Post by Isengrim » 2019-07-02, 17:32

adesh wrote:
2019-07-02, 13:58
Making guesses on part of the site is fine but if a browser happily tells about the current mode, I'd consider that a serious issue.
Pale Moon certainly doesn't advertise it, and I doubt any other browsers do either. There's no standard for sharing that kind of information with websites.
gepus wrote:
2019-07-02, 15:50
BTW, I assume that other browsers have the same shortcoming if not in native mode.
They do, or used to.
Linux Mint 19.2 Cinnamon (64-bit), Windows 7 (64-bit), Windows 10 build 1803 (64-bit)
"As long as there is someone who will appreciate the work involved in the creation, the effort is time well spent." ~ Tetsuzou Kamadani, Cave Story

User avatar
nicolaasjan
Hobby Astronomer
Hobby Astronomer
Posts: 24
Joined: 2017-07-28, 14:44
Location: The Netherlands

Re: Washington Post detects as "Private"

Post by nicolaasjan » 2019-07-02, 18:48

You can get rid of this nonsense by using uBlock Origin and add the following line in the "My Filters" section:

Code: Select all

washingtonpost.com##^script:has-text(Turn off private browsing)
and hit "Apply changes"

I had the same warning and I don't even use private mode...

[Edit]
How to install uBlock Origin in Pale Moon
Linux Mint 19.3 Mate 64bit
Pale Moon latest

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25409
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Washington Post detects as "Private"

Post by Moonchild » 2019-07-02, 21:02

For the record, the "guess" about private browsing mode is usually because they want to use certain types of in-browser storage that are generally disabled in private browsing/incognito modes. These sites rely on being able to use those feature for proper operation. Just hiding the warning will likely not fix the issue if it's caused by your settings.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
[TMac]
Hobby Astronomer
Hobby Astronomer
Posts: 16
Joined: 2019-06-29, 21:18

Re: Washington Post detects as "Private"

Post by [TMac] » 2019-07-02, 23:54

I haven't had this problem with other sites, but I haven't used Pale Moon for long. In Chrome, sites detect Private Browsing by looking for a form of storage, which isn't implemented in incognito mode. But I wasn't browsing WaPo in Private mode, so I'm guessing it was looking at the user agent and tried something based on it, which failed.

Changing the user agent solved it, but of course changes it for everything. Any chance of a per-site setting for that, must as for cookies?

They use privacy detection because they want persistent cookies and tracking, to count your visits for the paywall kick-in and to be able to better monetize you. But, again, I wasn't in private mode.

Frasier
Fanatic
Fanatic
Posts: 245
Joined: 2014-05-07, 02:44
Location: Indiana

Re: Washington Post detects as "Private"

Post by Frasier » 2019-07-03, 04:28

[TMac] wrote:
2019-07-02, 23:54
Any chance of a per-site setting for that, must as for cookies?
Yes, In 'about:config'
In the preferences window, right-click, from the menu select the 'New' option.
In the sub-menu select the 'String' option.
general-override.png
general-override.png (75.21 KiB) Viewed 892 times
For the requested preference name, enter:

Code: Select all

general.useragent.override.washingtonpost.com
override-string_entry.png
Press 'OK'.
for the string value enter:

Code: Select all

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.9) Goanna/4.3 PaleMoon/28.6.0
Press 'OK'. Close 'about:config'

User avatar
JoeyG
Lunatic
Lunatic
Posts: 370
Joined: 2017-06-12, 13:27
Location: How can you be in two places at once when you're not anywhere at all?

Re: Washington Post detects as "Private"

Post by JoeyG » 2019-07-03, 10:47

Frasier wrote:Yes, In 'about:config' ...
This didn't work for me. Adding the filter to UBlock Origin (mentioned above) did.

In any case, thanks to both posters.
Bye-bye Firefox.
---------------------
Pale Moon x64 28.8.1, 28.9.0a1 (portable 2020.01.14), and Basilisk x64 2020.01.12 on Win7 SP1 x64 (English). Lenovo S20, Xeon X5670, 12gb RAM. NEC PA272W on Matrox C420. NEC SpectraView 241 and PA241W on Matrox M9120. Thanks to the devs.

coffeebreak
Moon Magic practitioner
Moon Magic practitioner
Posts: 2031
Joined: 2015-09-26, 04:51
Location: U.S.

Re: Washington Post detects as "Private"

Post by coffeebreak » 2019-07-03, 11:44

Frasier wrote:
2019-07-03, 04:28
Yes, In 'about:config'
coffeebreak wrote:
2019-07-02, 13:42
this only seems to work if the setting is global: making an override for Washington Post with the native UA doesn't similarly work.

coffeebreak
Moon Magic practitioner
Moon Magic practitioner
Posts: 2031
Joined: 2015-09-26, 04:51
Location: U.S.

Re: Washington Post detects as "Private"

Post by coffeebreak » 2019-07-03, 11:46

[TMac] wrote:
2019-07-02, 23:54
Any chance of a per-site setting for that
A current or recent Chrome user agent does seem to work per/site (surprise).


Here's what I used (indicates W7 x86). Or use an example from a site such as here.

Code: Select all

Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.100 Safari/537.36

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25409
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Washington Post detects as "Private"

Post by Moonchild » 2019-07-03, 12:35

this only seems to work if the setting is global
In that case you'll have to investigate what other domains washingtonpost uses on their site because it will require an override for an external domain (not the root domain you are visiting).
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

coffeebreak
Moon Magic practitioner
Moon Magic practitioner
Posts: 2031
Joined: 2015-09-26, 04:51
Location: U.S.

Re: Washington Post detects as "Private"

Post by coffeebreak » 2019-07-07, 06:44

Update:
The native user agent for PM 28.6.0.1 works as a site-specific UA override for washingtonpost.com
(at least it works for me).

It seems to really be the string that does it, not the update itself, because the 28.6.0.1 string works also in PM 28.5.2, whose own native string still only works for me as a global UA override, not as site-specific.

User avatar
Isengrim
Board Warrior
Board Warrior
Posts: 1039
Joined: 2015-09-08, 22:54
Location: 127.0.0.1
Contact:

Re: Washington Post detects as "Private"

Post by Isengrim » 2019-07-07, 12:27

coffeebreak wrote:
2019-07-07, 06:44
Update:
The native user agent for PM 28.6.0.1 works as a site-specific UA override for washingtonpost.com
(at least it works for me).
This works for me as well. I bet their Private Browsing detection is relying on specific components of the user agent.
Linux Mint 19.2 Cinnamon (64-bit), Windows 7 (64-bit), Windows 10 build 1803 (64-bit)
"As long as there is someone who will appreciate the work involved in the creation, the effort is time well spent." ~ Tetsuzou Kamadani, Cave Story

User avatar
[TMac]
Hobby Astronomer
Hobby Astronomer
Posts: 16
Joined: 2019-06-29, 21:18

Re: Washington Post detects as "Private"

Post by [TMac] » 2019-07-08, 02:28

Where do I configure site-specific user agent strings? It's not in about:permissions, where other site-specific values seem to be.

coffeebreak
Moon Magic practitioner
Moon Magic practitioner
Posts: 2031
Joined: 2015-09-26, 04:51
Location: U.S.

Re: Washington Post detects as "Private"

Post by coffeebreak » 2019-07-08, 02:32

[TMac] wrote:
2019-07-08, 02:28
Where do I configure site-specific user agent strings?
In about:config .
See Frasier's post for how to do it, adjusting the string for 28.6.0.1.

Post Reply