HughesNet and issue with TLS 1.2

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderators: trava90, satrow

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
Post Reply
Sylvermoon
Hobby Astronomer
Hobby Astronomer
Posts: 23
Joined: 2017-11-09, 01:30

HughesNet and issue with TLS 1.2

Post by Sylvermoon » 2019-06-28, 21:42

I just moved to HughesNet from Wildblue. When logging into my account on the hughesnet.com site I get a dialog with the following message:

Attention. You are currently using a version of Mozilla Firefox that does not support the latest security protocols. Soon, Hughes will stop supporting secure transactions that do not use the latest security protocol (TLS 1.2).

It was my impression that Pale Moon IS using TLS 1.2? This is Pale Moon 28.5.2, on Windows 10. HughesNet is the only site (including all my financial sites) where I get this sort of message.

Anything I can do to make Pale Moon look "right" to HughesNet? I honestly don't miss Firefox, and am not interested in keeping it around and updated for one specific site.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25004
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: HughesNet and issue with TLS 1.2

Post by Moonchild » 2019-06-29, 01:34

Pale Moon fully supports TLS 1.2 (and 1.3!). The message you are seeing is because of woeful misdetection of Pale Moon by their website (most likely useragent sniffing on the rv: part which is our Goanna version, that might make them think you are using Firefox 4...). I suggest you report it to them so they can fix it.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

Sylvermoon
Hobby Astronomer
Hobby Astronomer
Posts: 23
Joined: 2017-11-09, 01:30

Re: HughesNet and issue with TLS 1.2

Post by Sylvermoon » 2019-06-29, 01:59

Thanks Moonchild. I'll send up a ticket there. So far, they've been pretty responsive....

Sylvermoon
Hobby Astronomer
Hobby Astronomer
Posts: 23
Joined: 2017-11-09, 01:30

Re: HughesNet and issue with TLS 1.2

Post by Sylvermoon » 2019-07-30, 22:42

Well.... all this time, talking to various people about this, with no results - and now they want to send an on-site tech rep to mess with my computer, and charge me $100 US!

Is there a general.useragent.override line I could add that would obviate this issue?

Post Reply