Cannot play video

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderators: trava90, satrow

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
User avatar
back2themoon
Board Warrior
Board Warrior
Posts: 1425
Joined: 2012-08-19, 20:32

Cannot play video

Unread post by back2themoon » 2019-02-07, 17:14

Hello everyone, could you please try this page? There's a video right on top of the page. Tried everything I could (including Safe Mode, Content/Video options and a clean PM Portable profile) but no luck. The "Play" triangle appears for an instant in the middle of the video thumbnail, but disappears immediately.
Error Console.png
Safe Mode / clean profile info: Help/Restart in Safe Mode
Information to include when asking for support - How to apply user agent overrides
How to download videos

Windows 10 Pro • Pale Moon x64 • Interlink x86 • Emsisoft Anti-Malware

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3953
Joined: 2011-10-03, 10:19
Location: Texas, USA

Re: Cannot play video

Unread post by Night Wing » 2019-02-07, 17:30

The play triangle disappears for me too even after disabling uBlock Origin.

I'm using 64 bit linux Pale Moon 28.3.1 running in 64 bit linux Mint 19.1 (Tessa) Xfce. User agent is Firefox Compatibility mode.
Linux Mint 19.2 (Tina) Xfce 64 Bit (Default Distribution OS) with 64 Bit linux Pale Moon
Windows 7 Home Premium & Ultimate SP1, 64 Bit (Backup OS) with 32 Bit windows Pale Moon

User avatar
badnick
Lunatic
Lunatic
Posts: 393
Joined: 2017-03-23, 19:56

Re: Cannot play video

Unread post by badnick » 2019-02-07, 17:57

Work for me: right click on the video and from the drop down menu select play and the video plays in the page but there are no control buttons. Or you can chose "view video " option and the Video is open in it's own window with full controls. It works with adblockers enabled (uBO and Disconnect in my case.
Windows 10 /64 (version 1809)
PM last/64

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3953
Joined: 2011-10-03, 10:19
Location: Texas, USA

Re: Cannot play video

Unread post by Night Wing » 2019-02-07, 18:08

badnick wrote:Work for me: right click on the video and from the drop down menu select play and the video plays in the page but there are no control buttons. Or you can chose "view video " option and the Video is open in it's own window with full controls. It works with adblockers enabled (uBO and Disconnect in my case.
Your comments above are correct.
Linux Mint 19.2 (Tina) Xfce 64 Bit (Default Distribution OS) with 64 Bit linux Pale Moon
Windows 7 Home Premium & Ultimate SP1, 64 Bit (Backup OS) with 32 Bit windows Pale Moon

User avatar
back2themoon
Board Warrior
Board Warrior
Posts: 1425
Joined: 2012-08-19, 20:32

Re: Cannot play video

Unread post by back2themoon » 2019-02-07, 18:29

badnick wrote:Work for me: right click on the video and from the drop down menu select play and the video plays in the page but there are no control buttons. Or you can chose "view video " option and the Video is open in it's own window with full controls. It works with adblockers enabled (uBO and Disconnect in my case.
Interesting, thanks. Not sure why this is required. Right-clicking, also reveals a "Show Controls" option which works (no need for own window). It's good enough. Not sure if it's supposed to work this way (I'm guessing it's not), but I'll mark it solved.
Safe Mode / clean profile info: Help/Restart in Safe Mode
Information to include when asking for support - How to apply user agent overrides
How to download videos

Windows 10 Pro • Pale Moon x64 • Interlink x86 • Emsisoft Anti-Malware

User avatar
back2themoon
Board Warrior
Board Warrior
Posts: 1425
Joined: 2012-08-19, 20:32

Re: Cannot play video

Unread post by back2themoon » 2019-07-02, 08:45

Back at this website, because for some reason it only serves Pale Moon the low-quality version of their videos (416x224) instead of the higher one (1024x576). Here is an example. (you need to right-click to play and show controls, see earlier posts)

I tried changing the Content/Video settings and the user agent with no result.
Safe Mode / clean profile info: Help/Restart in Safe Mode
Information to include when asking for support - How to apply user agent overrides
How to download videos

Windows 10 Pro • Pale Moon x64 • Interlink x86 • Emsisoft Anti-Malware

Goodydino
Lunatic
Lunatic
Posts: 497
Joined: 2017-10-10, 21:20

Re: Cannot play video

Unread post by Goodydino » 2019-07-02, 20:19

That page seems to depend on the absence of Disconnect and the presence of cookies. If I disabled Disconnect and enabled session cookies, I got the "View video" item in the context menu, and could play the video. Having Disconnect enabled and/or no cookies, the "View video" did not appear in the context menu.

User avatar
back2themoon
Board Warrior
Board Warrior
Posts: 1425
Joined: 2012-08-19, 20:32

Re: Cannot play video

Unread post by back2themoon » 2019-07-02, 20:43

Thanks, but context menu entries were never a problem. The only remaining issue seems to be the stream's quality. Currently, only the low-res version is available.
Safe Mode / clean profile info: Help/Restart in Safe Mode
Information to include when asking for support - How to apply user agent overrides
How to download videos

Windows 10 Pro • Pale Moon x64 • Interlink x86 • Emsisoft Anti-Malware

Post Reply