Problem with site styles

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderators: trava90, satrow

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
Post Reply
Alexium 67
Fanatic
Fanatic
Posts: 101
Joined: 2015-07-13, 10:34
Location: Russia

Problem with site styles

Post by Alexium 67 » 2018-12-24, 08:09

I posted already same topic in the Russian forum section, but found no any worked advice. So I ask international community to help me resolve one issue. This is our local special site for some state services - gosuslugi.ru. Some time (often) on my home Pale Moons (two PC) site not working. Issue with login page - all elements that must be hidden are visible, all buttons not working. But some times it start to work fine. It very important site for our family, so I decide to use IE11 for it. But I want to use Pale moon as my preferred browser. In same time other browsers display that login page correct way: including FF60+, IE11 and... PM28.2.2 x32 (!) at my work.

I tried all what I can. Changing UA, some other js tricks, clearing browser cache, clear profile, safe mode. I think it is Pale Moon problem. Yes, I know this is site problem that it orientated only to mainstream browsers. But...

May I somehow to help myself to resolve this issue? Collect some data? Logs?

I found only one thing - if the site work fine then there are lesser errors in console.

System specs: Windows 10 & 7, Pale Moon 28.2.2 x64.

Thanks.

If you need help to navigate site (it non-translated to English), ask me. I'll post screenshots

Here is one of console logs:

Code: Select all

Таблица стилей https://esia.gosuslugi.ru/idp/resources/css/disclaimer.css?1539181184000 не была загружена, потому что её MIME-тип («application/javascript») не «text/css». AuthnEngine
Таблица стилей https://esia.gosuslugi.ru/idp/resources/css/teaser.css?1539181184000 не была загружена, потому что её MIME-тип («application/javascript») не «text/css».  AuthnEngine
TypeError: $.widget is not a function[Подробнее]  prime-ui-0.8-min.js:22:17
downloadable font: Failed to convert WOFF 2.0 font to SFNT (font-family: "als_ekibastuz_bold" style:normal weight:normal stretch:normal src index:1) source: https://esia.gosuslugi.ru/idp/resources/fonts/als_ekibastuz_bold-webfont.woff2  base-page.css:13:12
downloadable font: rejected by sanitizer (font-family: "als_ekibastuz_bold" style:normal weight:normal stretch:normal src index:1) source: https://esia.gosuslugi.ru/idp/resources/fonts/als_ekibastuz_bold-webfont.woff2  base-page.css:13:12
downloadable font: Failed to convert WOFF 2.0 font to SFNT (font-family: "helveticaneuecyr" style:normal weight:normal stretch:normal src index:1) source: https://esia.gosuslugi.ru/idp/resources/fonts/helveticaneuecyr-roman-webfont.woff2  base-page.css:25:12
downloadable font: rejected by sanitizer (font-family: "helveticaneuecyr" style:normal weight:normal stretch:normal src index:1) source: https://esia.gosuslugi.ru/idp/resources/fonts/helveticaneuecyr-roman-webfont.woff2  base-page.css:25:12
Метод getPreventDefault() является устаревшим. Для его замены используйте метод defaultPrevented.  jquery.min.js:2:40212
Last edited by Alexium 67 on 2018-12-24, 08:12, edited 3 times in total.

User avatar
therube
Board Warrior
Board Warrior
Posts: 1108
Joined: 2018-06-08, 17:02

Re: Problem with site styles

Post by therube » 2018-12-26, 20:05

So is this the actual page you have an issue with, https://esia.gosuslugi.ru/idp/login/pwd/switch?cc=bp ?

On that page, if you have JavaScript disabled, it does not display properly, showing both the email and SNILS options (concurrently).


Are you using an extension that blocks JavaScript?


Restart in Safe Mode & see if that changes anything?

If not, as a test, create a new, clean Profile & see what that does.


Oh, I see you've done all that already.
(I should have read the other thread first. Hmm.)

And Private Mode did work - for a period of time.
So might be a cookie issue?
Though if cookie, you might have also expect the new Profile test to have worked, but it did not.
Oh, but you said it did work there too - once.

Issues related to Private Browsing

Private Browsing also likely enables... (don't recall, but some sort of blocking [others feel free to chime in), that is not enabled in a normal session.

And a useragent change also only works - intermittently, hmm.
Last edited by therube on 2018-12-26, 20:17, edited 6 times in total.

Alexium 67
Fanatic
Fanatic
Posts: 101
Joined: 2015-07-13, 10:34
Location: Russia

Re: Problem with site styles

Post by Alexium 67 » 2018-12-26, 21:52

May be something wrong with my provider? It's different at the home and at the work. Or any difference in x64 and x32 Pale Moon/Windows versions (x32 at the work).

P.S. Now it not working at work too.
Last edited by Alexium 67 on 2018-12-26, 21:56, edited 2 times in total.

Alexium 67
Fanatic
Fanatic
Posts: 101
Joined: 2015-07-13, 10:34
Location: Russia

Re: Problem with site styles

Post by Alexium 67 » 2018-12-27, 09:46

Here is one screenshot for example. Not one only variant, some time it display with some graphics even.
Pale Moon
Pale Moon
And Firefox version
Firefox
Firefox
*I used temporal hosting for this screenshots. So it will removed in the future.

**Thanks Moonchild for the tip about attachments!
Last edited by Alexium 67 on 2018-12-27, 09:55, edited 2 times in total.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25035
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Problem with site styles

Post by Moonchild » 2018-12-27, 09:51

Off-topic:
Alexium 67 wrote:*I used temporal hosting for this screenshot. So it will removed in the future.
You can attach images to your posts on this forum so they never go away - it keeps things relevant for future visitors.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

Alexium 67
Fanatic
Fanatic
Posts: 101
Joined: 2015-07-13, 10:34
Location: Russia

Re: Problem with site styles

Post by Alexium 67 » 2018-12-27, 10:02

Very, very strange issue. You can view the different addresses for PM and FF screenshots. I tried to copy FF one to PM address bar and... it now working after two page refresh! Looks like FF version.

I using this button on the original page to show the login page:
Gosuslugi3.jpg

User avatar
Konrad
Fanatic
Fanatic
Posts: 100
Joined: 2018-11-17, 18:19

Re: Problem with site styles

Post by Konrad » 2018-12-27, 11:47

I easily opened the sign-in page with Pale Moon x64. The page address and the page itself are identical to those you see in your Firefox browser.
The only difference is the version of Pale Moon — I have v28.1.0 installed, but I don’t think it matters here.

[В Pale Moon x64 без проблем открыл страницу авторизации через кнопку “Войти” на главной странице. Адрес и сама страница выглядят так же, как в Вашем Firefox.
Правда, есть одно отличие: у меня стоит Pale Moon v28.1.0, но не думаю, что причина в этом.]

[Pale Moon v28.1.0 x64 / Windows 8.1 x64]

User avatar
therube
Board Warrior
Board Warrior
Posts: 1108
Joined: 2018-06-08, 17:02

Re: Problem with site styles

Post by therube » 2018-12-28, 00:05

In your two screenshots, you're ending up at different pages.

/idp/rlogin?cc=bp (FF)
vs
/idp/AuthnEngine (PM)

Alexium 67
Fanatic
Fanatic
Posts: 101
Joined: 2015-07-13, 10:34
Location: Russia

Re: Problem with site styles

Post by Alexium 67 » 2018-12-28, 07:39

Yes. But I clicked to the same button in both cases. And now when PM works fine it open FF variant of link. Probably site is using some js redirect and some time it may be broken for PM.

unknownone
Hobby Astronomer
Hobby Astronomer
Posts: 22
Joined: 2017-03-29, 00:15

Re: Problem with site styles

Post by unknownone » 2019-06-19, 00:04

Hello, I have the exact same problem with the login form on the login page https://esia.gosuslugi.ru/idp/rlogin?cc=bp of the russian GosUslugi website with Palemoon 28.5.2. It is displayed correctly in private mode or after a full clean cache. Is this related to my profile or to Palemoon himself?
Thank you in advance

User avatar
Konrad
Fanatic
Fanatic
Posts: 100
Joined: 2018-11-17, 18:19

Re: Problem with site styles

Post by Konrad » 2019-06-19, 05:43

unknownone wrote:
2019-06-19, 00:04
Hello, I have the exact same problem with the login form on the login page https://esia.gosuslugi.ru/idp/rlogin?cc=bp of the russian GosUslugi website with Palemoon 28.5.2.
Use address https://esia.gosuslugi.ru/profile/user/personal, it automatically opens the log-in page.
Works fine in Palemoon 28.5.2 with uBO and eMatrix active.
Alternatively, you can open it from the main page https://www.gosuslugi.ru/.

unknownone
Hobby Astronomer
Hobby Astronomer
Posts: 22
Joined: 2017-03-29, 00:15

Re: Problem with site styles

Post by unknownone » 2019-07-02, 12:28

Thank you for the solution.

Post Reply