v28, dragging links into tab bar does not create new tab

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderators: trava90, satrow

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
jdpls
Hobby Astronomer
Hobby Astronomer
Posts: 16
Joined: 2014-10-13, 13:23
Location: USA

v28, dragging links into tab bar does not create new tab

Unread post by jdpls » 2018-08-17, 01:10

dunno if i'm the only one having this problem, and a quick search didn't turn up any existing topics, but it's always possible i missed something.

anyway, i can't create new tabs by dragging the link next to an open tab. thoughts?

User avatar
billmcct
Astronaut
Astronaut
Posts: 503
Joined: 2012-09-04, 15:19
Location: Atlanta Georgia USA

Re: v28, dragging links into tab bar does not create new tab

Unread post by billmcct » 2018-08-17, 01:29

It is working fine for me.

Win 7 x64
PM 28 x64
Win 7 x64 - Pale Moon 28x x32

User avatar
Nigaikaze
Keeps coming back
Keeps coming back
Posts: 972
Joined: 2014-02-02, 22:15
Location: Chicago, IL, USA

Re: v28, dragging links into tab bar does not create new tab

Unread post by Nigaikaze » 2018-08-17, 01:41

jdpls wrote:thoughts?
Have you tried doing this in Pale Moon's safe mode? Or with a new profile?
What extensions are you using? Testing in safe mode and in a new profile can rule out whether or not an extension or a configured preference is causing the problem.

jdpls
Hobby Astronomer
Hobby Astronomer
Posts: 16
Joined: 2014-10-13, 13:23
Location: USA

Re: v28, dragging links into tab bar does not create new tab

Unread post by jdpls » 2018-08-17, 02:52

Nigaikaze wrote:
jdpls wrote:thoughts?
Have you tried doing this in Pale Moon's safe mode? Or with a new profile?
What extensions are you using? Testing in safe mode and in a new profile can rule out whether or not an extension or a configured preference is causing the problem.
seems to be tab mix plus doing it based on my "turn off everything one by one and restart" method. as to why... :think:

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 23202
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: v28, dragging links into tab bar does not create new tab

Unread post by Moonchild » 2018-08-17, 06:46

TMP has always been a problematic extension; it's no surprise that (despite there having been months to sort this out... :/) there are issues with the new milestone.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

User avatar
Giraffe
Fanatic
Fanatic
Posts: 234
Joined: 2016-11-09, 11:57

Re: v28, dragging links into tab bar does not create new tab

Unread post by Giraffe » 2018-08-17, 07:48

It's a bit worrying that TMP is problematic - certainly no good in Basilisk - and I'd drop it if there were an alternative. It is very useful.
Windows 7 Pro 32-bit. Comodo Internet security or Comodo Firewall + Avira Anivirus.

User avatar
JustOff
Localization Coordinator
Localization Coordinator
Posts: 1727
Joined: 2015-09-03, 19:47
Location: UA
Contact:

Re: v28, dragging links into tab bar does not create new tab

Unread post by JustOff » 2018-08-17, 09:40

Try Tab Mix Plus Dev-Build 0.5.0.5pre.180718a1, it should resolve this issue.
Here are the add-ons I made in a spare time. That was fun!

User avatar
Giraffe
Fanatic
Fanatic
Posts: 234
Joined: 2016-11-09, 11:57

Re: v28, dragging links into tab bar does not create new tab

Unread post by Giraffe » 2018-08-17, 12:43

JustOff wrote:Try Tab Mix Plus Dev-Build 0.5.0.5pre.180718a1, it should resolve this issue.
Well, I removed the TMP that I had and installed the version in the link.
It's giving me the 100 - 100 px tabs that I like and also making Lollipop Road look as it should (without TMP the theme isn't all the way down the sidebar); also dragging a link now works.

In Basilisk, TMP stopped the simple Restart - Basilisk.exe would stay open - and also would prevent Basilisk being opened from PM via Open With.

If this is stable I'll be happy, thank you.
Last edited by Giraffe on 2018-08-17, 12:44, edited 1 time in total.
Windows 7 Pro 32-bit. Comodo Internet security or Comodo Firewall + Avira Anivirus.

jdpls
Hobby Astronomer
Hobby Astronomer
Posts: 16
Joined: 2014-10-13, 13:23
Location: USA

Re: v28, dragging links into tab bar does not create new tab

Unread post by jdpls » 2018-08-17, 19:02

JustOff wrote:Try Tab Mix Plus Dev-Build 0.5.0.5pre.180718a1, it should resolve this issue.
yep, that fixed it! thanks for the link.

Goodydino
Lunatic
Lunatic
Posts: 434
Joined: 2017-10-10, 21:20

Re: v28, dragging links into tab bar does not create new tab

Unread post by Goodydino » 2018-08-17, 21:43

If you want to open a link in a new tab, why not just middle-click it, or Ctrl-click, or Cmd-click (for Mac)?

User avatar
profdlp
Newbie
Newbie
Posts: 4
Joined: 2018-08-18, 14:48

Re: v28, dragging links into tab bar does not create new tab

Unread post by profdlp » 2018-08-18, 14:56

I make extensive use of the bookmarks toolbar. Not being able to drag links to the tab bar and have the open is a ... drag.

Goodydino
Lunatic
Lunatic
Posts: 434
Joined: 2017-10-10, 21:20

Re: v28, dragging links into tab bar does not create new tab

Unread post by Goodydino » 2018-08-18, 20:04

You can middle-click (or Ctrl-click) links in the bookmarks toolbar.

Locked