Page 1 of 1

All tabs stop working after a while

Posted: 2018-07-21, 12:23
by virtualpaul
I just started using palemoon a few days ago.
Everything seem to work well except that after a while using it, any web access I make result in the arrow going in circle forever. When this happens, all tabs have the same behavior and the only way I found is to restart palemoon. Firefox continues to work normally so it is not a connection issue. I am using 'private browsing' on both palemoon and firefox if it matters.

Re: All tabs stop working after a while

Posted: 2018-07-21, 14:03
by Night Wing
Since you've been using Firefox and just switched over to Pale Moon, since Pale Moon is now a fork of Firefox, if you've transferred over your Firefox profile to Pale Moon, this won't work anymore and it will cause problems. Better to start with a clean Pale Moon profile.

In Pale Moon, how did you configure your Tabs in Preferences?

Also, if you've got some addons which you used in Firefox, some of them probably won't work anymore since Firefox went to Quantum with web extensions. What addon/extensions are you using?

Lastly, since you didn't state what operating system you're using, I'm going to assume you're using Windows. If so, what anti-virus are you using?

Re: All tabs stop working after a while

Posted: 2018-07-21, 14:36
by therube
What is (PM) memory/CPU usage at these times?

Re: All tabs stop working after a while

Posted: 2018-07-22, 00:36
by virtualpaul
I don't recall transfering a Firefox profile to Pale Moon. I only saved my favorites in firefox and imported them in Pale Moon.

I have checked 'always show the tab bar', 'insert related tabs next to the current tab', when opening a new tab, show: 'te pale moon start page'.

I only installed 'adblock latitude'.

Yes, Windows 8.1 and I am using eset anti-virus.

It was using 17% CPU and 1.2GB of RAM for about 12 tabs. I still had 3GB left of 16GB.

Re: All tabs stop working after a while

Posted: 2018-07-22, 17:58
by franstam
hmmm i seem to face this weird issue as well.
my symptoms are i have 2 browser windows open when issue occurs. approximately 40 tabs on one and 90 tabs on other.
circle spins and it seems not to be able to resolve hostname.

fix is to close either one of the browser windows and voila accessible again

Re: All tabs stop working after a while

Posted: 2018-07-24, 04:48
by adesh
Although I'm on Linux, I face this issue as well and its a tricky one. On almost all occasions, I've been using private browsing (but that's part of my workflow habits). When I faced this issue recently I found an "out of memory" line in web console just before "normal processing" of the page stops, but the throbber keeps on going. After this, for example, media content keeps downloading but control buttons are not drawn (due to memory issue?) and new pages do not fully load (partially rendered and missing elements). All this time, system is responsive and I can execute other programs and play with them.
Unfortunately, I was not able to get more details from the console, and my issue might be different from the original in this thread.