Problems with My eBay and Pale Moon browser Topic is solved

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderators: trava90, satrow

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
spotify95
Moongazer
Moongazer
Posts: 11
Joined: Sun, 27 Nov 2016, 23:25

Problems with My eBay and Pale Moon browser

Unread postby spotify95 » Thu, 12 Jul 2018, 14:47

Hello,

I am having problems with eBay website and Pale Moon browser.

Specifically, the problems are occurring with the new style layout at "My eBay" page in that selections that I want to select, such as viewing listings that I am selling, are not working, and that I cannot print postage labels because the browser is unsupported. It thinks that Pale Moon is a very old version of Firefox (it takes the Pale Moon version number and thinks that Pale Moon is that version of Firefox - which, considering that Firefox is in the 50s now regarding versioning, makes pale Moon outdated and thus not able to run) and because of this, is making navigation difficult, especially with the newly created landing page that eBay have put in.

Furthermore, the button to change back to the old style eBay does not work on Pale Moon - though it works fine with Firefox so again compatibility issues here.

If they are any pale moon users here who are also eBayers (and therefore can duplicate this issue) then it'd be great to try and get this fixed - because if the website I need to use won't work in Pale Moon them I'll have to go back to Firefox...

vannilla
Fanatic
Fanatic
Posts: 173
Joined: Sat, 05 May 2018, 13:29

Re: Problems with My eBay and Pale Moon browser

Unread postby vannilla » Thu, 12 Jul 2018, 15:38

Have you tried changing the user agent?
You can do it for example with an extension.
If it's really because of the version number, rather than actually using unsupported features, then this should fix it.

PalleP
Fanatic
Fanatic
Posts: 100
Joined: Wed, 14 Feb 2018, 17:36

Re: Problems with My eBay and Pale Moon browser

Unread postby PalleP » Thu, 12 Jul 2018, 15:53

I use Ebay daily and have no problems so Pale Moon itself has no problem with Ebay. It must be a user agent sniffing problem.
I have very little experience with changing these settings, so hopefully someone else will help you with checking it and set it correctly.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3638
Joined: Mon, 03 Oct 2011, 10:19
Location: Texas, USA

Re: Problems with My eBay and Pale Moon browser

Unread postby Night Wing » Thu, 12 Jul 2018, 17:38

My wife has an eBay account and she has no problems with 64 bit linux Pale Moon 27.9.3 running in 64 bit linux Mint 19 (Tara) Xfce when accessing eBay on her HP laptop.

Since I've got two hard drives in my desktop tower computer, a linux Mint 19 hard drive and a Windows 7 hard drive, the last time she used 32 bit windows Pale Moon running in 64 bit Windows 7 Home Premium SP1 on my tower computer, she had no problems with eBay.

But she hasn't been to the eBay site since Tuesday (7-10-2018). And if it is a user agent sniffing thing, I'll just change the user agent for eBay. Right now my wife is gone for the day and won't be back home until around 5 PM. I'll have her check her eBay account and report back tonight.
Linux Mint 19 (Tara) Xfce 64 Bit (Default OS) with 64 Bit linux Pale Moon
Windows 7 SP1, 64 Bit (Backup OS) with 32 Bit windows Pale Moon

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3638
Joined: Mon, 03 Oct 2011, 10:19
Location: Texas, USA

Re: Problems with My eBay and Pale Moon browser

Unread postby Night Wing » Fri, 13 Jul 2018, 03:26

My wife is not having any problems with her eBay account. She doesn't get the unsupported browser prompt. She'll check it tomorrow to see if anything has changed.
Linux Mint 19 (Tara) Xfce 64 Bit (Default OS) with 64 Bit linux Pale Moon
Windows 7 SP1, 64 Bit (Backup OS) with 32 Bit windows Pale Moon

spotify95
Moongazer
Moongazer
Posts: 11
Joined: Sun, 27 Nov 2016, 23:25

Re: Problems with My eBay and Pale Moon browser

Unread postby spotify95 » Sat, 14 Jul 2018, 10:14

Hi, thanks for the replies regarding this. I am using the 32-bit version of Pale Moon on Windows 7 x64 (though I will also soon be using Windows 10 64 bit). The 32-bit version of Pale Moon was chosen due to a plugin that I previously required, being only released in 32 bit and therefore had to be 32 bit only.

I have no problems with most of the stuff on "My eBay" but on the new style eBay, some of the buttons and features do not work. I have attached some screenshots of the Seller Dashboard (getting rid of the personal info of course) and you can see the difference between the new My eBay and the old one.
Most of the buttons aren't clickable on Pale Moon under the new layout - including switching back to the old layout - so it's not as if it is currently that usable!

I had to use Firefox Compatibility (or whatever the setting is) in order to get Google services working properly.

Any help would be appreciated - as it works on Firefox (I used Firefox to take the screenshots, since I knew it works!) but not Pale Moon.
Attachments
New my eBay.png
Old My eBay.png

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22415
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Problems with My eBay and Pale Moon browser

Unread postby Moonchild » Sat, 14 Jul 2018, 10:42

It seems the "new selling overview" is currently in beta test (by default I'm presented with the old and fully working one, and being offered to try the new version); They likely started with Chrome, and would work on compatibility with other browsers from there. eBay does ask for feedback... you could let them know it's not working for you, and why.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

spotify95
Moongazer
Moongazer
Posts: 11
Joined: Sun, 27 Nov 2016, 23:25

Re: Problems with My eBay and Pale Moon browser

Unread postby spotify95 » Sun, 15 Jul 2018, 10:15

Moonchild wrote:It seems the "new selling overview" is currently in beta test (by default I'm presented with the old and fully working one, and being offered to try the new version); They likely started with Chrome, and would work on compatibility with other browsers from there. eBay does ask for feedback... you could let them know it's not working for you, and why.

Thank you for the information; I have since sent two comment forms in, one on the box that comes up when you try to go back to the old view, and one on the "let us know what you think" bit,

Only trouble is that the button to press, to go back to the old layout, doesn't work in Pale Moon, so unless there is some sort of fix that I am aware of, then I cannot go back to the old version of my eBay under Pale Moon!

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3638
Joined: Mon, 03 Oct 2011, 10:19
Location: Texas, USA

Re: Problems with My eBay and Pale Moon browser

Unread postby Night Wing » Sun, 15 Jul 2018, 12:47

spotify95 wrote:
Moonchild wrote:Only trouble is that the button to press, to go back to the old layout, doesn't work in Pale Moon, so unless there is some sort of fix that I am aware of, then I cannot go back to the old version of my eBay under Pale Moon!


Can you use another browser, like Firefox, to go back to the old version and then use Pale Moon again?
Linux Mint 19 (Tara) Xfce 64 Bit (Default OS) with 64 Bit linux Pale Moon
Windows 7 SP1, 64 Bit (Backup OS) with 32 Bit windows Pale Moon

spotify95
Moongazer
Moongazer
Posts: 11
Joined: Sun, 27 Nov 2016, 23:25

Re: Problems with My eBay and Pale Moon browser

Unread postby spotify95 » Sun, 15 Jul 2018, 21:44

I've logged in and switched Firefox back to the old version of eBay, but Pale Moon hasn`t switched back as well; it has decided to stay on the new version. Which is no good as the button to switch back doesn't work (and nor do any of the other buttons)...

Maybe eBay should have kept us all on the old version, with a choice to try the new beta version, until the new version is no longer beta and therefore becomes the main version? As far as I am aware, things are a mess currently.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22415
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Problems with My eBay and Pale Moon browser

Unread postby Moonchild » Mon, 16 Jul 2018, 07:10

Your setting for the old or new interface is probably saved in an eBay cookie. Try clearing your cookies for eBay.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

spotify95
Moongazer
Moongazer
Posts: 11
Joined: Sun, 27 Nov 2016, 23:25

Re: Problems with My eBay and Pale Moon browser

Unread postby spotify95 » Tue, 17 Jul 2018, 11:27

Moonchild wrote:Your setting for the old or new interface is probably saved in an eBay cookie. Try clearing your cookies for eBay.

Hi, thanks for the advice. I've just cleared my cookies for eBay under preferences, signed back in to eBay and gone to selling. It still shows up the "beta" interface, with the option to go back to the classic view, but of course the button to go back is broken in Pale Moon (as are all of the other buttons in the new interface)...
Last edited by spotify95 on Tue, 17 Jul 2018, 11:27, edited 1 time in total.

spotify95
Moongazer
Moongazer
Posts: 11
Joined: Sun, 27 Nov 2016, 23:25

Re: Problems with My eBay and Pale Moon browser  Topic is solved

Unread postby spotify95 » Thu, 16 Aug 2018, 21:36

It's fixed! eBay works perfectly now. I guess the new layout didn't like some of the internals to Pale Moon 27.x, because the new update to version 28.0 has fixed the problem.

Still don't know the root cause of the problem, but at least it works.
Thanks!

DoctorM
Fanatic
Fanatic
Posts: 102
Joined: Thu, 31 Jul 2014, 18:19
Location: USA

Re: Problems with My eBay and Pale Moon browser

Unread postby DoctorM » Mon, 20 Aug 2018, 03:38

That's funny. PM v28 kills eBay for me. Tested on two different PCs using the x64 and x86 versions (Win7 on both).
In both cases the new eBay layout appears, but logging in is a near endless loop. Occasionally it will accept a login, but even then if we try to do anything, it asks us to log in again.

Had to roll one PC back to PM v27 just for eBay.
Last edited by DoctorM on Mon, 20 Aug 2018, 03:39, edited 1 time in total.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3638
Joined: Mon, 03 Oct 2011, 10:19
Location: Texas, USA

Re: Problems with My eBay and Pale Moon browser

Unread postby Night Wing » Mon, 20 Aug 2018, 10:11

My wife has no problems using both 64 bit linux and/or 32 bit windows Pale Moon 28.0.0 to access her account on eBay to purchase items. Ditto for PayPal since she ordered some Carolyn Pollack jewelry last night.

Last night her eBay purchase was processed through PayPal using 64 bit linux Pale Moon 28.0.0 running in 64 bit linux Mint 19 (Tara) Xfce.
Linux Mint 19 (Tara) Xfce 64 Bit (Default OS) with 64 Bit linux Pale Moon
Windows 7 SP1, 64 Bit (Backup OS) with 32 Bit windows Pale Moon

DoctorM
Fanatic
Fanatic
Posts: 102
Joined: Thu, 31 Jul 2014, 18:19
Location: USA

Re: Problems with My eBay and Pale Moon browser

Unread postby DoctorM » Sat, 25 Aug 2018, 08:27

Hmm. I've reproduced this on two PCs and no one else is seeing it? That's odd.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3638
Joined: Mon, 03 Oct 2011, 10:19
Location: Texas, USA

Re: Problems with My eBay and Pale Moon browser

Unread postby Night Wing » Sat, 25 Aug 2018, 11:00

DoctorM wrote:Hmm. I've reproduced this on two PCs and no one else is seeing it?


Well, I've got four computers using Pale Moon 28 in both 64 bit linux and 32 bit windows Pale Moon and can't reproduce the problem you're having with eBay. My wife used eBay yesterday afternoon to make a purchase and again, she had no problems with eBay using 64 bit linux Pale Moon (28.0.0).

And this also included using PayPal to make the purchase. So what have you tried on our own to fix the problem you're having with eBay? Have you tried a new profile, safe mode, user agent.........what?
Linux Mint 19 (Tara) Xfce 64 Bit (Default OS) with 64 Bit linux Pale Moon
Windows 7 SP1, 64 Bit (Backup OS) with 32 Bit windows Pale Moon

DoctorM
Fanatic
Fanatic
Posts: 102
Joined: Thu, 31 Jul 2014, 18:19
Location: USA

Re: Problems with My eBay and Pale Moon browser

Unread postby DoctorM » Sat, 25 Aug 2018, 17:07

Yup, fixed it now. I uninstalled v28.
It's still too beta for every day use.
I've disabled adblock. I've accepted all cookies ebay threw at me. Still, logging on is an endless loop.
There's not much else the two installations have in common.

I don't mean anything by it against the development team. New versions of software always have growing pains. v27 was buggy at first launch too.
That said, I'm not here to beta test. I need a browser that works, and the ebay issue is only one of several.

DoctorM
Fanatic
Fanatic
Posts: 102
Joined: Thu, 31 Jul 2014, 18:19
Location: USA

Re: Problems with My eBay and Pale Moon browser

Unread postby DoctorM » Sat, 01 Sep 2018, 04:45

Okay, decided to try 28.0.1 tonight and deleted all eBay cookies, disabled APL, etc. I found the same issue, but it wasn't exactly what I thought.

I CAN log in to ebay, and go to specific sections without issue, but if I click the top item in most tabs, I get sent to the login page again.

For example: If I click "My eBay", I get asked to log in. If I click any of the items within the drop down menu (Summary, Recently Viewed, etc.) they work just fine.
Similarly from the Summary page, if I click the Messages or Account tabs, I'm asked to log in. But if I pick something from their drop down menus (Inbox, Sent, Unread...), everything works fine.

Examining the links, it looks like any link that uses "http://my.ebay.com/ws/eBayISAPI.dll?" is where Pale Moon 28 throws a shoe.

v27 doesn't do this. Maybe people haven't noticed because they don't use those specific links(?)


Return to “General support”

Who is online

Users browsing this forum: No registered users and 10 guests