Please note: we have made some forum changes regarding user data and privacy.
More info here: Planned downtime for the forum and changes.

what about continued support for windows Vista?

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderators: trava90, satrow

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
User avatar
WilliamK
Fanatic
Fanatic
Posts: 175
Joined: 2018-02-23, 06:51

Re: what about continued support for windows Vista?

Post by WilliamK » 2018-06-29, 22:53

EbonJaeger wrote: I hope none of those machines are connected to the internet
Usually not. I would expect them to be running AV seeing as XP and Vista did not already include a MS solution. They are usually bolted to the floor... if using the first release of our web browser they can only visit their intranet site, save nothing, copy nothing and maybe in kiosk mode with no other option than to use the given page links.

User avatar
inrobert
Hobby Astronomer
Hobby Astronomer
Posts: 21
Joined: 2018-04-03, 19:44

Re: what about continued support for windows Vista?

Post by inrobert » 2018-08-16, 18:24

Moonchild wrote:As for our support: support for features will be limited in Vista, but since it matches the minimum platform requirements there's no reason to change that on a per-application basis.
UXP applications including Basilisk and Pale Moon 28 should continue to run on Vista in the foreseeable future.
My 27.9.4 (64-bit) version was updated to 28 version through the built-in updater but it's not working on Vista Home Premium 64-bit (fully updated). It's not starting at all, showing the message that palemoon.exe is not a valid Win32 application.
What is official status of Pale Moon 28 Vista compatibility, was it tested? If it should be working I will try to reinstall it tomorrow, as it's on my PC at work.
Last edited by inrobert on 2018-08-16, 18:31, edited 1 time in total.

User avatar
Nigaikaze
Board Warrior
Board Warrior
Posts: 1110
Joined: 2014-02-02, 22:15
Location: Chicago, IL, USA

Re: what about continued support for windows Vista?

Post by Nigaikaze » 2018-08-16, 18:44

inrobert wrote:What is official status of Pale Moon 28 Vista compatibility
Moonchild wrote:Windows Vista is NOT supported.
Source: https://forum.palemoon.org/viewtopic.ph ... rt#p146601
Nichi nichi kore ko jitsu = Every day is a good day.

User avatar
inrobert
Hobby Astronomer
Hobby Astronomer
Posts: 21
Joined: 2018-04-03, 19:44

Re: what about continued support for windows Vista?

Post by inrobert » 2018-08-16, 19:09

Thank you. So I understand that even though UXP itself is supporting Vista, Pale Moon is not? If so, it would be good to block built-in update to 28 version on Vista or at least put information about Vista not being supported on release notes page (http://www.palemoon.org/releasenotes.shtml), because this is where people can go to see what are the important changes in new version proposed by built-in update.

User avatar
Isengrim
Keeps coming back
Keeps coming back
Posts: 998
Joined: 2015-09-08, 22:54
Location: 127.0.0.1
Contact:

Re: what about continued support for windows Vista?

Post by Isengrim » 2018-08-16, 19:17

UXP is a platform, and the platform does not support Vista, therefore no applications built upon the platform will support Vista.
Linux Mint 19.2 Cinnamon (64-bit), Windows 7 (64-bit), Windows 10 build 1803 (64-bit)
"As long as there is someone who will appreciate the work involved in the creation, the effort is time well spent." ~ Tetsuzou Kamadani, Cave Story

User avatar
inrobert
Hobby Astronomer
Hobby Astronomer
Posts: 21
Joined: 2018-04-03, 19:44

Re: what about continued support for windows Vista?

Post by inrobert » 2018-08-16, 19:39

Isengrim wrote:UXP is a platform, and the platform does not support Vista, therefore no applications built upon the platform will support Vista.
UXP as a platform was said to require Windows kernel 6, including Vista. Four posts above I did provide Moonchild quote that "support for features will be limited in Vista, but since it matches the minimum platform requirements there's no reason to change that on a per-application basis". So as I understand eventually it was just decided to not support Vista on UXP-based applications or requirements for the whole UXP were changed to not include Vista. Not debating justification of one or another decision, just noting that something else was said not long ago and there is no info about this change on release notes page.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24907
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: what about continued support for windows Vista?

Post by Moonchild » 2018-08-16, 21:20

As development continues, system requirements may change. This has been the case here too.
Just because I posted that in our early platform development stage does NOT mean it would be set in stone.

Sorry for any confusion this may have caused, but to confirm: Vista is not supported.
Last edited by Moonchild on 2018-08-16, 21:21, edited 1 time in total.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
inrobert
Hobby Astronomer
Hobby Astronomer
Posts: 21
Joined: 2018-04-03, 19:44

Re: what about continued support for windows Vista?

Post by inrobert » 2018-08-16, 21:47

Thank you for confirmation. Vista has low OS market share but maybe there will be 3rd party version for Vista (like it was for XP). I guess i will reinstall 27.9.4, as I will still go on Vista for now.

User avatar
PMRick
Newbie
Newbie
Posts: 4
Joined: 2018-07-27, 16:33

Re: what about continued support for windows Vista?

Post by PMRick » 2018-08-20, 17:11

On my my Vista PC, I recently updated to version 28, but got a "not a valid Win32 program" error message every time I tried to open it.. The same after re-booting. Reinstalled the PM version 27.9, and it is back to normal. Maybe I'll try a uninstall (w/ Revo) and install Version 28.
No issues on my Win 10 PC.
Otherwise PM is great, thanks MoonChild

User avatar
Isengrim
Keeps coming back
Keeps coming back
Posts: 998
Joined: 2015-09-08, 22:54
Location: 127.0.0.1
Contact:

Re: what about continued support for windows Vista?

Post by Isengrim » 2018-08-20, 18:00

PMRick wrote:On my my Vista PC, I recently updated to version 28, but got a "not a valid Win32 program" error message every time I tried to open it.. The same after re-booting. Reinstalled the PM version 27.9, and it is back to normal. Maybe I'll try a uninstall (w/ Revo) and install Version 28.
As has been explained a few times already...
Moonchild wrote:Sorry for any confusion this may have caused, but to confirm: Vista is not supported.
You might be able to get it to work on Vista, as a few people apparently have, but you are on your own for that.
Last edited by Isengrim on 2018-08-20, 18:00, edited 1 time in total.
Linux Mint 19.2 Cinnamon (64-bit), Windows 7 (64-bit), Windows 10 build 1803 (64-bit)
"As long as there is someone who will appreciate the work involved in the creation, the effort is time well spent." ~ Tetsuzou Kamadani, Cave Story

Locked