Page 1 of 1

Page not loading at all

Posted: Mon, 14 May 2018, 16:13
by Octopuss

Re: Page not loading at all

Posted: Mon, 14 May 2018, 16:17
by Night Wing
I clicked on your link using 64 bit linux Pale Moon 27.9.1 running in 64 bit linux Mint 18.3 (Sylvia) Xfce. It loaded the Magic Lantern Forum Index page in 1 second of time.

Re: Page not loading at all

Posted: Mon, 14 May 2018, 17:17
by rabnbeinn
Page not loading: Confirmed.

Tried all 3 UAMs and in safe mode.

Win 8.1 (x64)
Pm 27.9.1 (x64)

Re: Page not loading at all

Posted: Mon, 14 May 2018, 17:39
by Night Wing
I switched over to my windows hard drive in this tower computer. After clicking on the link using 32 bit windows Pale Moon 27.9.1 running in 64 bit Windows 7 Home Premium, SP1; the Magic Lantern Forum Index page does "not" load.

So the page loads without any problems in 64 bit linux Pale Moon, but does not load in 32 bit windows Pale Moon. Looks like a hiccup with Pale Moon in the windows operating system.

Re: Page not loading at all

Posted: Mon, 14 May 2018, 17:50
by GMforker
Page not loading

Because, this script does not load (blocked on the server?):
https://www.magiclantern.fm/forum/Theme ... t.js?fin20

Fixed (e.g.):
about:config

Code: Select all

general.useragent.override.magiclantern.fm = Pale Moon MSIE

(I will not search for other strings)

Re: Page not loading at all

Posted: Mon, 14 May 2018, 18:50
by Nightbird
Site works as soon as you block scripts or as soon as you override with an IE string
Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; Trident/4.0)

Re: Page not loading at all

Posted: Mon, 14 May 2018, 21:05
by Goodydino
That site does not seem to like Pale Moon. It works with SeaMonkey, Opera and Safari. Trying to block scripts with YesScript did not work well either.

Re: Page not loading at all

Posted: Mon, 14 May 2018, 21:39
by coffeebreak
It looks to be cloudflare's rocket-loader script again.

Code: Select all

https://ajax.cloudflare.com/cdn-cgi/scripts/dba9ecf7/cloudflare-static/rocket-loader.min.js

Error console.

Code: Select all

Error: Permission denied to access property "handleEvent"
Source File: https://ajax.cloudflare.com/cdn-cgi/scripts/dba9ecf7/cloudflare-static/rocket-loader.min.js
Line: 1

Error: ReferenceError: is_ie is not defined
Source File: https://www.magiclantern.fm/forum/Themes/default/scripts/theme.js?fin20 Line: 7

The page did load for me when scripts from cloudflare were blocked.

See https://forum.palemoon.org/viewtopic.php?f=3&t=19104
and https://forum.palemoon.org/viewtopic.php?f=37&t=19143

Re: Page not loading at all

Posted: Tue, 15 May 2018, 00:22
by Frasier
coffeebreak wrote:It looks to be cloudflare's rocket-loader script again.

Code: Select all

https://ajax.cloudflare.com/cdn-cgi/scripts/dba9ecf7/cloudflare-static/rocket-loader.min.js

Yep, that's the culprit, again. Wondered why the magiclantern forum loaded with no problems, then realized I had already blocked that script in the adblocker.

Re: Page not loading at all

Posted: Tue, 15 May 2018, 01:00
by Night Wing
I had also blocked "ajax.cloudflare" in my Domain Blocker in linux Mint for some other site so this is why my linux Pale Moon loaded the Green Lantern page.

Re: Page not loading at all

Posted: Tue, 15 May 2018, 14:32
by Octopuss
What does that script do?
Cloudflare is some web hosting, right?

Re: Page not loading at all

Posted: Tue, 15 May 2018, 14:48
by Frasier
Octopuss wrote:What does that script do?
Cloudflare is some web hosting, right?
See these two posts:
Re: craigmurray .org.uk/
Re: craigmurray .org.uk/

Re: Page not loading at all

Posted: Wed, 16 May 2018, 19:50
by badnick
This page works for me ( PM 27.9.1/Win 10 / 64)

Re: Page not loading at all

Posted: Thu, 17 May 2018, 13:09
by rabnbeinn
It now also opens for me when it wouldn't 2 days ago (as posted)

Re: Page not loading at all

Posted: Thu, 17 May 2018, 15:42
by Moonchild
Looks like CF might have fixed their script.
I'm asking for a status update.

Re: Page not loading at all

Posted: Thu, 17 May 2018, 21:30
by Moonchild
Cloudflare has deployed a fix for this issue in their script.
If pages still don't load, you need to clear your browser cache to get rid of cached versions of their script, navigate to the problematic page again.
(Preferences -> Advanced -> tab Network -> [Clear now] button under "Cached Web Content")

Re: Page not loading at all

Posted: Fri, 18 May 2018, 07:17
by Octopuss
Moonchild wrote:Looks like CF might have fixed their script.
I'm asking for a status update.

Ha, it works!