craigmurray.org.uk/

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderators: trava90, satrow

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
davews
Fanatic
Fanatic
Posts: 104
Joined: 2015-01-20, 09:36
Location: Bracknell

craigmurray.org.uk/

Unread post by davews » 2018-05-10, 18:16

Since today https://www.craigmurray.org.uk/ doesn't load in Palemoon, stalls at a blank page, has worked with no issues for some time. Loads fine in Firefox. Only change is this weeks Windows updates, now on W10 1709 Home build 16299.431. Updated PM to 27.9.1 in case the W10 1803 change had anything to do with it but no different.
As always on this forum everybody else will say it loads fine...

User avatar
adesh
Astronaut
Astronaut
Posts: 716
Joined: 2017-06-06, 07:38

Re: craigmurray.org.uk/

Unread post by adesh » 2018-05-10, 18:28

Yes, Loads fine with scripts disabled. :lol:

With scripts enabled, page loads initiallly then turns white due to some JS black magic.
Last edited by adesh on 2018-05-10, 18:31, edited 1 time in total.

User avatar
badnick
Lunatic
Lunatic
Posts: 394
Joined: 2017-03-23, 19:56

Re: craigmurray.org.uk/

Unread post by badnick » 2018-05-10, 18:29

Confirmed. Endless spinning and nothing loaded on this link.
Windows 10 /64 (version 1809)
PM last/64

Thehandyman1957

Re: craigmurray.org.uk/

Unread post by Thehandyman1957 » 2018-05-10, 19:36

Loads for me with Ublock. White page without it.
Screenshot - 5_10_2018 , 12_33_43 PM.png
Yeah Ublock. :thumbup:

Nightbird
Fanatic
Fanatic
Posts: 197
Joined: 2016-07-18, 21:12

Re: craigmurray.org.uk/

Unread post by Nightbird » 2018-05-10, 19:47

Override :
general.useragent.override.craigmurray.org.uk

with this string ;)

Mozilla/4.0 (compatible; MSIE 9.0; Windows NT 6.1; Trident/4.0)

it works (even with js and uBlock enabled)
Last edited by Nightbird on 2018-05-10, 21:09, edited 2 times in total.
Diversity is key.

coffeebreak
Board Warrior
Board Warrior
Posts: 1817
Joined: 2015-09-26, 04:51
Location: U.S.

Re: craigmurray.org.uk/

Unread post by coffeebreak » 2018-05-10, 20:17

The problem seems to be with this script:

Code: Select all

https://ajax.cloudflare.com/cdn-cgi/scripts/dba9ecf7/cloudflare-static/rocket-loader.min.js

Error console (after script is allowed).

Code: Select all

Error: Permission denied to access property "handleEvent" 
Source File: https://ajax.cloudflare.com/cdn-cgi/scripts/dba9ecf7/cloudflare-static/rocket-loader.min.js Line: 1

davews
Fanatic
Fanatic
Posts: 104
Joined: 2015-01-20, 09:36
Location: Bracknell

Re: craigmurray.org.uk/

Unread post by davews » 2018-05-10, 20:23

Thanks nightbird, override string added, now working fine. They must have changed something as it worked fine yesterday. By the way I already have Ublock, didn't work with just that.

Thehandyman1957

Re: craigmurray.org.uk/

Unread post by Thehandyman1957 » 2018-05-10, 21:30

You have to be blocking 3rd party scripts and frames with Ublock. It does not come out of the box that way. ;)
I posted a link to a tutorial video showing how to use those settings and what they do. Was very informative for me
as I was basically ignorant of how to use it beyond easy stuff.

How to use uBlock Origin advanced user mode tutorial 2018
https://forum.palemoon.org/viewtopic.php?f=4&t=18922
Last edited by Thehandyman1957 on 2018-05-10, 21:33, edited 1 time in total.

Nightbird
Fanatic
Fanatic
Posts: 197
Joined: 2016-07-18, 21:12

Re: craigmurray.org.uk/

Unread post by Nightbird » 2018-05-10, 21:44

davews wrote:Thanks nightbird, override string added, now working fine. They must have changed something as it worked fine yesterday. By the way I already have Ublock, didn't work with just that.
Maybe it will work tomorrow without the override. :?:
-----------------------------------------------------------------------------
I had an idea when i read what adesh wrote " Loads fine with scripts disabled".

I remembered that in the past, IE had "problems" with JS.
So i verified the page source and... bingo : IE7, IE8, IE9 are supported. ;)
Nowadays, this is rather "old" but it does matter for "our" problem.
So i tried an override with an IE string (IE 8 and 9), both worked. :)

edit : i tried with NoScript enabled / disabled and uBlock enabled, the site works.
Last edited by Nightbird on 2018-05-10, 21:52, edited 1 time in total.
Diversity is key.

Goodydino
Astronaut
Astronaut
Posts: 509
Joined: 2017-10-10, 21:20

Re: craigmurray.org.uk/

Unread post by Goodydino » 2018-05-10, 21:50

That site loads for me with Safari, Opera and SeaMonkey, but not with Pale Moon. I have uBlock Origin installed in all the browsers and the same setup in it for all of them.

coffeebreak
Board Warrior
Board Warrior
Posts: 1817
Joined: 2015-09-26, 04:51
Location: U.S.

Re: craigmurray.org.uk/

Unread post by coffeebreak » 2018-05-10, 22:19

Goodydino wrote:I have uBlock Origin installed in all the browsers and the same setup in it for all of them.

Pale Moon has a problem with a particular third-party script on this site. It's a problem that other browsers don't appear to have.

If you block third-party scripts in general (or just scripts from ajax.cloudflare.com) with uBlock Origin or any other blocker, Pale Moon loads craigmurray.co.uk properly.

User avatar
badnick
Lunatic
Lunatic
Posts: 394
Joined: 2017-03-23, 19:56

Re: craigmurray.org.uk/

Unread post by badnick » 2018-05-11, 08:50

Not working for me even with uBO disabled.
Windows 10 /64 (version 1809)
PM last/64

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24453
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: craigmurray.org.uk/

Unread post by Moonchild » 2018-05-11, 17:19

Rocket loader is a cloudflare-side script (in beta afaik) -- there's obviously a bug or interop issue with it so I reported this issue to cloudflare.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3973
Joined: 2011-10-03, 10:19
Location: Texas, USA

Re: craigmurray.org.uk/

Unread post by Night Wing » 2018-05-11, 17:30

Just to add my two cents worth.

That site loads just fine for me without any problems and I'm using 64 bit linux Pale Moon 27.9.1 running in 64 bit linux Mint 18.3 (Sylvia) Xfce. Just Adblock Latitude 5.0.1 enabled.
Last edited by Night Wing on 2018-05-11, 17:30, edited 1 time in total.
Linux Mint 19.2 (Tina) Xfce 64 Bit (Default Distribution OS) with 64 Bit linux Pale Moon
Windows 7 Home Premium & Ultimate SP1, 64 Bit (Backup OS) with 32 Bit windows Pale Moon

Goodydino
Astronaut
Astronaut
Posts: 509
Joined: 2017-10-10, 21:20

Re: craigmurray.org.uk/

Unread post by Goodydino » 2018-05-11, 20:26

coffeebreak wrote:
Goodydino wrote:I have uBlock Origin installed in all the browsers and the same setup in it for all of them.

Pale Moon has a problem with a particular third-party script on this site. It's a problem that other browsers don't appear to have.

If you block third-party scripts in general (or just scripts from ajax.cloudflare.com) with uBlock Origin or any other blocker, Pale Moon loads craigmurray.co.uk properly.
Not for me. I tried blocking ajax.cloudflare.com in uBlock Origin. It made no difference. I found that the page loaded if I blocked all javascript for it.
Last edited by Goodydino on 2018-05-11, 20:33, edited 1 time in total.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24453
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: craigmurray.org.uk/

Unread post by Moonchild » 2018-05-12, 13:01

The rocketloader script is confirmed the culprit. Once it's been allowed to load once, it will be in your cache and the browser will pull the result from cache as a measure to try and resume the load that never completed. Only clearing your cache afterwards will allow the page to load again.

I have an open ticket with CF about this interop issue. It's been confirmed to be their script at the root of this, and we'll have to see what their engineering team makes of it.
Unfortunately on the client side we can't do anything about this right now. CF needs to figure out first what's wrong with their script.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24453
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: craigmurray.org.uk/

Unread post by Moonchild » 2018-05-17, 21:30

Cloudflare has deployed a fix for this issue in their script.
If pages still don't load, you need to clear your browser cache to get rid of cached versions of their script, navigate to the problematic page again.
(Preferences -> Advanced -> tab Network -> [Clear now] button under "Cached Web Content")
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

davews
Fanatic
Fanatic
Posts: 104
Joined: 2015-01-20, 09:36
Location: Bracknell

Re: craigmurray.org.uk/

Unread post by davews » 2018-05-18, 07:31

Now working again, thanks for your efforts chaps.

User avatar
adesh
Astronaut
Astronaut
Posts: 716
Joined: 2017-06-06, 07:38

Re: craigmurray.org.uk/

Unread post by adesh » 2018-05-18, 08:11

Off-topic:
Good efforts, Moonchild! And that responsible behaviour of CloudFlare puts it ahead than many others.
Last edited by adesh on 2018-05-18, 08:13, edited 1 time in total.

Locked