Emergency: craigslist reply button broken

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderators: trava90, satrow

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
User avatar
cartel
Lunatic
Lunatic
Posts: 321
Joined: Sun, 16 Mar 2014, 21:57
Location: Chilliwack, BC

Emergency: craigslist reply button broken

Unread postby cartel » Sun, 29 Apr 2018, 05:37

this just started today.
It trys to load a captcha and fails.
Tried safemode, tried removing my hosts file.

Code: Select all

https://abbotsford.craigslist.ca/cto/d/2013-jeep-rubicon-2dr/6573975868.html


sorry, something went wrong



2017130.jpg

2017129.jpg
2017129.jpg (35.59 KiB) Viewed 9257 times
Last edited by cartel on Sun, 29 Apr 2018, 16:57, edited 2 times in total.

User avatar
ChrisPierman
Hobby Astronomer
Hobby Astronomer
Posts: 19
Joined: Fri, 04 Mar 2016, 15:29
Contact:

Re: craigslist reply button broken

Unread postby ChrisPierman » Sun, 29 Apr 2018, 11:10

Yes, I can confirm. Multiple machines, both architectures, no hosts or other blocking, safe mode: same result.

User avatar
ChrisPierman
Hobby Astronomer
Hobby Astronomer
Posts: 19
Joined: Fri, 04 Mar 2016, 15:29
Contact:

Re: craigslist reply button broken

Unread postby ChrisPierman » Sun, 29 Apr 2018, 15:58

Revisiting the thread, I realized some helpful info might be left out. It happens when you click on the "Reply" button. It IS the captcha mechanism but I don't think it necessarily means you're (end user) going to get a captcha (if it worked right.) In other words, in Firefox, clicking on "Reply" works well, without captcha shown at all.

User avatar
cartel
Lunatic
Lunatic
Posts: 321
Joined: Sun, 16 Mar 2014, 21:57
Location: Chilliwack, BC

Re: craigslist reply button broken

Unread postby cartel » Sun, 29 Apr 2018, 16:47

I've tried everything, user agents, defaut PM profile, disabled firewall, default hosts file, bypassed my router.
This is very important I use CL every day.

Anyone know a way to fix this?

thanks


2017134.jpg


Code: Select all

Timestamp: 4/29/2018 9:51:48 AM
Error: XML Parsing Error: no root element found
Location: https://abbotsford.craigslist.ca/reply/abb/cto/6573975868
Line Number 2, Column 1:
Source File: https://abbotsford.craigslist.ca/reply/abb/cto/6573975868
Line: 2
Last edited by cartel on Sun, 29 Apr 2018, 16:53, edited 3 times in total.

User avatar
cartel
Lunatic
Lunatic
Posts: 321
Joined: Sun, 16 Mar 2014, 21:57
Location: Chilliwack, BC

Re: Emergency: craigslist reply button broken

Unread postby cartel » Mon, 30 Apr 2018, 01:15

Works on Google Chrome but not PM.

Please help.

User avatar
Tomaso
Keeps coming back
Keeps coming back
Posts: 943
Joined: Thu, 23 Jul 2015, 16:09
Location: Norway

Re: Emergency: craigslist reply button broken

Unread postby Tomaso » Mon, 30 Apr 2018, 06:42

Here at my end, the issue is caused by blocking.

Problem filters:
* Fanboy's Annoyance List
* Fanboy's Cookiemonster List

Problem rule:

Code: Select all

##.grecaptcha-badge


Fix (add to filters):

Code: Select all

craigslist.*#@#.grecaptcha-badge


--

EDIT1:
I've reported the problem here:
https://github.com/ryanbr/fanboy-adblock/issues/353/

--

EDIT2:
What the hell!?
Earlier today, when visiting craigslist, I used uBO's logger to find that blocked element.
After whitelisting it, I tested the "reply" button several times, and I swear that it worked just fine!
But now, it's broken again, and I can't get it to work no matter what I do!!
Oh well, guess I can tell ryanbr to disregard the report that i filed then.
Last edited by Tomaso on Mon, 30 Apr 2018, 11:03, edited 3 times in total.

coffeebreak
Board Warrior
Board Warrior
Posts: 1340
Joined: Sat, 26 Sep 2015, 04:51
Location: U.S.

Re: Emergency: craigslist reply button broken

Unread postby coffeebreak » Mon, 30 Apr 2018, 13:08

Most of the time it doesn't work here.
But every once in a while it works, just randomly - maybe 1 in 4 tries.
Last edited by coffeebreak on Mon, 30 Apr 2018, 14:11, edited 2 times in total.

User avatar
Tomaso
Keeps coming back
Keeps coming back
Posts: 943
Joined: Thu, 23 Jul 2015, 16:09
Location: Norway

Re: Emergency: craigslist reply button broken

Unread postby Tomaso » Mon, 30 Apr 2018, 15:13

coffeebreak wrote:every once in a while it works, just randomly - maybe 1 in 4 tries.

Confirmed.

User avatar
Moonraker
Keeps coming back
Keeps coming back
Posts: 878
Joined: Wed, 30 Sep 2015, 23:02
Location: Lincolnshire.UK.

Re: Emergency: craigslist reply button broken

Unread postby Moonraker » Mon, 30 Apr 2018, 15:20

Just use chrome for that site then if it works there.Why make such a song and dance about it? :P
Slacko puppy linux 64bit.
Pale moon 27.9.0

User avatar
cartel
Lunatic
Lunatic
Posts: 321
Joined: Sun, 16 Mar 2014, 21:57
Location: Chilliwack, BC

Re: Emergency: craigslist reply button broken

Unread postby cartel » Mon, 30 Apr 2018, 21:46

Moonraker wrote:Just use chrome for that site then if it works there.Why make such a song and dance about it? :P

I hate chrome

I need this fixed, please I hope someone can look into this.
Last edited by cartel on Tue, 01 May 2018, 00:28, edited 2 times in total.

User avatar
Moonraker
Keeps coming back
Keeps coming back
Posts: 878
Joined: Wed, 30 Sep 2015, 23:02
Location: Lincolnshire.UK.

Re: Emergency: craigslist reply button broken

Unread postby Moonraker » Mon, 30 Apr 2018, 22:18

Sorry i assumed you were using chrome as a secondary browser.i only use palemoon and basilisk,
Oddly i cannot even get to the craigslist website as i get a secure connection error.
Slacko puppy linux 64bit.
Pale moon 27.9.0

User avatar
cartel
Lunatic
Lunatic
Posts: 321
Joined: Sun, 16 Mar 2014, 21:57
Location: Chilliwack, BC

Re: Emergency: craigslist reply button broken

Unread postby cartel » Tue, 01 May 2018, 00:27

Moonraker wrote:Sorry i assumed you were using chrome as a secondary browser.i only use palemoon and basilisk,
Oddly i cannot even get to the craigslist website as i get a secure connection error.

No sweat. I just despise chrome but I have a portable version I use in situations like this.
I basically make my living with CL so its really important to me.
I even tried restoring my OS to a saved image with acronis to before this happened. no luck.
Last edited by cartel on Tue, 01 May 2018, 00:29, edited 1 time in total.

coffeebreak
Board Warrior
Board Warrior
Posts: 1340
Joined: Sat, 26 Sep 2015, 04:51
Location: U.S.

Re: Emergency: craigslist reply button broken

Unread postby coffeebreak » Tue, 01 May 2018, 01:06

@cartel, Just a mention -
Chrome isn't the only alternative. The reply button works ok in current Basilisk (2018.04.27) and FF52.*esr too
(though a FF52 UA override did nothing).


cartel wrote:I basically make my living with CL so its really important to me.

I don't know if, between us all, we've come up with the information that will facilitate a fix.
But FWIW, here's what I could see...

Error console
It had one CSP error, and one warning related to recaptcha.
Disabling CSP made the error disappear, but didn't fix anything:

Code: Select all

Error: Content Security Policy: The page's settings blocked the loading of a resource at about:blank
("base-uri https://www.google.com").

Warning: mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the
object with the correct initial [[Prototype]] value using Object.create
Source File: https://www.gstatic.com/recaptcha/api2/v1524685466525/recaptcha__en.js Line: 5

Web console

Code: Select all

POST XHR https://abbotsford.craigslist.ca/reply/abb/cto/6573975868 [HTTP/1.1 404 Not Found 113ms]

Code: Select all

Network Response Request
Request URL:    https://abbotsford.craigslist.ca/reply/abb/cto/6573975868
Request Method:    POST
Status Code:    HTTP/1.1 404 Not Found

Request Headers
X-Requested-With:   XMLHttpRequest
User-Agent:   Mozilla/5.0 (Windows NT 6.1; rv:3.4) Goanna/20180412 PaleMoon/27.9.0
Referer:   https://abbotsford.craigslist.ca/cto/d/2013-jeep-rubicon-2dr/6573975868.html
Pragma:   no-cache
Host:   abbotsford.craigslist.ca
Content-Type:   application/x-www-form-urlencoded; charset=UTF-8
Content-Length:   498
Connection:   keep-alive
Cache-Control:   no-cache
Accept-Language:   en-US,en;q=0.5
Accept-Encoding:   gzip, deflate, br
Accept:   */*

Response Headers
X-Frame-Options:   SAMEORIGIN
Vary:   Accept-Encoding
Strict-Transport-Security:   max-age=86400
Server:   Apache
Pragma:   no-cache
Last-Modified:   Tue, 01 May 2018 00:43:44 GMT
Expires:   Thu, 01 Jan 1970 00:00:00 GMT
Date:   Tue, 01 May 2018 00:43:44 GMT
Content-Type:   text/html; charset=UTF-8
Content-Length:   1860
Content-Encoding:   gzip
Cache-Control:   private
Last edited by coffeebreak on Tue, 01 May 2018, 01:20, edited 1 time in total.

User avatar
cartel
Lunatic
Lunatic
Posts: 321
Joined: Sun, 16 Mar 2014, 21:57
Location: Chilliwack, BC

Re: Emergency: craigslist reply button broken

Unread postby cartel » Tue, 01 May 2018, 21:52

I guess I'm moving over to basilisk.
PM had a great run but I feel there's a push to move on. Hopefully for the better.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 21946
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Emergency: craigslist reply button broken

Unread postby Moonchild » Tue, 01 May 2018, 22:11

"Oh no one function of one website stopped working probably because of the ineptitude of the web designers in charge of the site! Well, thanks for all the fish, bye"
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

User avatar
cartel
Lunatic
Lunatic
Posts: 321
Joined: Sun, 16 Mar 2014, 21:57
Location: Chilliwack, BC

Re: Emergency: craigslist reply button broken

Unread postby cartel » Wed, 02 May 2018, 03:04

Moonchild wrote:"Oh no one function of one website stopped working probably because of the ineptitude of the web designers in charge of the site! Well, thanks for all the fish, bye"

Well basilisk is your browser though right?
Its true CL did something but I cant reply to items with PM thats the most important part of the site, if I cant buy, I cant sell.

If you have a way for you to continue PM that would be great.

I thought the roadmap was to discontinue PM and shift to basilisk?

Sorry if I sounded negative I dont mean to.

User avatar
Nigaikaze
Keeps coming back
Keeps coming back
Posts: 805
Joined: Sun, 02 Feb 2014, 22:15
Location: Chicago, IL, USA

Re: Emergency: craigslist reply button broken

Unread postby Nigaikaze » Wed, 02 May 2018, 03:50

cartel wrote:I thought the roadmap was to discontinue PM and shift to basilisk?

You thought wrong.

User avatar
cartel
Lunatic
Lunatic
Posts: 321
Joined: Sun, 16 Mar 2014, 21:57
Location: Chilliwack, BC

Re: Emergency: craigslist reply button broken

Unread postby cartel » Wed, 02 May 2018, 04:01

Nigaikaze wrote:
cartel wrote:I thought the roadmap was to discontinue PM and shift to basilisk?

You thought wrong.

What does this have to do with Pale Moon?

UXP will be the long-term future for Pale Moon. As such, we need something (an application) to develop this alongside our current browser platform and back-end. Eventually, Pale Moon will become a "UXP application", just like Basilisk is now. UXP applications retain full customization and freedom in application layout code, so the "look and feel" will not significantly change when Pale Moon is moved to the new platform (somewhere in 2018). Basilisk will allow us to develop and mature UXP so it'll be ready when we want to move over to it.

ok...
Last edited by cartel on Wed, 02 May 2018, 04:02, edited 1 time in total.

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 4584
Joined: Tue, 09 Oct 2012, 19:37

Re: Emergency: craigslist reply button broken

Unread postby New Tobin Paradigm » Wed, 02 May 2018, 05:18

Pale Moon is already being.. HAS been ported to UXP.. We are just fixing what busted and verifying all the features.. Basically, same process we did for Tycho to produce Pale Moon 27.. Except the same.. Least from a Pale Moon only perspective.

SEE: https://github.com/MoonchildProductions/uxp/issues/57

But for the love of god do NOT comment to the metaissue..
Last edited by New Tobin Paradigm on Wed, 02 May 2018, 05:21, edited 2 times in total.

User avatar
cartel
Lunatic
Lunatic
Posts: 321
Joined: Sun, 16 Mar 2014, 21:57
Location: Chilliwack, BC

Re: Emergency: craigslist reply button broken

Unread postby cartel » Wed, 02 May 2018, 06:34

OK I must not have read it slow enough, I thought PM was moving to Basilisk, but in fact its UXP moving to PM.
I thought that was it, PM discontinued.

Heres me after putting this 24' antenna up on this pipe in my tree the other day.
Its for my "CB".

a8yk7uI.jpg


I try to research as much as I can but it takes a few tries to get back to reality.

I found with PM, nothing helped with this captcha psych-out.
Basilisk will do the same thing if I have google. com with a user agent of

Code: Select all

 general.useragent.override.google.com;Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.1
it does the same thing as PM.
When I change it to

Code: Select all

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.9) Gecko/20100101 Firefox/52.9
it works as expected.

CL did change something for sure, I tried user agents on PM as I said a fresh default profile and even the Basilisk agent on PM.
Tried permissions, compatiblities, not much else from default.

I can use Basilisk till this irons out. The browser is nice, looks just like PM for me.

2017003.jpg

2017004.jpg
Last edited by cartel on Wed, 02 May 2018, 06:50, edited 2 times in total.


Return to “General support”

Who is online

Users browsing this forum: Majestic-12 [Bot] and 11 guests