ClearType issue after upgrading to 7.0

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderators: trava90, satrow

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
ghysler

ClearType issue after upgrading to 7.0

Unread postby ghysler » Sat, 01 Oct 2011, 21:19

I just upgraded to Pale Moon 7.0 (x64) and now notice some issues with the font rendering. It has the effect of ClearType being turned off, which makes most letters very thin. The only comparison I have at the moment is IE9, and ofcourse Pale Moon 6.0.2 (x64), where it is/was just fine.

I've already played around with the render options in about:config, specifically the ClearType options, but changing it does not seem to have any effect at all. Also with a clean profile the problem is still there.
Curious if this is Pale Moon (x64?) specific, or is just changed in Firefox itself.
Any tips for "turning on" ClearType again?

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22589
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: ClearType issue after upgrading to 7.0

Unread postby Moonchild » Sat, 01 Oct 2011, 21:33

There is probably one parameter you have not tried, of which the behavior has changed in v7. It's possible that your particular setup has problems with native GDI font rendering which can happen with some integrated graphics chips specifically.

Try changing about:config gfx.font_rendering.cleartype_params.rendering_mode from the default -1 (auto select) to either 0, 4 or 5.

The possible settings are: 0 = default, 1 = aliased, 2 = GDI Classic, 3 = GDI Natural, 4 = Natural, 5 = Natural Symmetric
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

ghysler

Re: ClearType issue after upgrading to 7.0

Unread postby ghysler » Sat, 01 Oct 2011, 21:56

Thanks for the quick respond. Changing this parameter to either 0, 4, 5 has sadly no effect at all. I'm also not using an integrated graphic chip (AMD 5770).
Are there any other things changed in 7.0, which might effect the font rendering?

I see now the result in Firefox 7.0 is the same, so it doesn't seem Pale Moon specific. A few searches on Google on Firefox 7.0 and font rendering issues didn't give me any related results, that's why I chose to ask over here first.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22589
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: ClearType issue after upgrading to 7.0

Unread postby Moonchild » Sun, 02 Oct 2011, 07:06

I'm using an ATI card myself as well and can't reproduce the problem, so it's a little hard to troubleshoot if cleartype parameters have no effect. If it's actually forced off, have you tried setting:
  • gfx.font_rendering.cleartype.always_use_for_content to true
  • gfx.font_rendering.cleartype.use_for_downloadable_fonts to true
    and if that still doesn't help:
  • gfx.font_rendering.directwrite.enabled to false
  • gfx.font_rendering.directwrite.use_gdi_table_loading to false
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

ghysler

Re: ClearType issue after upgrading to 7.0

Unread postby ghysler » Sun, 02 Oct 2011, 08:21

I've managed to fix the problem by using the guide on this page: http://support.mozilla.com/en-US/questions/862106.
Now using the following parameter settings, which come straight from my registry ClearType settings:

gfx.font_rendering.cleartype_params.cleartype_level; 100
gfx.font_rendering.cleartype_params.enhanced_contrast; 200
gfx.font_rendering.cleartype_params.gamma; 2200
gfx.font_rendering.cleartype_params.pixel_structure; 1
gfx.font_rendering.cleartype_params.rendering_mode; 0

It seems that changing the paramater you first mentioned does have effect, but only when I change it together with the other parameters. Still haven't got a clue why it's not working with the default settings anymore.
The parameter gfx.font_rendering.directwrite.enabled is set to false by default in Pale Moon (also in previous releases). I always set this parameter to true and have never seen a problem with it. What's the reason it's disabled by default?

Are you by any chance using the Ad Muncher extension? Ad Muncher itself does not recognize Pale Moon (yet) In previous releases a manual installation still worked, but with 7.0 the extension is unable to connect to the Ad Muncher application running in the background.

Thanks again for the quick support, I really appreciate it. Pale Moon (x64) has been my #1 browser for quite some time now, it's just perfect! :D
(btw, is it really necessary for every single post to be approved by a moderator first? I do find this a bit annoying :) )

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22589
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: ClearType issue after upgrading to 7.0

Unread postby Moonchild » Sun, 02 Oct 2011, 15:26

The parameter gfx.font_rendering.directwrite.enabled is set to false by default in Pale Moon (also in previous releases). I always set this parameter to true and have never seen a problem with it. What's the reason it's disabled by default?

It's disabled by default because using DirectWrite for fonts breaks the rendering on a large number of integrated graphics drivers with incomplete support for it (i.e.: most owners of cheap laptops and baseline desktops). It's more of a headache to deal with support requests when it's set to on by default and I would rather not give people a bad experience with the default settings ;)

(btw, is it really necessary for every single post to be approved by a moderator first? I do find this a bit annoying :) )

Only for newly registered users - the first 3 posts by users have to be approved, after that it's assumed you are not here to cause trouble or spam the board.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne


Return to “General support”

Who is online

Users browsing this forum: BLEXBot [Crawler], makhan and 9 guests