Disappearing toolbar icons Topic is solved

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderator: trava90

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
Locked
User avatar
Tomaso
Board Warrior
Board Warrior
Posts: 1383
Joined: 2015-07-23, 16:09
Location: Norway

Disappearing toolbar icons

Post by Tomaso » 2017-09-19, 16:51

Up until today I've had the icons for these two extensions nicely placed in Pale Moons toolbar:
https://addons.mozilla.org/en-US/firefo ... eo-player/
https://addons.mozilla.org/en-US/firefo ... ion-52.0.3
But now, suddely and without any warning, they're gone, and it seems to be impossible to add them back!
I've got both 'extensions.update.autoUpdateDefault' and 'extensions.update.enabled' set to "false", so the extensions hasn't updated themselves or anything.
What exactly has happened?

(Pale Moon v27.4.2,x64 / Win8.1Pro)

User avatar
Pallid Planetoid
Knows the dark side
Knows the dark side
Posts: 3498
Joined: 2015-10-06, 16:59
Location: Los Angeles CA USA

Re: Disappearing toolbar icons

Post by Pallid Planetoid » 2017-09-19, 17:31

Presumably you have checked in the "Customize Toolbar" window for the extension icons (if you have not right-click in empty area of Navigation Toolbar and select "Customize..." for this where your extension icons probably are now. Just drag them back to where they were before. ;)).
Current Pale Moon(x86) Release | WIN10 | I5 CPU, 1.7 GHz, 6GB RAM, 500GB HD[20GB SSD]
Formerly user Pale Moon Rising - to provide context involving embedded reply threads.
Good judgment comes from experience and a lot of that comes from bad judgment. - Will Rogers
Knowing Pale Moon is indisputably #1 is defined by knowing the totality of browsers. - Pale Moon Rising

User avatar
Tomaso
Board Warrior
Board Warrior
Posts: 1383
Joined: 2015-07-23, 16:09
Location: Norway

Re: Disappearing toolbar icons

Post by Tomaso » 2017-09-19, 18:09

Naturally, that was the first thing that I tried.
I tried reinstalling the extensions too (using the very same XPI files that I used when the extensions worked), but the icons were nowhere to be found.
They were still configurable from 'Tools' > 'Add-ons' > 'Extensions' of course.
..but that didn't help, because they didn't remember their settings enymore either!
Next I tried running a fresh extraction of Pale Moon v27.4.2.1 Portable, completely blocking all internet access with my firewall..
Same thing; no icons, and the extensions did not remember the settings.
Only thing I could think of is that these extensions (by the same author) has some kind of built-in kill switch, forcing people into updating at a given time.
..so I tried setting the clock back one day, to Sep.18.
And guess what?.. the icons popped right back!!
If you don't believe me, then try for yourself.

--

EDIT1:
From the looks of it, I think that the kill switch code lies within the chrome\content\addonoptions.*** files.
Now, if I could just figure out what this stuff means, and how to fix it.

--

EDIT2:
Nah, even deleting those files completely, and rebuilding the XPI files without them, didn't work.
Need to have someone take a look at this, that knows what they're doing.

--

EDIT3:
Oh, btw..
The version that I was using of 'YouTube High Definition' was v52.0.7, which was the last Pale Moon compatible release.
For some reason, none of the versions between v52.0.3 and v61.3 are available at mozilla.org anymore, so I've uploaded v52.0.7 here:
http://www.mediafire.com/file/2uj14f73m ... 52.0.7.zip

droyder

Re: Disappearing toolbar icons

Post by droyder » 2017-09-20, 05:02

I'm having the same problem with the YouTube High Definition extension icon having suddenly disappeared. :oops:

The extension is still appearing under my list of add-ons, but I can't get that "HD" icon to re-appear. (And it's not available to select and move under the Customization Toolbar option either.)

Also, more importantly, the Video Quality, Volume, and Auto Play settings that I've selected within the extension itself are not being applied on YouTube videos I watch. So it's as if the extension isn't functioning at all.

User avatar
Tomaso
Board Warrior
Board Warrior
Posts: 1383
Joined: 2015-07-23, 16:09
Location: Norway

Re: Disappearing toolbar icons

Post by Tomaso » 2017-09-20, 09:41

Can you confirm what I wrote about the built-in kill switch feature?
To confirm, simply set your PC clock back to September 18th and restart Pale Moon.
(If you're using an older version than 52.0.7, it might be necessary to set the clock further back)

User avatar
JustOff
Localization Coordinator
Localization Coordinator
Posts: 1896
Joined: 2015-09-03, 19:47
Location: UA
Contact:

Re: Disappearing toolbar icons

Post by JustOff » 2017-09-20, 15:48

Baris Derin's extensions are well known as time-limited. Each of them at the beginning of the file bootstrap.js contains the build constant, which defines the maximum allowed date in unixtime format. You can increase this value to unlock the add-on, but as for the old extensions for YouTube, they probably will not work correctly anyway due to the large number of changes made by Google recently.
Here are the add-ons I made in a spare time. That was fun!

User avatar
Tomaso
Board Warrior
Board Warrior
Posts: 1383
Joined: 2015-07-23, 16:09
Location: Norway

Re: Disappearing toolbar icons

Post by Tomaso » 2017-09-20, 16:01

Thank you so much for your help, JustOff!
Modifying that value did the trick!! :)

droyder

Re: Disappearing toolbar icons

Post by droyder » 2017-09-21, 06:40

Tomaso wrote:Thank you so much for your help, JustOff!
Modifying that value did the trick!! :)
Would you mind explaining how I can find that file and how to edit the value? Do I need to download some type of program/tool to do so? I tried searching my entire hard drive for "bootstrap.jp" but it's not locating anything, so I'm guessing I'm on the wrong track here.

And yes, I'm on 52.0.7 and the current version of PM. Thanks for any help!

User avatar
Tomaso
Board Warrior
Board Warrior
Posts: 1383
Joined: 2015-07-23, 16:09
Location: Norway

Re: Disappearing toolbar icons

Post by Tomaso » 2017-09-21, 10:19

@ droyder; check you pm's.

Locked