Problem opening PM "Profile Manager" Topic is solved

Users and developers helping users with generic and technical Pale Moon issues on all operating systems.
Please direct questions that are Mac or Linux-specific (dealing with installation and OS integration) to the appropriate Linux or Mac board.

Moderator: trava90

Forum rules
This board is for technical/general usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions that are specific for Linux and Mac to the dedicated boards for those operating systems.
Technical issues and questions not related to the Pale Moon browser should be posted in other boards!
Please keep off-topic and general discussion out of this board, thank you!
Locked
User avatar
bawldiggle
Lunatic
Lunatic
Posts: 440
Joined: 2013-02-22, 21:16
Location: East Coast Australia

Problem opening PM "Profile Manager"

Post by bawldiggle » 2016-03-25, 08:07

.
PM is installed on my PC in a custom folder ...

Code: Select all

C:\Programs2\PaleMoon\
From HowTo create a new Pale Moon Profile & use the Safemode tutorial

Using all these strings in "Start" ...

Code: Select all

"C:\Programs2\PaleMoon\palemoon.exe" -p
C:\Programs2\PaleMoon\palemoon.exe -p
palemoon.exe -p 
... all that opens is my PM default search page , ie, DuckDuckGo search engine
I have been trawling through this forum, via searches and the tutorials for the last 2 hours :crazy:

I am really stuck and would appreciate any help ... thank you :)
Win-7 PRO 64-bit
Palemoon; auto updates current version (32-bit)

User avatar
Pallid Planetoid
Knows the dark side
Knows the dark side
Posts: 3851
Joined: 2015-10-06, 16:59
Location: Los Angeles CA USA

Re: Problem opening PM "Profile Manager"

Post by Pallid Planetoid » 2016-03-25, 08:33

Have you tried just typing "palemoon -p" (w/out quotes) in your Windows Start Menu (w/out the paths and/or the "exe")?

Note: You will have to have exited Pale Moon (cannot have PM open) to do this (otherwise I think it will just start a new instance of PM). If you wanted to use the Profile Manager and keep your browser open then enter this instead: "palemoon -p -no-remote" (w/out quotes). Note: Keep in mind in this case the profile currently in use will be locked and of course then can't be deleted or renamed.

Note: The only reason you would need the path and "exe" would be if you're creating a short-cut to the Profile Manager and would need a "target" path and you wouldn't be using the Start Menu for this. If you are creating a shortcut then in your case you would use your first example as the target: "C:\Programs2\PaleMoon\palemoon.exe" -p
Current Pale Moon(x86) Release | WIN10 | I5 CPU, 1.7 GHz, 6GB RAM, 500GB HD[20GB SSD]
Formerly user Pale Moon Rising - to provide context involving embedded reply threads.
Good judgment comes from experience and a lot of that comes from bad judgment. - Will Rogers
Knowing Pale Moon is indisputably #1 is defined by knowing the totality of browsers. - Pale Moon Rising

Andrew Gilbertson

Re: Problem opening PM "Profile Manager"

Post by Andrew Gilbertson » 2016-03-25, 11:30

Try this:

Code: Select all

palemoon -no-remote -ProfileManager
If I recall correctly, if there is a profile named "default" and no other profiles, Pale Moon will open with the default profile even if you provide the -p option. The -ProfileManager option should open the Profile Manager, which will allow you to create a new profile; and the -no-remote option tells the new instance of Pale Moon not to try to communicate with any other processes on the system (in other words, even if Pale Moon is your default browser, this new instance won't open links from external programs).

User avatar
[Gort]
Apollo supporter
Apollo supporter
Posts: 40
Joined: 2016-02-13, 00:18
Location: UK

Re: Problem opening PM "Profile Manager"

Post by [Gort] » 2016-03-25, 15:30

AndyTheAbsurd wrote:Try this:

Code: Select all

palemoon -no-remote -ProfileManager
If I recall correctly, if there is a profile named "default" and no other profiles, Pale Moon will open with the default profile even if you provide the -p option.
Not in my experience (32-bit version of Pale Moon on a 64-bit version of Windows 8.1). I regularly use the profile manager to check if a supposed bug or issue is really one that's due to Pale Moon or just due to my default profile. After the test, I just delete the test profile, so that I only have the default profile left. I use the command "palemoon -no-remote -p" (no quotes) to open the profile manager while still running my default profile, which saves restarting Pale Moon after the test.

User avatar
x-15a2
Keeps coming back
Keeps coming back
Posts: 825
Joined: 2014-03-19, 00:28
Location: Triskelion

Re: Problem opening PM "Profile Manager"

Post by x-15a2 » 2016-03-25, 15:53

First, using the quotes and the .exe has nothing to do with it. Look at the shortcut properties (if using Windows) and you'll see that both are being used.

Instead of -P, use -ProfileManager

coffeebreak
Moon Magic practitioner
Moon Magic practitioner
Posts: 2667
Joined: 2015-09-26, 04:51
Location: U.S.

Re: Problem opening PM "Profile Manager"

Post by coffeebreak » 2016-03-25, 16:33

[Gort] wrote:I use the command "palemoon -no-remote -p" (no quotes) to open the profile manager while still running my default profile, which saves restarting Pale Moon after the test.

That's what I use as well and have never had it fail to work.
bawldiggle wrote:Using all these strings in "Start" ...

Code: Select all

"C:\Programs2\PaleMoon\palemoon.exe" -p
C:\Programs2\PaleMoon\palemoon.exe -p
palemoon.exe -p 
... all that opens is my PM default search page , ie, DuckDuckGo search engine
It looks like omitting -no-remote could be the problem (if you have the browser open while trying these commands).

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 29663
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: Problem opening PM "Profile Manager"

Post by Moonchild » 2016-03-28, 10:08

You have to make sure Pale Moon is completely shut down (Pale Moon button -> Exit, or File -> Exit) before trying to call up the profile manager.
-no-remote may not work if there's only one profile defined (I haven't looked in detail into the logic of the profile manager, but I assume this is a possibility)
"Son, in life you do not fight battles because you expect to win, you fight them merely because they need to be fought." -- Snagglepuss
Image

Locked