Searchbar automatic went to adressbar!

Users and developers helping users with generic and technical Pale Moon issues on all operating systems.

Moderator: trava90

Forum rules
This board is for technical/general usage questions and troubleshooting for the Pale Moon browser only.
Technical issues and questions not related to the Pale Moon browser should be posted in other boards!
Please keep off-topic and general discussion out of this board, thank you!
llorc
Hobby Astronomer
Hobby Astronomer
Posts: 24
Joined: 2016-06-03, 16:17

Searchbar automatic went to adressbar!

Unread post by llorc » 2021-10-25, 15:23

Hello,
sometimes when searching,
my palemoon dont show answers,it just work like the adressbar,
and i cant go back to my duckgo page.
Is there a trick in about:config to stop this strange behaviour ?

many thanks,

llorc

vannilla
Board Warrior
Board Warrior
Posts: 1816
Joined: 2018-05-05, 13:29

Re: Searchbar automatic went to adressbar!

Unread post by vannilla » 2021-10-25, 15:55

Use the dedicated search bar which can be added to the UI through the customize window (right click on a toolbar and click on customize.)

coffeebreak
Moon Magic practitioner
Moon Magic practitioner
Posts: 2867
Joined: 2015-09-26, 04:51
Location: U.S.

Re: Searchbar automatic went to adressbar!

Unread post by coffeebreak » 2021-10-25, 19:30

Assuming first that keyword.enabled (master-switch pref for searching from the address bar) is set to the default, true, in about:config...

I'm pretty sure there is no other setting to ensure that you get your desired behavior every single time without exception.

AFAIU the browser has to make a judgment about your intentions every time something is typed in the address bar, and occasionally it guesses wrong, depending on what was entered (some discussion here and here).

Another option you might consider, in addition to using the search bar, is keyword searches, in which you bookmark your search engines' pages and assign keywords to those bookmarks. It would allow to type your search in the address bar after first typing the relevant bookmark's keyword.

Blacklab
Keeps coming back
Keeps coming back
Posts: 787
Joined: 2012-06-08, 12:14
Location: Scotland UK (Maybe)

Re: Searchbar automatic went to adressbar!

Unread post by Blacklab » 2021-10-25, 23:38

llorc wrote:sometimes when searching, my palemoon dont show answers, it just work like the addressbar, and i cant go back to my duckgo page.
As coffeebreak says above the preference 'keyword.enabled' is the master switch and will turn the 'Domain Guessing and Auto-completing URLs' feature on or off. Open 'about:config' > Search for 'keyword.enabled' > Double-click on 'keyword.enabled' > Right-click and use 'Toggle' to change to either 'true' (on/enabled) or 'false' (off/disabled).

However, AFAICS there are several other about:config preferences that can affect the operation of the combined Searchbar & Addressbar and these are probably worth investigating as well e.g. 'browser.urlbar.autocomplete.enabled' and 'browser.fixup.alternate.enabled'. More info in Mozillazine Knowledge Base and old Mozilla Support articles and good discussion in the two previous forum threads coffeebreak suggested.

browser.fixup preferences.jpg
--- The 5 browser.fixup preferences in Pale Moon's about:config ---


FWIW - Personally I use the Address/URL/Navigation Bar for navigation only...and search in another tab using my Home Page which has my preferred DuckDuckGo settings string saved. Different strokes for different folks! :)

llorc
Hobby Astronomer
Hobby Astronomer
Posts: 24
Joined: 2016-06-03, 16:17

Re: Searchbar automatic went to adressbar!

Unread post by llorc » 2021-10-26, 05:57

Hello,and many thanks for reply!
My Browser looks like this:
Zwischenablage01.jpg
[/size]

When searching sometimes i come directly to a side,and cant go back again!
I tried both keyword options,but nothing changed!

but anyway,many thanks for help !

llorc

Post Reply