Page not loading at all

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderators: trava90, satrow

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
Octopuss
Lunatic
Lunatic
Posts: 347
Joined: Mon, 26 Jan 2015, 13:58

Page not loading at all

Postby Octopuss » Mon, 14 May 2018, 16:13


User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3194
Joined: Mon, 03 Oct 2011, 10:19
Location: Texas, USA

Re: Page not loading at all

Postby Night Wing » Mon, 14 May 2018, 16:17

I clicked on your link using 64 bit linux Pale Moon 27.9.1 running in 64 bit linux Mint 18.3 (Sylvia) Xfce. It loaded the Magic Lantern Forum Index page in 1 second of time.
Linux Mint 18.3 (Sylvia) Xfce 64-Bit (Default OS) with 64-Bit linux Pale Moon
Windows 7 SP1 64 Bit (Backup OS) with 32-Bit windows Pale Moon

User avatar
rabnbeinn
Lunatic
Lunatic
Posts: 258
Joined: Fri, 18 Nov 2011, 20:38
Location: Scotland

Re: Page not loading at all

Postby rabnbeinn » Mon, 14 May 2018, 17:17

Page not loading: Confirmed.

Tried all 3 UAMs and in safe mode.

Win 8.1 (x64)
Pm 27.9.1 (x64)

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3194
Joined: Mon, 03 Oct 2011, 10:19
Location: Texas, USA

Re: Page not loading at all

Postby Night Wing » Mon, 14 May 2018, 17:39

I switched over to my windows hard drive in this tower computer. After clicking on the link using 32 bit windows Pale Moon 27.9.1 running in 64 bit Windows 7 Home Premium, SP1; the Magic Lantern Forum Index page does "not" load.

So the page loads without any problems in 64 bit linux Pale Moon, but does not load in 32 bit windows Pale Moon. Looks like a hiccup with Pale Moon in the windows operating system.
Last edited by Night Wing on Mon, 14 May 2018, 17:40, edited 2 times in total.
Linux Mint 18.3 (Sylvia) Xfce 64-Bit (Default OS) with 64-Bit linux Pale Moon
Windows 7 SP1 64 Bit (Backup OS) with 32-Bit windows Pale Moon

GMforker
Lunatic
Lunatic
Posts: 497
Joined: Thu, 27 Aug 2015, 06:29
Location: Czech Republic

Re: Page not loading at all

Postby GMforker » Mon, 14 May 2018, 17:50

Page not loading

Because, this script does not load (blocked on the server?):
https://www.magiclantern.fm/forum/Theme ... t.js?fin20

Fixed (e.g.):
about:config

Code: Select all

general.useragent.override.magiclantern.fm = Pale Moon MSIE

(I will not search for other strings)

Nightbird
Fanatic
Fanatic
Posts: 100
Joined: Mon, 18 Jul 2016, 21:12

Re: Page not loading at all

Postby Nightbird » Mon, 14 May 2018, 18:50

Site works as soon as you block scripts or as soon as you override with an IE string
Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; Trident/4.0)

Goodydino
Fanatic
Fanatic
Posts: 212
Joined: Tue, 10 Oct 2017, 21:20

Re: Page not loading at all

Postby Goodydino » Mon, 14 May 2018, 21:05

That site does not seem to like Pale Moon. It works with SeaMonkey, Opera and Safari. Trying to block scripts with YesScript did not work well either.

coffeebreak
Board Warrior
Board Warrior
Posts: 1175
Joined: Sat, 26 Sep 2015, 04:51
Location: U.S.

Re: Page not loading at all

Postby coffeebreak » Mon, 14 May 2018, 21:39

It looks to be cloudflare's rocket-loader script again.

Code: Select all

https://ajax.cloudflare.com/cdn-cgi/scripts/dba9ecf7/cloudflare-static/rocket-loader.min.js

Error console.

Code: Select all

Error: Permission denied to access property "handleEvent"
Source File: https://ajax.cloudflare.com/cdn-cgi/scripts/dba9ecf7/cloudflare-static/rocket-loader.min.js
Line: 1

Error: ReferenceError: is_ie is not defined
Source File: https://www.magiclantern.fm/forum/Themes/default/scripts/theme.js?fin20 Line: 7

The page did load for me when scripts from cloudflare were blocked.

See https://forum.palemoon.org/viewtopic.php?f=3&t=19104
and https://forum.palemoon.org/viewtopic.php?f=37&t=19143
Last edited by coffeebreak on Mon, 14 May 2018, 21:46, edited 1 time in total.

Frasier
Moon lover
Moon lover
Posts: 88
Joined: Wed, 07 May 2014, 02:44
Location: Indiana

Re: Page not loading at all

Postby Frasier » Tue, 15 May 2018, 00:22

coffeebreak wrote:It looks to be cloudflare's rocket-loader script again.

Code: Select all

https://ajax.cloudflare.com/cdn-cgi/scripts/dba9ecf7/cloudflare-static/rocket-loader.min.js

Yep, that's the culprit, again. Wondered why the magiclantern forum loaded with no problems, then realized I had already blocked that script in the adblocker.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3194
Joined: Mon, 03 Oct 2011, 10:19
Location: Texas, USA

Re: Page not loading at all

Postby Night Wing » Tue, 15 May 2018, 01:00

I had also blocked "ajax.cloudflare" in my Domain Blocker in linux Mint for some other site so this is why my linux Pale Moon loaded the Green Lantern page.
Last edited by Night Wing on Tue, 15 May 2018, 01:01, edited 1 time in total.
Linux Mint 18.3 (Sylvia) Xfce 64-Bit (Default OS) with 64-Bit linux Pale Moon
Windows 7 SP1 64 Bit (Backup OS) with 32-Bit windows Pale Moon

Octopuss
Lunatic
Lunatic
Posts: 347
Joined: Mon, 26 Jan 2015, 13:58

Re: Page not loading at all

Postby Octopuss » Tue, 15 May 2018, 14:32

What does that script do?
Cloudflare is some web hosting, right?

Frasier
Moon lover
Moon lover
Posts: 88
Joined: Wed, 07 May 2014, 02:44
Location: Indiana

Re: Page not loading at all

Postby Frasier » Tue, 15 May 2018, 14:48

Octopuss wrote:What does that script do?
Cloudflare is some web hosting, right?
See these two posts:
Re: craigmurray .org.uk/
Re: craigmurray .org.uk/

User avatar
badnick
Fanatic
Fanatic
Posts: 249
Joined: Thu, 23 Mar 2017, 19:56

Re: Page not loading at all

Postby badnick » Wed, 16 May 2018, 19:50

This page works for me ( PM 27.9.1/Win 10 / 64)

User avatar
rabnbeinn
Lunatic
Lunatic
Posts: 258
Joined: Fri, 18 Nov 2011, 20:38
Location: Scotland

Re: Page not loading at all

Postby rabnbeinn » Thu, 17 May 2018, 13:09

It now also opens for me when it wouldn't 2 days ago (as posted)

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 20995
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Page not loading at all

Postby Moonchild » Thu, 17 May 2018, 15:42

Looks like CF might have fixed their script.
I'm asking for a status update.
Last edited by Moonchild on Thu, 17 May 2018, 15:43, edited 1 time in total.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 20995
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Page not loading at all

Postby Moonchild » Thu, 17 May 2018, 21:30

Cloudflare has deployed a fix for this issue in their script.
If pages still don't load, you need to clear your browser cache to get rid of cached versions of their script, navigate to the problematic page again.
(Preferences -> Advanced -> tab Network -> [Clear now] button under "Cached Web Content")
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

Octopuss
Lunatic
Lunatic
Posts: 347
Joined: Mon, 26 Jan 2015, 13:58

Re: Page not loading at all

Postby Octopuss » Fri, 18 May 2018, 07:17

Moonchild wrote:Looks like CF might have fixed their script.
I'm asking for a status update.

Ha, it works!


Return to “General support”

Who is online

Users browsing this forum: No registered users and 13 guests