Pale Moon 64 fails to load Blip.TV videos

The place to report Pale Moon specific bugs on the Windows operating system.

Moderator: satrow

Hobbit

Pale Moon 64 fails to load Blip.TV videos

Unread post by Hobbit » 2014-09-27, 00:42

Heyas,

I just switched to Pale Moon 64 24.7.2 over from Firefox, and everything worked fine until I tried to watch videos on Blip.tv.

For example: http://blip.tv/OLPresents/olp-moon-of-the-wolf-7006800

When I load that page up, there's just a black square where the flash video should be. When I right-click he square, I don't see the usual flash menu options ("About Adobe Flash Player", etc.). It's like there's no video, the flash isn't even trying to load. It seems like a blank frame.

The problem happens even when I restart Pale Moon with add-ons disabled.

Flash 15.0.0.152 is listed in Pale Moon's plugins. When I go to the Adobe Flash test page, it works. And YouTube works fine, so does Daily Motion and any other flash video site I can think of. When I load the same URL up in Chrome, or Firefox 32.0.3, the video loads fine.

Suspecting it might be a 64-bit problem (I'm pretty sure my other browsers are 32-bit), I tried installing Pale Moon 32, but it didn't make any difference. Blip.TV videos just aren't loading for me in Pale Moon.

I searched the forums, couldn't find anything about a Blip.tv bug, so I figured it'd help to post this here

P.S. I'm running Windows 7 Pro 64-bit, fully updated with Windows Update.

ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2014
Joined: 2012-06-28, 01:20

Re: Pale Moon 64 fails to load Blip.TV videos

Unread post by ron_1 » 2014-09-27, 20:40

I just tested it and videos from blip.tv also does not work for me.

Hobbit

Re: Pale Moon 64 fails to load Blip.TV videos

Unread post by Hobbit » 2014-09-27, 20:57

Hmm, so it's not just me then? That's a relief. :)

Here's another development: Pale Moon seems to be able to play embedded Blip.TV videos.

Here's the Blip.TV video embedded on a site called That Guy With the Glasses:

http://thatguywiththeglasses.com/videol ... f-the-wolf

On TGWTG, the video placeholders load. Press play and the video will begin. (Wait through the ads if you must). So far, so good.

But! If you press the white "BLIP" icon in the lower-right of the video, it will open a new tab with the same video playing on Blip.TV's site:

http://blip.tv/OLPresents/olp-moon-of-the-wolf-7006800

Here, there IS no placeholder image, no way to play the video. And when I right-click the empty black box, it's like flash isn't even here, just an empty frame or something.

Very strange.

I even tried using the User Agent Overrider addon to mask my Pale Moon as Firefox 29, just in case Blip.TV's site is mystified by the Pale Moon user agent, but that didn't seem to help.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24224
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Pale Moon 64 fails to load Blip.TV videos

Unread post by Moonchild » 2014-09-27, 21:41

Blip.tv does something really odd in their flash-based video player. I even made it hang up and crash the flash plugin by right-clicking the video (that indeed doesn't load and just shows black, on a 32-bit version). Certainly something in the realm of flash scripting that is amiss, because the browser otherwise works just fine rendering their pages.
City of Heroes public server: https://www.moonshard.org/ -- Vote for it on cohservers.com

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

Ageless

Re: Pale Moon 64 fails to load Blip.TV videos

Unread post by Ageless » 2014-10-01, 22:08

Hobbit wrote:Here's another development: Pale Moon seems to be able to play embedded Blip.TV videos.
Embedded Blip.tv videos don't play for me. All of the videos on Achievement Hunter ceased playing about two weeks ago, almost overnight. No updates on Pale Moon or Flash during that time, so it must (again) be something about Blip.tv, probably their advertisements. Example video from AH: http://ah.roosterteeth.com/archive/?id=9756

No problems with Youtube videos on the Youtube site.

I did disable Flashblock and Adblock Plus for the site, didn't matter.
Pale Moon 24.7.2 - 64bit.
Flash 15.0.0.152.
Windows 7 - 64bit.

So I use IE 11 for playing videos on AH these days.

Ageless

Re: Pale Moon 64 fails to load Blip.TV videos

Unread post by Ageless » 2014-10-07, 20:33

All right, Blip.tv has fixed a couple of things. New videos will now work, older videos that didn't work before still don't work.
All new videos on http://achievementhunter.com/home.php work again.

Locked