Dplay.* - videos won't play Topic is solved

The place to report Pale Moon specific bugs on the Windows operating system.
Post Reply
User avatar
Tomaso
Board Warrior
Board Warrior
Posts: 1383
Joined: 2015-07-23, 16:09
Location: Norway

Dplay.* - videos won't play

Post by Tomaso » 2019-11-25, 13:07

Issue:
Videos won't play at the Nordic Dplay sites.

Affected sites:
https://www.dplay.dk/
https://www.dplay.fi/
https://www.dplay.no/
https://www.dplay.se/

Error in Pale Moon's console:

Code: Select all

Strict-Transport-Security: The site specified a header that could not be parsed successfully.
What I've tried, so far:
* Disabling Strict Transport Security (No effect, and the above error message appears regarlessly).
* Disabling MSE (No effect).
* Disabling adblocking (No effect).
* Various UA overrides (No effect).
* Latest unstable Pale Moon build (Same problem).
* Basilisk (Same problem).
* Mozregression (The videos played just fine, in all Firefox builds tested).

josephd
Fanatic
Fanatic
Posts: 101
Joined: 2014-09-09, 12:15
Location: Tennessee

Re: Dplay.* - videos won't play

Post by josephd » 2019-11-25, 14:18

The sites mentioned load fine. Video will not play for me either, dplay.dk/ requests me to login. The other 3 state they are out of my region. I disabled nothing. Had no errors in console.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25807
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Dplay.* - videos won't play

Post by Moonchild » 2019-11-25, 14:39

"something unexpected happened" -- and the web console is filled with a whole slew of errors in minified blobs that can't be troubleshot even if you would try to.

Also, when trying different compatmode, it's simply telling people to use Firefox or Chrome (IE is also not supported) with the rather rude message:
Image1.png
"That's typical, your browser is not supported by us.
The site does not work with your browser. Below you find our recommendations of browser which we know work much better than what you are using.
Please try to download one of these.
Google Chrome
Mozilla Firefox"
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

User avatar
Tomaso
Board Warrior
Board Warrior
Posts: 1383
Joined: 2015-07-23, 16:09
Location: Norway

Re: Dplay.* - videos won't play

Post by Tomaso » 2019-11-25, 15:37

OK, thanks for looking into it.

User avatar
gepus
Lunatic
Lunatic
Posts: 407
Joined: 2017-12-14, 12:59

Re: Dplay.* - videos won't play

Post by gepus » 2019-11-26, 11:33

@Moonchild
Have you cookies blocked by accident?
If blocked I get what your screenshot shows. Otherwise the site loads fine.

@Tomaso
It's impossible to check the videos since either I'm prompted for a login or the videos are not for my region.
Same applies if I test with IceCat 68.2.0esr.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25807
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Dplay.* - videos won't play

Post by Moonchild » 2019-11-26, 12:13

gepus wrote:
2019-11-26, 11:33
Have you cookies blocked by accident?
I never block cookies.
The screen shows if you give them an "unknown" useragent.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

User avatar
gepus
Lunatic
Lunatic
Posts: 407
Joined: 2017-12-14, 12:59

Re: Dplay.* - videos won't play

Post by gepus » 2019-11-26, 12:54

Moonchild wrote:
2019-11-26, 12:13
The screen shows if you give them an "unknown" useragent.
I see.
However, Pale Moon in default compatibility mode doesn't seem to give such an "unknown" user agent since the page loads fine.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25807
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Dplay.* - videos won't play

Post by Moonchild » 2019-11-26, 13:00

gepus wrote:
2019-11-26, 12:54
Moonchild wrote:
2019-11-26, 12:13
The screen shows if you give them an "unknown" useragent.
I see.
However, Pale Moon in default compatibility mode doesn't seem to give such an "unknown" user agent since the page loads fine.
:roll: might want to read a little closer what I wrote.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

Post Reply