Bank login page displays incorrectly

The place to report Pale Moon specific bugs on the Windows operating system.
Post Reply
User avatar
Nixal
Newbie
Newbie
Posts: 6
Joined: 2019-09-17, 08:01

Bank login page displays incorrectly

Post by Nixal » 2019-09-17, 11:37

This problem has been happening since Pale Moon 28.7.0 32-bit and is the same in 28.7.1 32-bit, on Windows 7 Professional 64-bit.

Following this link to log in to Swedbank, a Swedish bank: https://online.swedbank.se/app/privat/?ns=1

The login page doesn't display correctly in Pale Moon. The page that is shown when signed in also doesn't display correctly.
Here are two images for comparison. One for how it currently looks in Pale Moon:
Swedbank Pale Moon.jpg
And one for how it looks in Chrome and more or less used to look in Pale Moon (probably not exactly the same because of rendering differences):
Swedbank Chrome.jpg
I can contact the bank if this is on their end, but I have a feeling they will say it's a problem with the browser, so I report it here first just in case something might have changed in 28.7.0.

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 6730
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: Bank login page displays incorrectly

Post by New Tobin Paradigm » 2019-09-17, 12:26

Code: Select all

Timestamp: 9/17/2019 8:25:05 AM
Error: TypeError: Not enough arguments to CSSStyleSheet.insertRule.
Source File: https://online.swedbank.se/SWB-PRIVATE-160.1.0-2019-09-13_16_21_33/src/app.878aa3fe5f0656d46d3d.js
Line: 690

Timestamp: 9/17/2019 8:25:06 AM
Error: XML Parsing Error: no root element found
Location: https://online.swedbank.se/campaign/ads
Line Number 1, Column 1:
Source File: https://online.swedbank.se/campaign/ads
Line: 1

Timestamp: 9/17/2019 8:25:07 AM
Error: TypeError: Not enough arguments to CSSStyleSheet.insertRule.
Source File: https://online.swedbank.se/SWB-PRIVATE-160.1.0-2019-09-13_16_21_33/src/app.878aa3fe5f0656d46d3d.js
Line: 690

Timestamp: 9/17/2019 8:25:08 AM
Error: XML Parsing Error: no root element found
Location: https://online.swedbank.se/campaign/ads
Line Number 1, Column 1:
Source File: https://online.swedbank.se/campaign/ads
Line: 1

Timestamp: 9/17/2019 8:25:08 AM
Error: XML Parsing Error: no root element found
Location: https://online.swedbank.se/is/hc2
Line Number 1, Column 1:
Source File: https://online.swedbank.se/is/hc2
Line: 1
Image
- You should never hand someone a gun unless you're sure where they'll point it. -
https://binaryoutcast.com/ | http://thereisonlyxul.org/ | Freenode #binaryoutcast

User avatar
Nixal
Newbie
Newbie
Posts: 6
Joined: 2019-09-17, 08:01

Re: Bank login page displays incorrectly

Post by Nixal » 2019-09-17, 17:47

I contacted the bank, ready to supply that information, but as could be expected their answer was that they only support mainstream browsers.

The site can still be used in Pale Moon, it just doesn't display properly.

So I guess it's business as usual. You can use any browser you want as long as you use Chrome.

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 6730
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: Bank login page displays incorrectly

Post by New Tobin Paradigm » 2019-09-17, 17:56

I am sure we will get whatever underlying feature it is using eventually. Just needed logged as it was.

Also, yeah. Chrome, Chrome (Opera), Chrome (New Edge), Chrome (Brave), Chrome (Vivaldi), Pseudo-Chrome Wanna be/Gecko (Firefox and rebuilds like Waterfox), Pseudo-Chrome Clone/Trident (Original Edge maybe IE11), Pseudo-Chrome/Non-Blink Webkit (Safari), and MAYBE khtml.. if you are lucky.

No time for Goanna and UXP Applications. Sucks doesn't it?

Maybe you need a different bank :shh:
Image
- You should never hand someone a gun unless you're sure where they'll point it. -
https://binaryoutcast.com/ | http://thereisonlyxul.org/ | Freenode #binaryoutcast

User avatar
Tomaso
Board Warrior
Board Warrior
Posts: 1383
Joined: 2015-07-23, 16:09
Location: Norway

Re: Bank login page displays incorrectly

Post by Tomaso » 2019-09-18, 09:15

Mozregression result:
* Last bad: Firefox v55.0a1 (2017-04-20)
* First good: Firefox v55.0a1 (2017-04-21)

Pushlog:
https://hg.mozilla.org/mozilla-central/ ... b52715852a

User avatar
adesh
Keeps coming back
Keeps coming back
Posts: 811
Joined: 2017-06-06, 07:38

Re: Bank login page displays incorrectly

Post by adesh » 2019-09-18, 16:15

Thanks Tomaso!

That should be: https://hg.mozilla.org/mozilla-central/ ... 2442135725
Bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1358018

It's actually a two-line change, should be trivial to port.

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 6730
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: Bank login page displays incorrectly

Post by New Tobin Paradigm » 2019-11-28, 12:59

Issue #1304 (UXP)

RESOLVED FIXED
Image
- You should never hand someone a gun unless you're sure where they'll point it. -
https://binaryoutcast.com/ | http://thereisonlyxul.org/ | Freenode #binaryoutcast

User avatar
Nixal
Newbie
Newbie
Posts: 6
Joined: 2019-09-17, 08:01

Re: Bank login page displays incorrectly

Post by Nixal » 2019-12-10, 20:13

I appreciate the fix, the login page now displays correctly. Unfortunately, the site doesn't display correctly when logged in.

There is a menu to the left, with content supposed to be shown to the right of the menu. In Pale Moon there is only white space to the right of the menu, with all the content moved down below the menu. The site can still be used, the content is just misplaced so one has to scroll down.

I can show pictures with sensitive information obscured if needed.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25807
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Bank login page displays incorrectly

Post by Moonchild » 2019-12-11, 11:41

I'm afraid images won't be of much help because it's not possible to the page structure/styling from an image.
I would be able to investigate if I had a Swedbank account but I do not.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

Freddy
Moongazer
Moongazer
Posts: 10
Joined: 2016-11-05, 04:54

Re: Bank login page displays incorrectly

Post by Freddy » 2020-01-06, 06:24

Moonchild wrote:
2019-12-11, 11:41
I'm afraid images won't be of much help because it's not possible to the page structure/styling from an image.
I would be able to investigate if I had a Swedbank account but I do not.
You can access the demo version without an account.

They appear to be using some kind of messy combination of flexbox and grid.

User avatar
adesh
Keeps coming back
Keeps coming back
Posts: 811
Joined: 2017-06-06, 07:38

Re: Bank login page displays incorrectly

Post by adesh » 2020-01-06, 07:09

Off-topic:
They seem to be loading 14 MB of javascript file on that page, which is ridiculous. Not a work of good engineers. No wonder their site has issues.
https://demo.swedbank.se/SWB-PRIVATEDEM ... 6aabae4.js

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25807
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Bank login page displays incorrectly

Post by Moonchild » 2020-01-06, 11:05

It's an absolute mess with many nesting levels each being given individual CSS rules with many duplications. They are mixing absolute, static and fixed positioning, they are mixing flex and grid, column and row ordering, many forced percentage widths and sizing, and it's not possible to reasonably drill down into their design to figure out where exactly it goes wrong. I'm surprised it even works on more than one browser as it is...
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

Freddy
Moongazer
Moongazer
Posts: 10
Joined: 2016-11-05, 04:54

Re: Bank login page displays incorrectly

Post by Freddy » 2020-01-06, 12:31

From what I can tell, it seems that the grid container does not have its display property set to grid (or inline-grid).
At first, I guessed that maybe other browsers implicitly display it as a grid because the grid-template-columns and grid-template-rows properties are set. Then I actually checked with Vivaldi, and found that the layout code was fundamentally different and apparently does not use grid layout at all.

For those of us who actually use that site with Pale Moon, putting the following in chrome/userContent.css seems to serve as a workaround:

Code: Select all

.acorn-main-layout__grid  {
	display: grid;
}

User avatar
Moonraker
Board Warrior
Board Warrior
Posts: 1252
Joined: 2015-09-30, 23:02
Location: uk.

Re: Bank login page displays incorrectly

Post by Moonraker » 2020-01-06, 14:09

Vivaldi,brave,iridium,iron, etc etc are all chromium with a different jacket on are they not.?.Not independent in the true sense as google still controls those browsers.
Xenial puppy linux 32-bit.
Tahrpup 6.0.5.32 bit.
Pale moon 28.8.1.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25807
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Bank login page displays incorrectly

Post by Moonchild » 2020-01-06, 14:48

Not sure what quirk they are targeting then. you can't use grid if you don't set display:grid

If the code served is different then perhaps using a UA override will alleviate the problem so it doesn't specifically try to shove incompatible (and incomplete) code through the browser.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

Freddy
Moongazer
Moongazer
Posts: 10
Joined: 2016-11-05, 04:54

Re: Bank login page displays incorrectly

Post by Freddy » 2020-01-06, 15:52

Moonchild wrote:
2020-01-06, 14:48
Not sure what quirk they are targeting then. you can't use grid if you don't set display:grid
Most likely all the browsers they test on get served the functional code, and Pale Moon just ends up in some fallback case that their web-devs neither know nor care about.

Moonchild wrote:
2020-01-06, 14:48
If the code served is different then perhaps using a UA override will alleviate the problem so it doesn't specifically try to shove incompatible (and incomplete) code through the browser.
I tried using Vivaldi's UA as an override, but it did not seem to change anything. I still got the broken grid-based layout.

It is probably Javascript-based sniffing. It looks like the entire site is AJAX-loaded from a tiny stub HTML-file.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25807
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Bank login page displays incorrectly

Post by Moonchild » 2020-01-06, 16:07

Might be fruitless but you can always let the bank know that their site isn't displaying properly and referring them to this thread for information.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

Post Reply