Bug with tabs ... (no "x" on tabs; random occurrence) ...

The place to report Pale Moon specific bugs on the Windows operating system.

Moderator: satrow

Omnimaxus
Apollo supporter
Apollo supporter
Posts: 34
Joined: Sun, 13 May 2018, 00:05

Bug with tabs ... (no "x" on tabs; random occurrence) ...

Unread postby Omnimaxus » Fri, 17 Aug 2018, 22:26

Hello to everyone. There seems to be a bug with Pale Moon x64 28.0.0 (the "milestone" version; the one that was recently released). I installed Pale Moon with a clean profile. Saw that the tabs did not have "X" on them (to show where to click so they can be closed). This appears to be a random occurrence. See below. This is a bug, so am posting it here for examination. Thanks to whoever responds. (Probably Moonchild.)

aaaaaaaaa.jpg
Last edited by Omnimaxus on Fri, 17 Aug 2018, 22:26, edited 2 times in total.

Omnimaxus
Apollo supporter
Apollo supporter
Posts: 34
Joined: Sun, 13 May 2018, 00:05

Re: Bug with tabs ... (no "x" on tabs; random occurrence) ...

Unread postby Omnimaxus » Sun, 19 Aug 2018, 15:51

Wanted to follow up here and see if Moonchild or anyone else associated with Pale Moon had anything to say about this apparent bug. Also, have any other users noticed the same bug? Thanks.

User avatar
therube
Astronaut
Astronaut
Posts: 614
Joined: Fri, 08 Jun 2018, 17:02

Re: Bug with tabs ... (no "x" on tabs; random occurrence) ...

Unread postby therube » Sun, 19 Aug 2018, 16:13

clean profile

But tabs are on top & are square?
Is that expected?

User avatar
Tomaso
Keeps coming back
Keeps coming back
Posts: 985
Joined: Thu, 23 Jul 2015, 16:09
Location: Norway

Re: Bug with tabs ... (no "x" on tabs; random occurrence) ...

Unread postby Tomaso » Sun, 19 Aug 2018, 16:42

therube wrote:
clean profile

But tabs are on top & are square?
Is that expected?

What do you mean?
Pale Moon's tabs have always been square, unless you're using a third party theme.
And "tabs on" top is just a simple preference, and shouldn't affect anything.

Regarding the issue at hand; I haven't run into this problem myself.
But it's probably related to this one:
viewtopic.php?f=3&t=20006/
Like 99% of all the other issues that have been posted in the forum these last couple of days, it's caused by upgrading from v27 to v28.
If you keep in mind all the major changes in v28, this procedure can almost be compared to installing a new browser on top of a completely different one!
Of course, I know that upgrading has been taken into consideration by the developers, and updating any type of software should work flawlessly, in theory.
..but nevertheless, all my years as a Windows user tells me differently!
When it comes to huge milestone releases (as Pale Moon v28 clearly is), I think that a clean install is the only proper way to go:
viewtopic.php?f=3&t=11170&p=78365#p78365
Anyway, this discussion has been brought up before, and since I know that many people considers clean installs to be too "drastic", some of you might want to check this post first:
viewtopic.php?f=3&t=216/

User avatar
therube
Astronaut
Astronaut
Posts: 614
Joined: Fri, 08 Jun 2018, 17:02

Re: Bug with tabs ... (no "x" on tabs; random occurrence) ...

Unread postby therube » Sun, 19 Aug 2018, 17:00

Pale Moon's tabs have always been square, unless you're using a third party theme.

Mine aren't (that's why I asked) ? (Screenshot, viewtopic.php?p=148472#p148472.)
And "tabs on" top is just a simple preference

Ah, OK.
Last edited by therube on Sun, 19 Aug 2018, 17:04, edited 2 times in total.

Omnimaxus
Apollo supporter
Apollo supporter
Posts: 34
Joined: Sun, 13 May 2018, 00:05

Re: Bug with tabs ... (no "x" on tabs; random occurrence) ...

Unread postby Omnimaxus » Sun, 19 Aug 2018, 17:15

There is supposed to be a “X” on each tab so people know where to click to close them.

yami_
Fanatic
Fanatic
Posts: 154
Joined: Thu, 26 Apr 2018, 11:05

Re: Bug with tabs ... (no "x" on tabs; random occurrence) ...

Unread postby yami_ » Sun, 19 Aug 2018, 17:26

therube wrote:But tabs are on top & are square?
Is that expected?

The default theme adapts to the operating system:
Image
Windows 7
Image
Windows 10
Last edited by yami_ on Sun, 19 Aug 2018, 18:13, edited 1 time in total.
cat came back from Berkeley waving flags
- rob pike

User avatar
therube
Astronaut
Astronaut
Posts: 614
Joined: Fri, 08 Jun 2018, 17:02

Re: Bug with tabs ... (no "x" on tabs; random occurrence) ...

Unread postby therube » Sun, 19 Aug 2018, 17:35

(Oh, OK, I didn't know that.)

Omnimaxus
Apollo supporter
Apollo supporter
Posts: 34
Joined: Sun, 13 May 2018, 00:05

Re: Bug with tabs ... (no "x" on tabs; random occurrence) ...

Unread postby Omnimaxus » Sun, 19 Aug 2018, 17:43

Windows 10. Let me be clear - sometimes the “X” is there. Sometimes not. The “X” should be there at all times.

Omnimaxus
Apollo supporter
Apollo supporter
Posts: 34
Joined: Sun, 13 May 2018, 00:05

Re: Bug with tabs ... (no "x" on tabs; random occurrence) ...

Unread postby Omnimaxus » Sun, 19 Aug 2018, 17:44

Hope Moonchild acknowledges this bug soon. Needs to be fixed. (Thanks!)

User avatar
Tomaso
Keeps coming back
Keeps coming back
Posts: 985
Joined: Thu, 23 Jul 2015, 16:09
Location: Norway

Re: Bug with tabs ... (no "x" on tabs; random occurrence) ...

Unread postby Tomaso » Sun, 19 Aug 2018, 18:08

yami_ wrote:The default theme adapts to the operating system

I knew that, but didn't think that it affected the actual shape of things.
After closer inspection, I can confirm that Pale Moon's tabs are slightly rounded in the top corners under Win8.1 too.
Although, only by a single pixel! :)

Image

DoctorM
Moon lover
Moon lover
Posts: 98
Joined: Thu, 31 Jul 2014, 18:19
Location: USA

Re: Bug with tabs ... (no "x" on tabs; random occurrence) ...

Unread postby DoctorM » Mon, 20 Aug 2018, 03:42

Check Tools/Addons/Themes and check your theme.

I accidentally had a mixed installation where v28's Default Theme was installed on a v27 browser. They are incompatible and the 'x' disappeared from tabs.

So definitely check your Theme. Is it something custom and does it match your browser version?
Last edited by DoctorM on Mon, 20 Aug 2018, 03:42, edited 1 time in total.

Omnimaxus
Apollo supporter
Apollo supporter
Posts: 34
Joined: Sun, 13 May 2018, 00:05

Re: Bug with tabs ... (no "x" on tabs; random occurrence) ...

Unread postby Omnimaxus » Mon, 20 Aug 2018, 19:28

Everything is set to default (themes-wise). The only extension I have is Adblock Latitude, too. Thought I'd throw that in, too.

DoctorM
Moon lover
Moon lover
Posts: 98
Joined: Thu, 31 Jul 2014, 18:19
Location: USA

Re: Bug with tabs ... (no "x" on tabs; random occurrence) ...

Unread postby DoctorM » Tue, 21 Aug 2018, 04:38

Just as long as the Default theme you have is the one that matches your browser. They have version compatibility limits, just like other addons.
You could have some how gotten the wrong version during an upgrade.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3567
Joined: Mon, 03 Oct 2011, 10:19
Location: Texas, USA

Re: Bug with tabs ... (no "x" on tabs; random occurrence) ...

Unread postby Night Wing » Tue, 21 Aug 2018, 10:12

When using linux or windows Pale Moon 28.0.0, I have an "x" in every tab that is open. My tabs are on the bottom, not on the top.

My operating distro/systems are linux Mint 19 (Tara) Xfce and Windows 7 (Home Premium SP1, Ultimate SP1). The lightweight themes (personas) I use I get from the Solid colored themes from Firefox Addons are (Fuzzy Navel, Caramel, Blue Light 2012, Dream of Waves) and right now I'm using Fuzzy Navel.
Linux Mint 19 (Tara) Xfce 64 Bit (Default OS) with 64 Bit linux Pale Moon
Windows 7 SP1, 64 Bit (Backup OS) with 32 Bit windows Pale Moon

Omnimaxus
Apollo supporter
Apollo supporter
Posts: 34
Joined: Sun, 13 May 2018, 00:05

Re: Bug with tabs ... (no "x" on tabs; random occurrence) ...

Unread postby Omnimaxus » Wed, 22 Aug 2018, 17:23

So ... is this a bug or not? Can someone from the Pale Moon team acknowledge it? Moonchild? Will this be fixed for the next release? Thanks to all.

DoctorM
Moon lover
Moon lover
Posts: 98
Joined: Thu, 31 Jul 2014, 18:19
Location: USA

Re: Bug with tabs ... (no "x" on tabs; random occurrence) ...

Unread postby DoctorM » Sat, 25 Aug 2018, 06:12

You say you are using the 'defaults', but not actually confirming that your version numbers match.
See how it says "Default 28.0.0" which is the same version as my PM installation.
If the two numbers don't match, it could be the source of your problem.

Image

Omnimaxus
Apollo supporter
Apollo supporter
Posts: 34
Joined: Sun, 13 May 2018, 00:05

Re: Bug with tabs ... (no "x" on tabs; random occurrence) ...

Unread postby Omnimaxus » Sat, 25 Aug 2018, 18:57

DoctorM:

It is the default theme. Version 28.0.0 as shown in the add-ons manager tab. Not sure how what you said could happen. Don't think it's technically possible.

Moonchild and/or anyone else on the Pale Moon team:

Is this a bug or not? Please advise. If it is, will it be changed for the next release? Am running 28.0.0 on Windows 10 (64-bit). Latest "official" build. Thanks!

User avatar
JustOff
Localization Coordinator
Localization Coordinator
Posts: 1509
Joined: Thu, 03 Sep 2015, 19:47
Location: UA
Contact:

Re: Bug with tabs ... (no "x" on tabs; random occurrence) ...

Unread postby JustOff » Sat, 25 Aug 2018, 19:15

I understand your frustration that your problem has not acknowledged yet, but, please be a little more patient.

Please try these options (the simplest way is to use portable packages):

1) Disable hardware acceleration (HWA)
2) Try 32-bit build (with and without HWA)

Please also provide [IMPORTANT!] Information to include when asking for support.
Last edited by JustOff on Sat, 25 Aug 2018, 19:15, edited 1 time in total.
Here are the add-ons I made in a spare time. That was fun!

DoctorM
Moon lover
Moon lover
Posts: 98
Joined: Thu, 31 Jul 2014, 18:19
Location: USA

Re: Bug with tabs ... (no "x" on tabs; random occurrence) ...

Unread postby DoctorM » Sat, 25 Aug 2018, 19:44

Omnimaxus wrote:DoctorM:]
It is the default theme. Version 28.0.0 as shown in the add-ons manager tab. Not sure how what you said could happen. Don't think it's technically possible.


You do not have to yell.
The point is, I have seen installations of PM where the version of the default theme in the add-ons manager is wrong for the version of PM. It's an installation thing that can happen if you upgrade/downgrade/whatever. When this has happened, the X's disappeared from tabs.


Return to “Bug reports (Windows)”

Who is online

Users browsing this forum: No registered users and 5 guests