4chan.org Broken by latest update

The place to report Pale Moon specific bugs on the Windows operating system.

Moderator: satrow

vuubik
New to the forum
New to the forum
Posts: 1
Joined: Mon, 02 Apr 2018, 12:19

4chan.org Broken by latest update

Unread postby vuubik » Mon, 02 Apr 2018, 12:28

As the title says- the site no longer works- I thought it was my copy of Greasemoneky for Pale Moon, so I tried the earlier official still compatible version, but that didn't work either with the script 4chan X, so the newest update was to blame.
Can you guys put in a rollback feature so if this happens in future I don't have to wait for a new update to fix my browsing?

User avatar
satrow
Forum staff
Forum staff
Posts: 1706
Joined: Thu, 08 Sep 2011, 11:27

Re: 4chan.org Broken by latest update

Unread postby satrow » Mon, 02 Apr 2018, 13:28

Please define exactly what 'doesn't work', screenshots can be useful.

A quick look around 4chan, W7 Pale Moon 27.8.3 x64, reveals no obvious differences to my previous visits there.

User avatar
adesh
Astronaut
Astronaut
Posts: 569
Joined: Tue, 06 Jun 2017, 07:38

Re: 4chan.org Broken by latest update

Unread postby adesh » Mon, 02 Apr 2018, 15:32

vuubik wrote:Can you guys put in a rollback feature so if this happens in future I don't have to wait for a new update to fix my browsing?

Rollback is not a normal use case, so adding support for it makes little sense considering that building a feature requires a developer to work on it (and that may in turn hamper the regular development of the browser). You will not see such a feature soon unless Pale Moon team grows significantly.

If you want to try an older version of Pale Moon, see here.
Last edited by adesh on Mon, 02 Apr 2018, 15:32, edited 1 time in total.

User avatar
Isengrim
Astronaut
Astronaut
Posts: 545
Joined: Tue, 08 Sep 2015, 22:54
Location: 127.0.0.1
Contact:

Re: 4chan.org Broken by latest update

Unread postby Isengrim » Mon, 02 Apr 2018, 20:06

Does the problem persist in Safe Mode?
Linux Mint 18.3 Cinnamon (64-bit)
Windows 7 (64-bit) (Sometimes)
Windows 10 build 1803 (64-bit) (Sometimes)
We are our choices.

User avatar
Moonraker
Keeps coming back
Keeps coming back
Posts: 895
Joined: Wed, 30 Sep 2015, 23:02
Location: Lincolnshire.UK.

Re: 4chan.org Broken by latest update

Unread postby Moonraker » Mon, 02 Apr 2018, 20:16

Empty statements like it doesnt work without giving any form of explanantion of what exactly does not work and your modus operandi would be useful too,
what extensions do you have installed.?
Have you tried without extensions enabled ?

have you tinkered in about:config for example.

shot in the dark posts like this require shot in the dark responses which only leaves us guessing and chasing our own tails.
Slacko puppy linux 64bit.
Pale moon 27.9.0

User avatar
Sajadi
Keeps coming back
Keeps coming back
Posts: 944
Joined: Fri, 19 Apr 2013, 00:46

Re: 4chan.org Broken by latest update

Unread postby Sajadi » Mon, 02 Apr 2018, 21:53

No Web-console errors - site works normally here. It is possible to write answers, if you mark certain text and click to answer, text appears in the answer field. So, seen from my point of view, the site is fully operational.
Last edited by Sajadi on Mon, 02 Apr 2018, 21:53, edited 1 time in total.

BenFenner
Fanatic
Fanatic
Posts: 146
Joined: Mon, 01 Jun 2015, 12:52
Location: US Southeast

Re: 4chan.org Broken by latest update

Unread postby BenFenner » Sat, 02 Jun 2018, 12:33

I know I'm bumping a slightly older thread, but a few weeks back I've noticed the frames version of 4chan not working at all.
https://4chan.org/frames

It displays a white frame on the left, and a white frame on the right, both about equal width.
Viewing the source shows the content is missing, and likely a JS fill problem. The console shows no JS errors (no errors of any kind actually).

Image


If I visit https://4chan.org without the frames, the site redirects to the frames site with the same results.


If I visit a board directly without frames https://4chan.org/o (SFW automotive section) then the site seems to work normally (albeit without frames) except many of the thumbnails, when clicked, won't load the larger image, and instead a user-friendly 404 notice is displayed at the top of the screen.

Image


I have confirmed this on multiple machines (some that never had NoScript installed). I'm up-to-date using 64-bit Pale Moon 27.9.2. I have ABPrime installed on all of the setups I've tested with (subscribed to EasyList).
Changing from the "Firefox Compatibility" User Agent to "Native" doesn't change anything.

I have a buddy who tested with MS Edge for me and the site works fine for him. I'm finally on a machine with Firefox (I don't run any add-ons or plugins with FIreFox), and it too displays the frames site just fine.
Last edited by BenFenner on Sat, 02 Jun 2018, 13:33, edited 11 times in total.

BenFenner
Fanatic
Fanatic
Posts: 146
Joined: Mon, 01 Jun 2015, 12:52
Location: US Southeast

Re: 4chan.org Broken by latest update

Unread postby BenFenner » Sat, 02 Jun 2018, 12:47

Okay, I figured out how to enter Safe Mode, and the site works quite well there. Let me see if I can narrow this down some more...

Edit: Well, disabling ABPrime 1.0.5 allows the site to work perfectly. Like clockwork, enabling it again causes the site to misbehave as described. I'll see about updating EasyLIst and maybe post in the ABPrime thread.

Edit 2: Disabling ABPrime for 4chan only also lets the site work properly, so I'm thinking it's an EasyList problem and not an ABPrime problem. I'll try posting to their forum. https://forums.lanik.us/viewtopic.php?f=64&t=40926
Last edited by BenFenner on Sat, 02 Jun 2018, 14:41, edited 4 times in total.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22424
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: 4chan.org Broken by latest update

Unread postby Moonchild » Sat, 02 Jun 2018, 13:43

EasyList is becoming more and more of an issue. Not so "easy"
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

User avatar
Tomaso
Board Warrior
Board Warrior
Posts: 1042
Joined: Thu, 23 Jul 2015, 16:09
Location: Norway

Re: 4chan.org Broken by latest update

Unread postby Tomaso » Sat, 02 Jun 2018, 15:57

BenFenner wrote:https://4chan.org/frames

It works just fine with EasyList in uBlock Origin.
Last edited by Tomaso on Sat, 02 Jun 2018, 15:58, edited 1 time in total.

BenFenner
Fanatic
Fanatic
Posts: 146
Joined: Mon, 01 Jun 2015, 12:52
Location: US Southeast

Re: 4chan.org Broken by latest update

Unread postby BenFenner » Sat, 02 Jun 2018, 18:39

Yah, the folks at EasyList had me do a little more testing, and it seems the issue is with ABPrime itself. I will post in the appropriate thread to alert Tobin.
Edit: Or maybe not. Seems Tobin is banned? Or maybe that was a secondary account that got banned? Looks like I'll just report a bug to the project on GitHub https://github.com/binoc-central/abprime/issues/5 .
At the worst, I'll just stick with AdBlock Latitude for a while.

Pertinant testing from the EasyList forum:
BenFenner wrote:I've tried with Firefox Portable 60.0.1 and uBlock Origin 1.16.8 and the problem does not present with this setup.
I then replaced ABPrime on my Pale Moon setup with AdBlock Latitude (AdBlock Plus tweaked a little to work with Pale Moon) and still the problem does not present with this setup.

So, I believe now I've narrowed down the issue to the ABPrime plugin. Sorry for the trouble. I will alert the developer on his home forum.
Cheers!
Last edited by BenFenner on Sat, 02 Jun 2018, 19:23, edited 6 times in total.

User avatar
Lootyhoof
Themeist
Themeist
Posts: 1138
Joined: Thu, 09 Feb 2012, 23:35
Location: United Kingdom

Re: 4chan.org Broken by latest update

Unread postby Lootyhoof » Sat, 02 Jun 2018, 19:03

If you go into Filter Preferences and click the Filter List link, does it go to easylist.to or another site?

BenFenner
Fanatic
Fanatic
Posts: 146
Joined: Mon, 01 Jun 2015, 12:52
Location: US Southeast

Re: 4chan.org Broken by latest update

Unread postby BenFenner » Sat, 02 Jun 2018, 19:11

Lootyhoof wrote:If you go into Filter Preferences and click the Filter List link, does it go to easylist.to or another site?

It leads to the correct easylist.to URL.

As mentioned above, this seems to actually be an ABPrime issue, not an EasyList issue. :thumbup:
Last edited by BenFenner on Sat, 02 Jun 2018, 19:12, edited 1 time in total.

User avatar
Lootyhoof
Themeist
Themeist
Posts: 1138
Joined: Thu, 09 Feb 2012, 23:35
Location: United Kingdom

Re: 4chan.org Broken by latest update

Unread postby Lootyhoof » Sat, 02 Jun 2018, 19:35

I've mentioned this to Tobin and an update should have been pushed out (v1.0.7). Does this fix the issue?

Frasier
Fanatic
Fanatic
Posts: 137
Joined: Wed, 07 May 2014, 02:44
Location: Indiana

Re: 4chan.org Broken by latest update

Unread postby Frasier » Sun, 03 Jun 2018, 02:20

Lootyhoof wrote:I've mentioned this to Tobin and an update should have been pushed out (v1.0.7). Does this fix the issue?
The update appears to have solved the issue. https://4chan.org/frames works fine now.

BenFenner
Fanatic
Fanatic
Posts: 146
Joined: Mon, 01 Jun 2015, 12:52
Location: US Southeast

Re: 4chan.org Broken by latest update

Unread postby BenFenner » Sun, 03 Jun 2018, 03:11

When Tobin said it was fixed "already", I thought he meant in 1.0.6 but I see that 1.0.7 is out now and I can confirm it has fixed the issue for me too! :thumbup:
Now I can go back to ABPrime on my other machine too. It's a good day.


Return to “Bug reports (Windows)”

Who is online

Users browsing this forum: No registered users and 6 guests