PM 27.5.1 CPU now OK, but Youtube not working properly in fullscreen

The place to report Pale Moon specific bugs on the Windows operating system.

Moderator: satrow

SGvagon
Lunatic
Lunatic
Posts: 414
Joined: Sat Feb 16, 2013 1:33 pm
Location: Czech Republic - Slavonice
Contact:

PM 27.5.1 CPU now OK, but Youtube not working properly in fullscreen

Postby SGvagon » Tue Oct 10, 2017 2:02 pm

Hello,

after update Palemoon on the latest version 27.5.1 (x86) . Youtube videos now not draining CPU on 70-80% , but in fullscreen Youtube videos are stuttering (15-20 FPS) . In normal player (not in fullscreen) videos are OK.
I have MSI laptop with Core i7 6700HQ , GTX 960M , 8GB RAM, but this probably you already know.

Thank you in advnace.

User avatar
megaman
Knows the dark side
Knows the dark side
Posts: 2850
Joined: Tue Aug 30, 2011 4:40 pm
Location: H-town
Contact:

Re: PM 27.5.1 CPU now OK, but Youtube not working properly in fullscreen

Postby megaman » Tue Oct 10, 2017 3:05 pm

I tested this yesterday but only looked at the raw results of the hardware's performance. Once again, I'm solely AMD. If the video plays smooth, whatever random video I play, it has to lie with either Intel HD. I can't blame the Nvidia graphics but since you have them, it's possible. How are your settings on the Battery meter? Power Saver, Balanced, or High Performance? I strictly use Power Saver with Battery Saver GPU, so my GPU is not pushing its max performance but I let the CPU go all out to 100% if possible.

Well, I have tested 2 random videos and they are smooth as butter. The only time I have dropped frames is when it buffered and it was just one frame per buffer, so I let it sit and load until half of the video. The videos were using 1920X1080@60fps. (Only tested in Full Screen at the time)

From the last thread someone else mentioned a similar problem and had an i3, so just Intel HD? I can't assume here. If so, are you using the latest drivers? I'm surprised if Intel HD is the problem, really, it's the most vastly used and supported.

Edit: I could've sworn someone said i3 but quick scan of that thread and I didn't notice, but either way, the rest stands.
Curiosity leads to a world of experiments.

SGvagon
Lunatic
Lunatic
Posts: 414
Joined: Sat Feb 16, 2013 1:33 pm
Location: Czech Republic - Slavonice
Contact:

Re: PM 27.5.1 CPU now OK, but Youtube not working properly in fullscreen

Postby SGvagon » Tue Oct 10, 2017 3:59 pm

Strange, now it works for me too :eh: . So, I hope, that it will be work at the future.

User avatar
megaman
Knows the dark side
Knows the dark side
Posts: 2850
Joined: Tue Aug 30, 2011 4:40 pm
Location: H-town
Contact:

Re: PM 27.5.1 CPU now OK, but Youtube not working properly in fullscreen

Postby megaman » Tue Oct 10, 2017 4:12 pm

SGvagon wrote:Strange, now it works for me too :eh: . So, I hope, that it will be work at the future.

I very well hope that it continues working or the problem is underlining in your OS, maybe another program or security software kicking in. It's still a mystery, mainly because another user was using Linux during the incident.
Curiosity leads to a world of experiments.

SGvagon
Lunatic
Lunatic
Posts: 414
Joined: Sat Feb 16, 2013 1:33 pm
Location: Czech Republic - Slavonice
Contact:

Re: PM 27.5.1 CPU now OK, but Youtube not working properly in fullscreen

Postby SGvagon » Fri Oct 13, 2017 6:07 am

Hm interesting, Youtube videos lagging on a first time (after start Windows/Laptop) for 1-2 minutes, then maybe activate HW acceleration and videos then smooth. There is slow activating HW acceleration I think. Firefox or Opera this starts immediately and videos not stuttering.

User avatar
megaman
Knows the dark side
Knows the dark side
Posts: 2850
Joined: Tue Aug 30, 2011 4:40 pm
Location: H-town
Contact:

Re: PM 27.5.1 CPU now OK, but Youtube not working properly in fullscreen

Postby megaman » Fri Oct 13, 2017 5:38 pm

SGvagon wrote:Hm interesting, Youtube videos lagging on a first time (after start Windows/Laptop) for 1-2 minutes, then maybe activate HW acceleration and videos then smooth. There is slow activating HW acceleration I think. Firefox or Opera this starts immediately and videos not stuttering.

I tested this, as soon as possible after the computer restarted, and it wasn't a problem. Other than using 1080p and had buffering, the laggy wasn't happening.

Edit: Can you temporarily make another Windows account and see how Pale Moon works, there? I think Windows might have problems on its own or I'm at a loss on what is happening.
Curiosity leads to a world of experiments.

SGvagon
Lunatic
Lunatic
Posts: 414
Joined: Sat Feb 16, 2013 1:33 pm
Location: Czech Republic - Slavonice
Contact:

Re: PM 27.5.1 CPU now OK, but Youtube not working properly in fullscreen

Postby SGvagon » Sat Oct 14, 2017 5:09 pm

I bought SSD and reinstall the system for this problem, but it still stuttering 2-3 minutes after fresh windows and Palemoon start.

SGvagon
Lunatic
Lunatic
Posts: 414
Joined: Sat Feb 16, 2013 1:33 pm
Location: Czech Republic - Slavonice
Contact:

Re: PM 27.5.1 CPU now OK, but Youtube not working properly in fullscreen

Postby SGvagon » Mon Oct 23, 2017 2:30 pm

I don't know if Youtube did some changes, but I can't watch on 60 FPS videos at all after start windows and Palemoon. 60 FPS videos (maybe non 60 FPS too) are blinking to black and player is totally freezing. And videos no 60 FPS smooth. I must using Firefox or Opera now, where is all smooth :| .

User avatar
megaman
Knows the dark side
Knows the dark side
Posts: 2850
Joined: Tue Aug 30, 2011 4:40 pm
Location: H-town
Contact:

Re: PM 27.5.1 CPU now OK, but Youtube not working properly in fullscreen

Postby megaman » Mon Oct 23, 2017 5:38 pm

SGvagon wrote:I don't know if Youtube did some changes, but I can't watch on 60 FPS videos at all after start windows and Palemoon. 60 FPS videos (maybe non 60 FPS too) are blinking to black and player is totally freezing. And videos no 60 FPS smooth. I must using Firefox or Opera now, where is all smooth :| .

Blinking to black is a problem with Hardware Acceleration, disable it and check again.
Drivers updated, right? Well, I just got drivers from Nvidia on my desktop, so that could help?
Curiosity leads to a world of experiments.

SGvagon
Lunatic
Lunatic
Posts: 414
Joined: Sat Feb 16, 2013 1:33 pm
Location: Czech Republic - Slavonice
Contact:

Re: PM 27.5.1 CPU now OK, but Youtube not working properly in fullscreen

Postby SGvagon » Mon Oct 23, 2017 6:36 pm

When I disable it, all videos are stuttering and not smooth. I am using the latest Intel drivers (HW acceleration using intel graphic, well? Not Nvidia, but I have the latest Nvidia drivers too) .
I have MSI Laptop GP62 6QF with Core i7 6700HQ and Nvidia GTX960M (Windows 7 PRO x64bit) . I know that you told me, this CPU is bad for gecko or goanna, but in Firefox Youtube videos are completely ok (60FPS too) .
And how I said, this problem is the biggest when I start windows and then Palemoon (3-4 minutes) , Palemoon and watching videos is unusuable.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 2884
Joined: Mon Oct 03, 2011 10:19 am
Location: Texas, USA

Re: PM 27.5.1 CPU now OK, but Youtube not working properly in fullscreen

Postby Night Wing » Mon Oct 23, 2017 9:48 pm

When watching YouTube videos, there is no lagging or stuttering using 32 bit windows Pale Moon (and no problems either using 64 bit linux Pale Moon) in (27.5.1). I have hardware acceleration turned off.
Linux Mint 18.2 (Sonya) Xfce 64-Bit (Default OS) with 64-Bit linux Pale Moon
Windows 7 SP1 64 Bit (Backup OS) with 32-Bit windows Pale Moon

SGvagon
Lunatic
Lunatic
Posts: 414
Joined: Sat Feb 16, 2013 1:33 pm
Location: Czech Republic - Slavonice
Contact:

Re: PM 27.5.1 CPU now OK, but Youtube not working properly in fullscreen

Postby SGvagon » Tue Oct 24, 2017 5:13 am

What CPU you have? I have Skylake i7 6700HQ.

SGvagon
Lunatic
Lunatic
Posts: 414
Joined: Sat Feb 16, 2013 1:33 pm
Location: Czech Republic - Slavonice
Contact:

Re: PM 27.5.1 CPU now OK, but Youtube not working properly in fullscreen

Postby SGvagon » Tue Oct 24, 2017 5:19 am

Ok, I did some progress. When I set Gecko compatibility in settings. Youtube works better now :-) . Maybe Youtube works different for another compatibility mode?
Image

User avatar
megaman
Knows the dark side
Knows the dark side
Posts: 2850
Joined: Tue Aug 30, 2011 4:40 pm
Location: H-town
Contact:

Re: PM 27.5.1 CPU now OK, but Youtube not working properly in fullscreen

Postby megaman » Tue Oct 24, 2017 5:29 am

SGvagon wrote:Ok, I did some progress. When I set Gecko compatibility in settings. Youtube works better now :-) . Maybe Youtube works different for another compatibility mode?

Really? I'll have to test this. Glad you found the solution, never would have thought of that. I'm using Firefox Compatibility Mode, which comes default.
Curiosity leads to a world of experiments.

SGvagon
Lunatic
Lunatic
Posts: 414
Joined: Sat Feb 16, 2013 1:33 pm
Location: Czech Republic - Slavonice
Contact:

Re: PM 27.5.1 CPU now OK, but Youtube not working properly in fullscreen

Postby SGvagon » Tue Oct 24, 2017 5:38 am

It helps, but very little. Stuttering after start the sytem is still here. In Firefox or Opera not.

Btw. I hope, that newer versions of Palemoon will have some changes in MSE, or can include Firefox decoding. Now it works, but not that good as in Firefox or Opera (60 FPS videos there smoother than in Palemoon) .

SGvagon
Lunatic
Lunatic
Posts: 414
Joined: Sat Feb 16, 2013 1:33 pm
Location: Czech Republic - Slavonice
Contact:

Re: PM 27.5.1 CPU now OK, but Youtube not working properly in fullscreen

Postby SGvagon » Thu Oct 26, 2017 6:59 pm

OK,
Intel released new version of Intel driver for my CPU (i7 6700HQ on Windows 7 PRO x64bit) 15.45.19.4678 „and now Palemoon works at 60 FPS smooth from start laptop“ :-) . I hope, that will fixed my problem. So maybe Intel have lots of problems with Skylake CPU series and now slowly fixing it. Because the last driver was from 5/30/2017 . It's 5 months now and Intel release new version on Windows 7! Yay :) !

EDIT: Hmm, it worked only first time, but I tried now second restart the laptop and Palemoon stuttering again :-/ . So I will need another solution for this problem. Other browsers like Firefox, Cyberfox, Opera, Chrome, Vivaldi works normally.

SGvagon
Lunatic
Lunatic
Posts: 414
Joined: Sat Feb 16, 2013 1:33 pm
Location: Czech Republic - Slavonice
Contact:

Re: PM 27.5.1 CPU now OK, but Youtube not working properly in fullscreen

Postby SGvagon » Sat Oct 28, 2017 1:11 pm

I wrote on Intel forum and they are said me, that this problem is maybe in Palemoon. So I will wait for more information.


Return to “Bug reports (Windows)”

Who is online

Users browsing this forum: No registered users and 5 guests