PM 28.0.1 crash Topic is solved

The place to report Pale Moon specific bugs on the Windows operating system.

Moderator: satrow

fifonik
Apollo supporter
Apollo supporter
Posts: 38
Joined: Fri, 29 Aug 2014, 02:21
Location: Brisbane, Australia

PM 28.0.1 crash

Unread postby fifonik » Mon, 03 Sep 2018, 01:01

I tried 28.0.1 and noticed it is much better than 28.0.0 in terms of smoothness and the browser is not hanging any longer (that forced me to roll back from 28.0.0 to 27.9.4).

However, with 28.0.1 I'm experiencing random crashes from time to time (it is just closing).
AppCrashView does not show anything.
In Windows application log I see entry related to the crash:

Code: Select all

Faulting application name: palemoon.exe, version: 4.1.4.6816, time stamp: 0x5b881b6c
Faulting module name: xul.dll, version: 4.1.4.6816, time stamp: 0x5b881d51
Exception code: 0xc0000005
Fault offset: 0x00000000004b86f4
Faulting process id: 0x15ac
Faulting application start time: 0x01d44317f00cfc25
Faulting application path: C:\Program Files\Pale Moon\palemoon.exe
Faulting module path: C:\Program Files\Pale Moon\xul.dll
Report Id: cd1d8463-788b-49db-b09e-c71f3a518d89
Faulting package full name:
Faulting package-relative application ID:


Unfortunately, I do not know how to re-produce the issue as it is completely intermittent.
However, it looks lime mostly it happens when a new tab/window is opened by clicking on external links (links in other programs).
I tried PM 28.0.1 portable 64-bit with about the same set of addons and have not seen such crashes. However, external links not opened in the portable PM and it is mostly just staying open.

System info:
CPU: i7-4790 (no overclocking)
RAM: 16 GB
GPU: AMD R5-240 + Integrated Intel GPU (dual monitor)
Windows 10 64-bit 1803
Palemoon 28.0.1 64-bit installed over 27.x profile (with quite a few addons installed).

P.S. I've rolled back to 27.9.4 for now.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3530
Joined: Mon, 03 Oct 2011, 10:19
Location: Texas, USA

Re: PM 28.0.1 crash

Unread postby Night Wing » Mon, 03 Sep 2018, 02:00

You went from 27.9.4 to 28.0.0 and when 28 wasn't to your liking, you rolled back to (27.9.4). If you didn't make a new profile when you rolled back to 27.9.4, then that could be the reason you're now having problems when you updated to (28.0.1). Did you make a new profile when you rolled back to (27.9.4).?

Then you went to 28.0.1 and had problems with this version. Did you make a new profile in (28.0.1)? If you didn't make a new profile for this version and then rolled back to 27.9.4 (a second time), you just might start having problems cropping up with (27.9.4) somewhere down the line.

Bottom line. Updating to a new version, having problems, rolling back and forth like a yo-yo, without creating new profiles, corrupts profiles.

I'm harping on a new profile because in your first post in this topic thread, you never said if you made a new profile so my post is basically guess work. If you haven't made any new profiles, I wouldn't count on a future version, like updating from 27.9.4 to 28.0.2, to solve your problems.
Last edited by Night Wing on Mon, 03 Sep 2018, 02:00, edited 1 time in total.
Linux Mint 19 (Tara) Xfce 64-Bit (Default OS) with 64-Bit linux Pale Moon
Windows 7 SP1, 64 Bit (Backup OS) with 32-Bit windows Pale Moon

fifonik
Apollo supporter
Apollo supporter
Posts: 38
Joined: Fri, 29 Aug 2014, 02:21
Location: Brisbane, Australia

Re: PM 28.0.1 crash

Unread postby fifonik » Tue, 04 Sep 2018, 00:58

I'm aware that upgrade to 28 converts profile so I backed up my profile (with PM backup tool & manually) before upgrading to 28 and restored it when downgraded.
I have not created new profiles. I restored my old 27.x profile after every downgrade.
Last edited by fifonik on Tue, 04 Sep 2018, 01:00, edited 3 times in total.

fifonik
Apollo supporter
Apollo supporter
Posts: 38
Joined: Fri, 29 Aug 2014, 02:21
Location: Brisbane, Australia

Re: PM 28.0.1 crash

Unread postby fifonik » Wed, 05 Sep 2018, 21:21

Tried to upgrade from 27.9.4 64-bit to 28.0.1 64-bit on my home PC (with about the same set of addons) and do not have any crashes after 3 days (I'm noticing small slowness while switching tab or scrolling, but nothing major).
As I'm the only user of these PCs, browser usage is about the same. However, PCs specs are completely different. At home I have Ryzen5 1600, 16GB RAM, GPU AMD RX 470, (no integrated GPU, single monitor), Windows 10 64-bit 1803.

One difference that I'm thinking might be an issue -- GPU/drivers. On the problematic PC it is dual monitor setup so iGPU + AMD GPU are used. In addition, it is Dell so I cannot install the most recent Intel/AMD drivers (quite old Radeon 17.7 is used, newer driver simply not available).
Could you advice, how can I check what GPU is used by Palemoon and how to tell Palemoon what GPU I'd like to use for HW acceleration?

Thanks.

User avatar
therube
Astronaut
Astronaut
Posts: 500
Joined: Fri, 08 Jun 2018, 17:02

Re: PM 28.0.1 crash

Unread postby therube » Thu, 06 Sep 2018, 20:35

If you think it is video card related, disable Hardware Acceleration & test running that way for a while.

Tools | Preferences | Advanced -> User hardware acceleration when available (uncheck)

fifonik
Apollo supporter
Apollo supporter
Posts: 38
Joined: Fri, 29 Aug 2014, 02:21
Location: Brisbane, Australia

Re: PM 28.0.1 crash  Topic is solved

Unread postby fifonik » Thu, 13 Sep 2018, 22:35

I've made another attempt to upgrade 27.9.4 to 28.0.1 (the same profile).
This time after upgrading I opened about:config and went through all modified options (they are in bold), reset everything that is not related to currently installed/configured extensions, restarted browser and made browser changes that I need through UI.

It is working without crashes for more than a day already (HW acceleration is still ON).
Last edited by fifonik on Thu, 13 Sep 2018, 22:37, edited 2 times in total.


Return to “Bug reports (Windows)”

Who is online

Users browsing this forum: Moz [Crawler] and 5 guests