thefreedictionary.com pronunciation button stopped working

The place to report Pale Moon specific bugs on the Windows operating system.

Moderator: satrow

LL25255252
Moon lover
Moon lover
Posts: 76
Joined: Sat Aug 29, 2015 3:44 am

thefreedictionary.com pronunciation button stopped working

Postby LL25255252 » Sun Jun 18, 2017 8:10 pm

http://www.thefreedictionary.com/doleful
from the Browser console:
Use of getPreventDefault() is deprecated. Use defaultPrevented instead. jquery-1.7.2.min.js:3:0

Tested on a new Pale Moon 27.3 (32 bit) profile (and with all plugin's on Ask to Activate)
win 7 x64

Thanks in advance.

User avatar
satrow
Forum staff
Forum staff
Posts: 1503
Joined: Thu Sep 08, 2011 11:27 am

Re: thefreedictionary.com pronunciation button stopped working

Postby satrow » Sun Jun 18, 2017 8:28 pm

Works as expected here, W7 PM27.3.0 x64 in Native mode. Test by switching it (Alt) Tools > Options > Advanced > General tab - Compatibility. You can also test your other issues with it.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 20067
Joined: Sun Aug 28, 2011 5:27 pm
Location: 58.5°N 15.5°E
Contact:

Re: thefreedictionary.com pronunciation button stopped working

Postby Moonchild » Sun Jun 18, 2017 8:34 pm

LL{numbers} -- you seem to have a number of related issues with things (especially audio) not loading that others can't reproduce. Please try to get to the bottom of it without opening a new thread for each site that stopped working that you happen to use, so things can remain focused on solving your apparent issues with Pale Moon.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

LL25255252
Moon lover
Moon lover
Posts: 76
Joined: Sat Aug 29, 2015 3:44 am

Re: thefreedictionary.com pronunciation button stopped working

Postby LL25255252 » Sun Jun 18, 2017 8:43 pm

satrow wrote:Works as expected here, W7 PM27.3.0 x64 in Native mode. Test by switching it (Alt) Tools > Options > Advanced > General tab - Compatibility. You can also test your other issues with it.

Thank you @satrow. Tried your suggestion in all the sites I reported but it didn't help. Maybe you succeeded and I didn't because you run Pale Moon 64bit and I run Pale Moon 32bit.

User avatar
satrow
Forum staff
Forum staff
Posts: 1503
Joined: Thu Sep 08, 2011 11:27 am

Re: thefreedictionary.com pronunciation button stopped working

Postby satrow » Sun Jun 18, 2017 8:48 pm

Did you refresh each affected tab/page after making the change?

LL25255252
Moon lover
Moon lover
Posts: 76
Joined: Sat Aug 29, 2015 3:44 am

Re: thefreedictionary.com pronunciation button stopped working

Postby LL25255252 » Sun Jun 18, 2017 8:55 pm

Moonchild wrote:LL{numbers} -- you seem to have a number of related issues with things (especially audio) not loading that others can't reproduce. Please try to get to the bottom of it without opening a new thread for each site that stopped working that you happen to use, so things can remain focused on solving your apparent issues with Pale Moon.
Thank you @Moonchild - next time I'll follow your advice/guideline.
I opened a new thread because I got a different warning from the Browser Console. I forgot also to mention that no issues (including audio issues) in other browsers like firefox and waterfox on the the same pages.

Yavanius
Apollo supporter
Apollo supporter
Posts: 37
Joined: Wed Aug 19, 2015 5:16 am
Location: SoCal, USA

Re: thefreedictionary.com pronunciation button stopped working

Postby Yavanius » Mon Jun 19, 2017 10:33 pm

Maybe try running Palemoon Portable: http://www.palemoon.org/palemoon-portable.shtml

and see if you get the same issues? It could help you to try and troubleshoot where you might have an issue before starting with a fresh install of Palemoon.

LL25255252
Moon lover
Moon lover
Posts: 76
Joined: Sat Aug 29, 2015 3:44 am

Re: thefreedictionary.com pronunciation button stopped working

Postby LL25255252 » Mon Jun 19, 2017 10:51 pm

Yavanius wrote:Maybe try running Palemoon Portable: http://www.palemoon.org/palemoon-portable.shtml

and see if you get the same issues? It could help you to try and troubleshoot where you might have an issue before starting with a fresh install of Palemoon.

@Yavanius thank you. I've just managed to fix my issue without your tip but it's a great idea and I intend to use it next time I have some issue like this one.
Very soon I'm going to post here what exactly I think happened.

Yavanius
Apollo supporter
Apollo supporter
Posts: 37
Joined: Wed Aug 19, 2015 5:16 am
Location: SoCal, USA

Re: thefreedictionary.com pronunciation button stopped working

Postby Yavanius » Mon Jun 19, 2017 10:59 pm

Glad to hear it. :) Sometimes you just have to sigh and get yourself another cup of coffee... :coffee:

LL25255252
Moon lover
Moon lover
Posts: 76
Joined: Sat Aug 29, 2015 3:44 am

Re: thefreedictionary.com pronunciation button stopped working

Postby LL25255252 » Tue Jun 20, 2017 12:16 am

Tried to restart my PC - didn't help.
Launched CCleaner64 (ver. 5.26) and run the "Cleaner" part (not the Registry cleaner part).

Launched Pale Moon.
Checked again Soundcloud.com & Audiomack.com & thefreedictionary.com sites ... and surprise...media is playing OK. :)

Generally whenever I have an issue with the browser I immediately backup the profile folder in case it will be hard to find the culprit. This time unfortunately I didn't do it ( maybe because I thought it would be easy to solve it because the issue didn't involve extensions).

Fortunately enough though I backed up my profile 3 days ago.
When I now open that backup profile I see a file (a database) named webappsstore.sqlite. whose size is 11MB. Isn't it too big ?Is this normal ?

For comparison - Today after "cleaning" with CCleaner I I surfed the net including playing some YT and soundcloud files and the file is still under 100kb.

And another info - looking into a December 2016 backup the size of it was 7MB.

You can see this webappsstore.sqlite file in the "files to be deleted" part of CCleaner Analyzer.
Note that it shows 14MB but it is the sum of 13 files (apparently I need to remove some small old PM profiles I used before for troubleshooting).

Image

Pale Moon has crashed a few times for me on the last few months so I'm wondering, is it possible that sometimes after the browser crashes webappsstore.sqlite gets bigger and bigger to a point that it can cause the media playing issue I reported here ? :?:
And suggestion - maybe Pale Moon should detect that the file size is too big and offer an option to remove it.
Is this related to this mozilla bug - https://bugzilla.mozilla.org/show_bug.cgi?id=857888 ("webappsstore.sqlite is larger than it should be") ?

A different guess
- could the culprit be some file "outside" the "AppData/Roaming" profile folder ? maybe a file from the Offline Cache folders under "AppData/LocaL" caused the issue and later Ccleaner "cleaned" it ?

One last thing that needs an explanation. In my OP I reported that the issue happened to me on a new profile. But in a new profile the size of webappsstore.sqlite is very small so it contradicts my "too big webappsstore.sqlite" theory I described before.
So the explanation is that it was not a truly NEW profile. I checked the "created date" of the profile folder and it dates one day before my troubleshooting !!
I just realized now that I screwed-up the troubleshooting and instead of creating a new profile I used a profle I created a day earlier. It was a profile I created to troubleshoot a browser's crash involving an old Greasemonkey script. Though I disabled this addon and cleared cache and cookies the profile was not a truly new/fresh profile... and a good chance is that the many crashes the browser got during the day before caused its webappsstore.sqlite size to become big like the size of the file in my main profile (11MB )
So please let me apologize for a not fully accurate report... :(

I read on another thread that PM 27 HTML5 storage is located in webappsstore.sqlite. Is it true ?

So finally, after reading my new info, can you please tell me if you think this webappsstore.sqlite file caused my issue ?
Thanks in advance, again.

LL25255252
Moon lover
Moon lover
Posts: 76
Joined: Sat Aug 29, 2015 3:44 am

Re: thefreedictionary.com pronunciation button stopped working

Postby LL25255252 » Wed Jun 28, 2017 7:06 pm

9 days have passed. The issue reported in my OP hasn't returned since but I want to update my report.
As I described in my last post, I run CCleaner and after that the issue I had with playing media on thefreedictionary.com , soundcloud.com and audiomack.com was was gone.
As you can see from the screenshot I took from the CCleaner window (before the deletion) webappsstore.sqlite got to be very big.

I then raised the question - Is it possible that webappsstore.sqlite was the culprit :?:

So this is my update:
During these 9 days webappsstore.sqlite grew from a small (less than 100kb) file to an 11MB file !! Is this normal :?:
Should I delete it again :?:

Image

User avatar
adesh
Lunatic
Lunatic
Posts: 324
Joined: Tue Jun 06, 2017 7:38 am

Re: thefreedictionary.com pronunciation button stopped working

Postby adesh » Thu Jun 29, 2017 10:02 am

LL25255252 wrote:During these 9 days webappsstore.sqlite grew from a small (less than 100kb) file to an 11MB file !! Is this normal :?:

webappsstore.sqlite file contains data that websites store on your computer, similar to the cookies. So, if you browse a lot of sites or if you visit the kind of sites that rely heavily on this storage, this file can grow well in size. And 11MB is nothing to worry about :)


Return to “Bug reports (Windows)”

Who is online

Users browsing this forum: No registered users and 7 guests