Palemoon deleted a username/password from store

For the more technical/geeky chat subjects!

Moderator: satrow

yereverluvinuncleber
Fanatic
Fanatic
Posts: 143
Joined: Wed, 06 Dec 2017, 21:25

Palemoon deleted a username/password from store

Unread postby yereverluvinuncleber » Sun, 07 Oct 2018, 10:05

Probably raised this in the wrong part tof the forum, apologies, I was being logged out continuously and had a bit of a panic.

I have PM 27.9.3 32 bit (I never update until ALL the problems have been ironed out in a new release) on Windows 7 64bit.

It has been working beautifully.

System required a hard reboot after a lock-up due to some networking issue. Palemoon started immediately after the reboot and when I visited my first site (Deviantart) Palemoon started up with difficulty and locked up having to be killed manually. See event log entry at bottom of post.

On the next run I tried my usual sites but for some reason I was able to access unable to access deviantart, initially it logged me in and I was able to respond to messages on my account. Then I noticed an error message in a pop up that was accidentally clicked-through as there was so much happening on startup. I was not able to take the message text down. I was logged out of the site AND COULD NOT LOG BACK IN.

All my passwords are stored and remembered by PM, I have a very strong 18 character master password. No issues before.

PM would not fill in the username/password fields as normal. I checked the password list using the saved password editor plugin. My site/username password entry for Deviantart was now missing, it was gone from the list. I exported the list to a text file for analysis. The entry is no longer present in the password list. Only PM or myself can delete an entry from the list, it wasn't me.

I also have Firefox running on the same machine using the same exported/imported password list, I can see the entry for deviantart still extant in that list. I was able to take the site details from FF and bring them over to PM and was then able to log in successfully.

Other sites also had access problems from the same point, several asking me to relogin - this Palemoon forum for example expected me to relogin before posting, though initially accepting me as being logged in. Strange behaviour.

The QB64 forum that I access daily will not allow me to login at all despite my password credentials all being present and good, stating "Session verification failed. Please try logging out and back in again, and then try again." I cannot access this site at all.

Not sure what has happened but somehow PM has deleted the site/username/password details from the password file for one of my important sites and that is a worry to me. It is just lucky that I have a recent export.

In the system application event log I see only one error:
The program palemoon.exe version 27.9.3.6735 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Action Center control panel.
Process ID: bf4
Start Time: 01d45e1c6ae4c0ae
Termination Time: 78
Application Path: C:\Program Files (x86)\Pale Moon\palemoon.exe
Report Id: 46a01488-ca11-11e8-b733-0025647f6cbd

I'm assuming profile corruption of some sort. Any thoughts?
Last edited by yereverluvinuncleber on Sun, 07 Oct 2018, 12:59, edited 1 time in total.

yereverluvinuncleber
Fanatic
Fanatic
Posts: 143
Joined: Wed, 06 Dec 2017, 21:25

Re: Palemoon deleted a username/password from store

Unread postby yereverluvinuncleber » Sun, 07 Oct 2018, 10:28

It IS Palemoon.

It is deleting sites/usernames/passwords dynamically. It has just deleted THIS forum from my site history.

What seems to be happening is some sort of issue with the current session. When I posted my last post, after I had made the post I was immediately logged out and when I attempted to relogin, the site/username/password details were deleted. What is happening then is that every site that I visit and attempt to login the user/pass verification details are being removed.

In addition PM is running so slowly as to be unusable when using the dodgy profile.

I am forced to use Firefox for the moment until I can get PM working again. I am suspecting a corruped profile but I have a list of bookmarks/passwords so I can easily (I hope) recreate it.

One other thing, when I restarted PM the first time after the system restart, all my tabs were gone too so PM is having a wobble. When I recreate a new profile is there anything I need to look out for?

I have created a new profile
I have copied over the extensions, fastdial, bookmarkbackup and searchplugins folders from the old profile
I have copied over the prefs.js to copy the customisations
I have copied over my open tabs that I have regularly backed up
I have imported all my passwords and set up a master password.

I now just need to figure out how to restore my lost tabs... any pointers? I know it is possible.

In the end I used the output from the "save my tabs" extension, removed the first three columns, renamed the file from .txt to .html then opened the page in Palemoon and used the 'linky' extension to open all text links as separate tabs. A bit of shuffling up and down my tabs to close all the youtube pages opening all at the same time (volume OFF) and I was done.

Profile restored. Time to backup my profile a little more often. PM has been SO stable that I was lulled into a false sense of security. Time wasted three hours.

In addition my suggestion, regularly export and save your password file as PM can corrupt the entries! My exported XMLs are stored in a veracrypt volume.
Last edited by yereverluvinuncleber on Sun, 07 Oct 2018, 13:04, edited 3 times in total.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22436
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Palemoon deleted a username/password from store

Unread postby Moonchild » Mon, 08 Oct 2018, 10:44

System required a hard reboot after a lock-up due to some networking issue. Palemoon started immediately after the reboot and when I visited my first site (Deviantart) Palemoon started up with difficulty and locked up having to be killed manually. See event log entry at bottom of post.


It is deleting sites/usernames/passwords dynamically. It has just deleted THIS forum from my site history.


I'm afraid you're drawing the wrong conclusions here.

What is really the question is why your system locked up. "some networking issue" (very vague... what happened?) should never lock up your OS so hard that you have to use a hard reboot, so there's definitely something odd going on there.

From there, your issues are not necessarily from design flaws in the browser. In fact, Pale Moon would be doing its best to recover from corrupted database tables in the profile after a hard reset. Purging site history due to corrupted records after recovery has failed is normal -- and in fact the only way a reasonably stable use in the future can be guaranteed. Most likely your session store was also corrupted by the hard reboot.

So, the bottom line is: don't force a hard reboot when the browser is running -- you can end up with unrecoverable corruption in your profile.

All that aside though, we won't continue providing support for v27.* -- please update to v28.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne


Return to “Technical chat”

Who is online

Users browsing this forum: No registered users and 2 guests