Why are add-ons marked "not available"?

Frequently Asked Questions about the Pale Moon browser and their answers.

Moderator: satrow

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22305
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Why are add-ons marked "not available"?

Unread postby Moonchild » Mon, 14 Apr 2014, 09:30

Why are add-ons marked "not available" for Pale Moon?

If you explore available add-ons (extensions) in either the add-on manager or directly on addons.mozilla.org, you may notice that quite a few add-ons are marked as "Unavailable for Firefox 24.9".

This is neither a shortcoming of the browser, nor of the add-ons, but rather of the Mozilla add-ons website!

The underlying problem for developers:
Because of Firefox's rapid release development and the incessant tinkering with the Firefox user interface, many add-on developers are forced to make add-ons compatible with a very small or even single-version range of the browser it was made for. As an example, the "Aero Improved" add-on developer states:
As I cannot keep up with the changes in the bloat (Developer Tools mostly) of FF's rapid releases without breaking compatibility, this release is for FF 27 only. I will only support the most recent version from now on.

In almost all cases, recent updates of add-ons are also solely made to provide compatibility with the latest version of Firefox, and not because bugs were fixed or the add-on was improved or had features added.

The resulting problem for Pale Moon:
Pale Moon's user interface and front-end is (closest) compatible with Firefox 24 at the time of this writing. This is why Pale Moon sends a major version number 24 (for add-on compatibility) to the Mozilla add-ons site. With developers being forced to either stop developing or "living on the edge" in their development (because it's not a paid job, plain and simple), it means that the latest version of the add-on will be incompatible with Pale Moon's application version.

The problem on Mozilla's website:
This wouldn't be a problem, if the Mozilla add-ons website would be smarter in how it offers add-ons to visitors. Unfortunately, AMO (addons.mozilla.org) has a very inflexible system. When the browser version isn't compatible with the latest version of an add-on, it will simply refuse to serve the add-on and state the entire add-on is "not available". This is incorrect, because previous versions are available and would work perfectly fine on the visitor's browser.
There are many, many reasons why someone would not run the very latest 6-week carousel version of Firefox. For example: All of the corporate users on the Extended Service Release, personal choice because of removal of desired/essential features as has been done lately, or even more common that people are already using other extensions that have not been updated for the very latest version of Firefox (usually because the developer would not be able to keep up with providing free work every 6 weeks or to do complete rewrites to address removal of core features/APIs).
Those users are denied access to extensions that would otherwise work perfectly fine on their browser if only AMO would offer a compatible version instead of just saying "not available".

For users to use these add-ons, they currently have to go to the bottom of the page, click "Version information", then click the small "See complete version history" link, and manually check which of the previous versions of the add-on are compatible with Pale Moon or their preferred version of Firefox. It's very convoluted, not easy to discover, and mostly simply unknown to users.

A suggestion was made to improve AMO to offer the "most recent compatible version" in this situation, but so far has gone unanswered and unaddressed (or even acknowledged). Quite possibly, this is because AMO administration is part of the Mozilla management structure and as such will always be pushing for the "latest, (not so) greatest" version of the Firefox browser instead of having a saner delivery system for the wide range of visitors' browser versions.
https://forums.mozilla.org/addons/viewtopic.php?f=20&t=16395
Last edited by Moonchild on Wed, 01 Apr 2015, 11:08, edited 3 times in total.
Reason: Tasty typoes...
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

Take note: 23 November is Wolfenoot! Eat roast meat and/or cake decorated like the full moon. #wolfenoot

Return to “Frequently Asked Questions (F.A.Q.)”

Who is online

Users browsing this forum: No registered users and 2 guests