Build results for Pale Moon 27 (Windows)

For the more technical/geeky chat subjects!

Moderator: satrow

User avatar
intika
Apollo supporter
Apollo supporter
Posts: 35
Joined: Mon May 09, 2016 12:20 am
Location: Belgium
Contact:

Build results for Pale Moon 27 (Windows)

Postby intika » Sat Mar 18, 2017 5:38 am

Building on :
- Win 10 - x32 - Intel Duo 2.8 Ghz - 8 Gb Ram - GForce 9xxx 512 - SSD - (but the project was on a sata hdd)
- Got VS2015 on the machine added VS2013.Com. on top for palemoon
- Win 10 (Cleaned from all the garbage MS added since 8)

Condition :
Running many applications at the same time (at least 10, many browsers, video going on etc...) but nothing really too heavy - AV disabled
While compiling script running, computer used the whole compiling time...

First Build Time :
4h30

Second Build time :
30 Min

Working release ? :
Yes

Process completed without any error ? :
Yes, some warning here and there which is normal
but near the end of the building process i had to free up some ram to get it to build successfully
(had the issue with firefox before... as when it start doing some serious work with library it need a lot of ram)

Is the machine usable while building ? :
Yes, without problem

Compared to building firefox in almost the same condition ? :
Palemoon take a little bit more time like 25%~35% compared to firefox (With my settings)

Other :
i loved the palemoon black icon :)...
i think if i would close everything etc and just let the script build i will get something like 2h ~ 3h for a clean first build (but i did not test it)

User avatar
intika
Apollo supporter
Apollo supporter
Posts: 35
Joined: Mon May 09, 2016 12:20 am
Location: Belgium
Contact:

Re: Build instructions for Pale Moon 27 (Windows)

Postby intika » Sat Mar 18, 2017 2:28 pm

Building time with just the compiler running (build from scratch) :
1h30 (instead of 4h30 lol)

Second build :
Still 30 Min

User avatar
Fedor2
Lunatic
Lunatic
Posts: 323
Joined: Mon Apr 11, 2016 1:26 am

Re: Build results for Pale Moon 27 (Windows)

Postby Fedor2 » Mon Mar 27, 2017 2:48 am

You may want enable parallel building, it will be faster. It just finished building of new release, and it has taken 45 minutes. (core 2 duo, 4 gb ram, sata hdd, video doesn't matter)

add this to the mozconfig

Code: Select all

mk_add_options MOZ_MAKE_FLAGS="-j4"


Return to “Technical chat”

Who is online

Users browsing this forum: No registered users and 5 guests