No favicons anymore

About this bulletin board and the Pale Moon website

Moderators: satrow, FranklinDM, Lootyhoof

Post Reply
User avatar
pm4eva
Apollo supporter
Apollo supporter
Posts: 43
Joined: 2018-06-12, 10:26
Location: CET

No favicons anymore

Post by pm4eva » 2019-05-03, 18:26

No favicons visible nor on website nor in forum anymore

Maybe code like that could help

Code: Select all

<head>
  <link href="favicon.png" type="image/png" rel="icon">
</head>
thx and greets

User avatar
therube
Board Warrior
Board Warrior
Posts: 1105
Joined: 2018-06-08, 17:02

Re: No favicons anymore

Post by therube » 2019-05-03, 18:30

on website nor in forum
On this website/forum, or on any?

(I see them on my end.

Now, while this page has it: https://www.videohelp.com/software
Individual pages of softwares it lists do not (any longer), https://www.videohelp.com/software/ffmpeg.
[Been wanting to mention that to them.])

yami_
Astronaut
Astronaut
Posts: 505
Joined: 2018-04-26, 11:05

Re: No favicons anymore

Post by yami_ » 2019-05-03, 18:32

You do not need this if the favicon is stored in the root directory, like in case of both Pale Moon website and forum.
cat came back from Berkeley waving flags -- rob pike

User avatar
pm4eva
Apollo supporter
Apollo supporter
Posts: 43
Joined: 2018-06-12, 10:26
Location: CET

Re: No favicons anymore

Post by pm4eva » 2019-05-03, 18:41

I only talk about Pale Moon sites at the moment but the problem exists on all websites without that code.
It seems it is still a problem with Pale Moon and uBlockOrigin

Firefox with uBlockOrigin shows the favicons
I really don't know why becouse i use same blocklists and settings.

But what i know is that this code works on other sites.
thx and greets

User avatar
therube
Board Warrior
Board Warrior
Posts: 1105
Joined: 2018-06-08, 17:02

Re: No favicons anymore

Post by therube » 2019-05-03, 18:56

It seems it is still a problem with Pale Moon and uBlockOrigin
So if you restart in Safe Mode, you can see the favicons?

User avatar
pm4eva
Apollo supporter
Apollo supporter
Posts: 43
Joined: 2018-06-12, 10:26
Location: CET

Re: No favicons anymore

Post by pm4eva » 2019-05-04, 05:52

Yes, even if i deactivate only uBlockOrigin in PaleMoon/Basilisk/Firefox52ESR i can see the favicons.
In Firefox 66 no problem and visible with uBlockOrigin.
thx and greets

User avatar
Isengrim
Board Warrior
Board Warrior
Posts: 1001
Joined: 2015-09-08, 22:54
Location: 127.0.0.1
Contact:

Re: No favicons anymore

Post by Isengrim » 2019-05-04, 10:30

pm4eva wrote:
2019-05-04, 05:52
Yes, even if i deactivate only uBlockOrigin in PaleMoon/Basilisk/Firefox52ESR i can see the favicons.
In Firefox 66 no problem and visible with uBlockOrigin.
Don't just deactivate UBO, actually restart the whole browser in Safe Mode (Help > Restart in Safe Mode). There's a huge difference between the two.
Linux Mint 19.2 Cinnamon (64-bit), Windows 7 (64-bit), Windows 10 build 1803 (64-bit)
"As long as there is someone who will appreciate the work involved in the creation, the effort is time well spent." ~ Tetsuzou Kamadani, Cave Story

User avatar
Konrad
Moon lover
Moon lover
Posts: 97
Joined: 2018-11-17, 18:19

Re: No favicons anymore

Post by Konrad » 2019-05-04, 11:33

pm4eva wrote:
2019-05-03, 18:41
I only talk about Pale Moon sites at the moment but the problem exists on all websites without that code. It seems it is still a problem with Pale Moon and uBlockOrigin
It’s rather strange. I use uBO in Pale Moon 28.5.0 without the code you have provided and all pages of the Pale Moon forum and website have their favicons.

moonie
Moonbather
Moonbather
Posts: 62
Joined: 2017-08-25, 12:59

Re: No favicons anymore

Post by moonie » 2019-05-04, 11:50

It's funny, this topic coming up, because yesterday all of my bookmark favicons were gone (I think it was due to me deleting some file when searching for what turned out to be an .msi installer to delete; I get fanatical when I detect an unexplained increase in drive data—I even took the opportunity to backup my bookmarks, as the resulting .html file was half of its usual size without the icons.) No problem with that for me, though, as they come back when used, and i don't have that many of them saved to begin with. But I do think that in my case it was caused by the deletion of whatever file that was... wish I remembered what that file was, for possible future reference.

User avatar
pm4eva
Apollo supporter
Apollo supporter
Posts: 43
Joined: 2018-06-12, 10:26
Location: CET

Re: No favicons anymore

Post by pm4eva » 2019-05-05, 23:46

It must be a uBlockOrigin problem.
Without it i CAN see the favicons.
So i do not need use SafeMode for testing it again, or do i?
I am a little confused now.
thx and greets

User avatar
Nigaikaze
Board Warrior
Board Warrior
Posts: 1110
Joined: 2014-02-02, 22:15
Location: Chicago, IL, USA

Re: No favicons anymore

Post by Nigaikaze » 2019-05-05, 23:56

pm4eva wrote:
2019-05-05, 23:46
It must be a uBlockOrigin problem.
It must be a uBlock Origin configuration problem on your end. Like Konrad, I am using uBO with Pale Moon and I am having no trouble seeing the favicons with uBO enabled. What version of uBO are you using?
Also, try disabling the various filter lists you're using one by one and see if you can see the favicons afterwards; that might narrow the problem down to a specific filter list.
Nichi nichi kore ko jitsu = Every day is a good day.

doofy
Astronaut
Astronaut
Posts: 587
Joined: 2017-08-14, 23:43

Re: No favicons anymore

Post by doofy » 2019-05-06, 00:00

There's no must about it.

It's highly unlikely to be uB0.
What it could be is interference between uB0 and another extension - with anything to do with tab handling being a likely suspect.

I'd leave uB0 on, and slowly turn off all other extensions, starting with any tab stuff.

User avatar
pm4eva
Apollo supporter
Apollo supporter
Posts: 43
Joined: 2018-06-12, 10:26
Location: CET

Re: No favicons anymore

Post by pm4eva » 2019-05-06, 00:16

uBlock Origin 1.16.4.10
Tab Mix Plus 0.5.7.0

tested in save mode = favicons visible
tested all addons deactivated and only UBO activated = NO favicons visible

now i ll ceck disabling all blocklists
hope i can login later i got troubles before with login here again
thx and greets

User avatar
pm4eva
Apollo supporter
Apollo supporter
Posts: 43
Joined: 2018-06-12, 10:26
Location: CET

Re: No favicons anymore

Post by pm4eva » 2019-05-06, 02:06

Now i am even more confused.
I found out it is a problem with Fanboy's Enhanced Tracking List

But only in PaleMoon and with uBlockOrigin
If i disable this list i can see the favicons again.

In Firefox 66.0.4 and uBlockOrigin no problem with this list.
And even in PaleMoon with AdblockLatitude i can use this list.

It must be a very strange side effect or version bug in uBlockOrigin.

Thank you for helping.
thx and greets

User avatar
Nigaikaze
Board Warrior
Board Warrior
Posts: 1110
Joined: 2014-02-02, 22:15
Location: Chicago, IL, USA

Re: No favicons anymore

Post by Nigaikaze » 2019-05-06, 02:25

pm4eva wrote:
2019-05-06, 02:06
I found out it is a problem with Fanboy's Enhanced Tracking List
But only in PaleMoon and with uBlockOrigin
If i disable this list i can see the favicons again.
Very glad to hear you figured it out. The odd thing is I'm using that same version of uBlock Origin (v1.16.4.10) with Pale Moon 28.5.0, and if I enable Fanboy's Enhanced Tracking List I can still see favicons on all of the palemoon.org pages. I don't know why that list would be behaving differently with your PM/uBO combination ... unless there really is some level of interference with uBO by another one of your PM extensions.
Nichi nichi kore ko jitsu = Every day is a good day.

User avatar
pm4eva
Apollo supporter
Apollo supporter
Posts: 43
Joined: 2018-06-12, 10:26
Location: CET

Re: No favicons anymore

Post by pm4eva » 2019-05-10, 11:09

I have found a fix now for this problem.
If you add this rule in uBlockOrigin, the favicons will be shown again.

Code: Select all

/favicon.ico$image,third-party,domain=~bt.com|~ebay.com.au|~ebay.com|~go.com|~github.com|~stackexchange.com|~stackoverflow.com|~askubuntu.com|~reddit.com|~4chan.org|~twitter.com|~live.com|~espn.com,badfilter
This rule just disables exactly the same rule from Fanboys Enhanced Tracking List.
But i realy dont know why that rule makes troubles.
thx and greets

User avatar
Tomaso
Board Warrior
Board Warrior
Posts: 1309
Joined: 2015-07-23, 16:09
Location: Norway

Re: No favicons anymore

Post by Tomaso » 2019-05-11, 14:25


User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24979
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: No favicons anymore

Post by Moonchild » 2019-05-11, 17:21

the favicon can lead to artificially slow page-load time ... if it is nonexistent.
That's nonsense. The favicon is requested separately, not as part of the page load.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
johnstr
New to the forum
New to the forum
Posts: 1
Joined: 2019-08-08, 14:19

Re: No favicons anymore

Post by johnstr » 2019-08-08, 14:23

pm4eva wrote:
2019-05-10, 11:09
I have found a fix now for this problem.
If you add this rule in uBlockOrigin, the favicons will be shown again.

Code: Select all

/favicon.ico$image,third-party,domain=~bt.com|~ebay.com.au|~ebay.com|~go.com|~github.com|~stackexchange.com|~stackoverflow.com|~askubuntu.com|~reddit.com|~4chan.org|~twitter.com|~live.com|~espn.com,badfilter
This rule just disables exactly the same rule from Fanboys Enhanced Tracking List.
But i realy dont know why that rule makes troubles.
You are a life saver. Struggled for sometime with this issue.


Thanks

lavabo
Apollo supporter
Apollo supporter
Posts: 45
Joined: 2015-07-29, 08:47
Location: paris

Re: No favicons anymore

Post by lavabo » 2019-11-11, 08:20

pm4eva wrote:
2019-05-06, 02:06
Now i am even more confused.
I found out it is a problem with Fanboy's Enhanced Tracking List

But only in PaleMoon and with uBlockOrigin
If i disable this list i can see the favicons again.

In Firefox 66.0.4 and uBlockOrigin no problem with this list.
And even in PaleMoon with AdblockLatitude i can use this list.

It must be a very strange side effect or version bug in uBlockOrigin.

Thank you for helping.
i had the same list and the same favicon problem, but the faivcon of the bookmark was not loaded. the favicon in the URl and in the tab loaded fine though...
I disabled the list and i get the favicon in the bookmark too now.

Post Reply