Longer "Connecting...." while accessing Pale Moon forum. Topic is solved

About this bulletin board and the Pale Moon website

Moderators: Indalecio, satrow

User avatar
Latitude
Lunatic
Lunatic
Posts: 382
Joined: Mon Mar 21, 2016 6:28 pm

Longer "Connecting...." while accessing Pale Moon forum.

Postby Latitude » Mon May 29, 2017 7:12 am

I don't know why it takes a slightly longer time to access Pale Moon forum.

(The "Connecting to forum.palemoon.org...." status appears to take longer time.)

I'm in Indonesia and using wireless network for daily internet use.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 18775
Joined: Sun Aug 28, 2011 5:27 pm
Location: 58.5°N 15.5°E
Contact:

Re: Longer "Connecting...." while accessing Pale Moon forum.

Postby Moonchild » Mon May 29, 2017 9:01 am

For you, the forum server is literally on the other side of the planet (Canada). That's a long route, and many things can slow down traffic along the way.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.
Image

User avatar
gracious1
Fanatic
Fanatic
Posts: 231
Joined: Sun May 15, 2016 5:00 am
Location: sunny upsate NY
Contact:

Re: Longer "Connecting...." while accessing Pale Moon forum.

Postby gracious1 » Tue May 30, 2017 2:17 am

I am in the USA, and I am noticing the same issue as the OP.
ImageBe not the first by whom the new are tried, nor yet the last to lay the old aside. — Alexander Pope

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 18775
Joined: Sun Aug 28, 2011 5:27 pm
Location: 58.5°N 15.5°E
Contact:

Re: Longer "Connecting...." while accessing Pale Moon forum.

Postby Moonchild » Tue May 30, 2017 8:54 am

I am in the EU, and the forum is as fast as you could reasonably expect (connecting to barely takes any time).

Can you both include a traceroute to see if there are common factors?
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.
Image

User avatar
gracious1
Fanatic
Fanatic
Posts: 231
Joined: Sun May 15, 2016 5:00 am
Location: sunny upsate NY
Contact:

Re: Longer "Connecting...." while accessing Pale Moon forum.

Postby gracious1 » Sat Jun 10, 2017 2:10 am

Output of traceroute

Code: Select all

$ traceroute forum.palemoon.org
traceroute to forum.palemoon.org (144.217.16.169), 30 hops max, 60 byte packets
 1  192.168.0.1 (192.168.0.1)  11.062 ms  11.016 ms  11.442 ms
 2  142.254.213.177 (142.254.213.177)  19.112 ms  20.972 ms  20.966 ms
 3  agg39.ithcnycy02h.northeast.rr.com (24.58.240.93)  135.721 ms  135.713 ms  138.108 ms
 4  agg79.esyrnyaw02r.northeast.rr.com (24.58.52.88)  24.917 ms  24.931 ms  27.957 ms
 5  agg27.rochnyei01r.northeast.rr.com (24.58.32.76)  33.502 ms  34.101 ms  39.712 ms
 6  bu-ether45.chcgildt87w-bcr00.tbone.rr.com (107.14.19.106)  44.262 ms  37.973 ms  37.508 ms
 7  0.ae0.pr1.chi10.tbone.rr.com (107.14.17.192)  29.739 ms 0.ae4.pr1.chi10.tbone.rr.com (66.109.1.66)  33.707 ms 0.ae2.pr1.chi10.tbone.rr.com (107.14.17.196)  34.506 ms
 8  chi-b21-link.telia.net (213.248.76.97)  35.474 ms  36.817 ms  36.836 ms
 9  nyk-bb3-link.telia.net (62.115.137.54)  46.946 ms nyk-bb4-link.telia.net (62.115.125.16)  50.827 ms  50.855 ms
10  nyk-b2-link.telia.net (62.115.137.99)  40.282 ms nyk-b2-link.telia.net (213.155.130.28)  41.050 ms  44.202 ms
11  be100-154.nwk-5-a9.nj.us (192.99.146.38)  44.654 ms  44.715 ms  49.473 ms
12  192.99.146.138 (192.99.146.138)  55.457 ms *  51.384 ms
13  po7.bhs-vac1-a75.qc.ca (192.99.146.147)  50.448 ms  52.437 ms  52.796 ms
14  bhs-vac1-a75-1-firewall.qc.ca (192.99.146.152)  54.036 ms  55.392 ms  55.436 ms
15  bhs-vac1-a75-2-shield.qc.ca (192.99.146.153)  59.098 ms  51.767 ms  50.584 ms
16  bhs-vac1-a75-3.qc.ca (192.99.146.151)  51.644 ms  51.650 ms  53.649 ms
17  * * *
18  be50-7.bhs-3a-a9.qc.ca (198.27.73.94)  216.396 ms be50-5.bhs-3a-a9.qc.ca (198.27.73.92)  219.621 ms be50-5.bhs-3b-a9.qc.ca (198.27.73.96)  59.493 ms
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *
ImageBe not the first by whom the new are tried, nor yet the last to lay the old aside. — Alexander Pope

User avatar
dark_moon
Knows the dark side
Knows the dark side
Posts: 3506
Joined: Mon Jan 09, 2012 5:34 pm
Location: Germany

Re: Longer "Connecting...." while accessing Pale Moon forum.

Postby dark_moon » Sat Jun 10, 2017 8:11 am

My looks different (live in Germany):

Code: Select all

Routenverfolgung zu forum.palemoon.org [144.217.16.169] über maximal 30 Abschnit
te:

  1    <1 ms    <1 ms    <1 ms  my router [my router IP]
  2     7 ms     8 ms     8 ms  my provider IP
  3    16 ms    15 ms    15 ms  f-ee1-i.F.DE.NET.DTAG.DE [217.5.95.186]
  4    16 ms    16 ms    16 ms  be100-162.fra-5-a9.de.eu [37.187.232.98]
  5    22 ms    18 ms    18 ms  be100-1169.ams-5-a9.nl.eu [91.121.215.196]
  6    17 ms    17 ms    17 ms  po7.sbg-vac1-a75.fr.eu [213.186.32.143]
  7    18 ms    18 ms    18 ms  sbg-vac1-a75-1-firewall.fr.eu [178.33.99.143]
  8    17 ms    17 ms    16 ms  sbg-vac1-a75-2-shield.fr.eu [178.33.99.144]
  9    17 ms    17 ms    17 ms  sbg-vac1-a75-3.fr.eu [178.33.99.142]
 10     *        *        *     Zeitüberschreitung der Anforderung.
 11   182 ms   182 ms   182 ms  vl1308.bhs-g1-a75.qc.ca [213.251.130.61]
 12   344 ms   331 ms   342 ms  be50-5.bhs-3a-a9.qc.ca [198.27.73.92]
 13   182 ms   182 ms   182 ms  144.217.16.169

Ablaufverfolgung beendet.
Happy Pale Moon x64 under Win7 x64 User
German translator for Pale Moon 15+ and Pale Moon Commander addon

HowTo create a new Pale Moon Profile & use the Safe Mode
My GPG Key: 0x01EAFE95

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 18775
Joined: Sun Aug 28, 2011 5:27 pm
Location: 58.5°N 15.5°E
Contact:

Re: Longer "Connecting...." while accessing Pale Moon forum.

Postby Moonchild » Sat Jun 10, 2017 1:13 pm

gracious1 your traceroute is certainly not looking healthy, but it's somewhere in Canada where it goes awry. Not really much you or I can do about.
Latitude, can you please post a trace too if you are still having issues, see if there are common problems on the route for you both? If so I can poke the provider and ask about it.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.
Image

User avatar
Latitude
Lunatic
Lunatic
Posts: 382
Joined: Mon Mar 21, 2016 6:28 pm

Re: Longer "Connecting...." while accessing Pale Moon forum.

Postby Latitude » Sat Jun 10, 2017 5:32 pm

Accessing Pale Moon forum without any hassles through Pale Moon browser.

But, in command prompt, "tracert forum.palemoon.org" only gets RTOs, sequentially.

I don't know why.

Code: Select all

C:\Users\USER>tracert forum.palemoon.org

Tracing route to forum.palemoon.org [144.217.16.169]
over a maximum of 30 hops:

  1     *        *        *     Request timed out.
  2     *        *        *     Request timed out.
  3     *        *        *     Request timed out.
  4     *        *        *     Request timed out.
  5     *        *        *     Request timed out.
  6     *        *        *     Request timed out.
  7     *        *        *     Request timed out.
  8     *        *        *     Request timed out.
  9     *        *        *     Request timed out.
 10     *        *        *     Request timed out.
 11     *        *        *     Request timed out.
 12  ^C
C:\Users\USER>


Living in a third-world country maybe the culprit. :lol:

User avatar
Latitude
Lunatic
Lunatic
Posts: 382
Joined: Mon Mar 21, 2016 6:28 pm

Re: Longer "Connecting...." while accessing Pale Moon forum.

Postby Latitude » Sat Jun 10, 2017 5:38 pm

My ISP's name is "3". (http://tri.co.id/)

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 18775
Joined: Sun Aug 28, 2011 5:27 pm
Location: 58.5°N 15.5°E
Contact:

Re: Longer "Connecting...." while accessing Pale Moon forum.

Postby Moonchild » Mon Jun 12, 2017 10:31 am

Latitude, you're probably blocking pings in your firewall. If so, you may also be blocking other ICMP protocols or TCP status packages which are needed for smooth operation of networking.

You say you have no issues connecting now but you opened this thread yourself... so, which is it?
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.
Image

User avatar
Latitude
Lunatic
Lunatic
Posts: 382
Joined: Mon Mar 21, 2016 6:28 pm

Re: Longer "Connecting...." while accessing Pale Moon forum.

Postby Latitude » Mon Jun 12, 2017 10:50 am

Moonchild wrote:Latitude, you're probably blocking pings in your firewall. If so, you may also be blocking other ICMP protocols or TCP status packages which are needed for smooth operation of networking.

You say you have no issues connecting now but you opened this thread yourself... so, which is it?


I mean that I eventually could access Pale Moon forum, although sometimes, the quite long "Connecting...." status still happens.

I have HostsMan installed in my computer and my hosts file is 12+ MB with DNS Client service set to disabled.
Maybe the hosts file is the culprit?

Firewall: standard Windows firewall.

But, my internet connection is censored by the government in ISP level and couldn't use alternate DNS servers (like Google DNS) because they are blacklisted too.
The software the gov't uses is squid.
(But, I could bypass it by using proxies, the "free VPN" add-ons :) ).

Lucio Chiappetti
Fanatic
Fanatic
Posts: 200
Joined: Mon Sep 01, 2014 3:11 pm
Location: Milan Italy

Re: Longer "Connecting...." while accessing Pale Moon forum.

Postby Lucio Chiappetti » Mon Jun 12, 2017 11:17 am

For me (Italy) the connection to the PM forum itself is as fast as ever, but the tab and status bar remains in "connecting" status (to pagead2.googlesyndication.com) for a longer time after the page has displayed OK. I assumed this was due to the fact I recenlty disabled the adblocker for the PM site (it seemed to start occurring since then)

I noted significant slowdowns occasionally (in the last weeks) to another forum (server in Switzerland) also served by PhpBB. It was referred by the mantainers to saturation of database accesses on the server (hosting also other forums) possibly due to DDoS attacks. In a few cases there were also timeout messages.

User avatar
adesh
Moonbather
Moonbather
Posts: 51
Joined: Tue Jun 06, 2017 7:38 am

Re: Longer "Connecting...." while accessing Pale Moon forum.

Postby adesh » Mon Jun 12, 2017 12:34 pm

Lucio Chiappetti wrote:but the tab and status bar remains in "connecting" status (to pagead2.googlesyndication.com) for a longer time after the page has displayed OK

I'm also facing the very same issue even though I have blocked that domain using my hosts file on my Linux system. The page loads completely and then after one second the "connecting" message appears in status bar and rotating circle is shown again in tab title bar to indicate page loading. This loading activity happens for almost 10 seconds.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 18775
Joined: Sun Aug 28, 2011 5:27 pm
Location: 58.5°N 15.5°E
Contact:

Re: Longer "Connecting...." while accessing Pale Moon forum.

Postby Moonchild » Mon Jun 12, 2017 4:12 pm

The bottom ad is loaded asynchronously. The page itself will be done before those connections are fired. If you for whatever reason block connections to (some of the host of) the ad networks serving the ads, it will keep the text in the status bar until it times out. If you prefer not to see details of background connections (or if they confuse you), you can switch those off in the status bar options.
Attachments
bgnwstatus.png
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.
Image

User avatar
adesh
Moonbather
Moonbather
Posts: 51
Joined: Tue Jun 06, 2017 7:38 am

Re: Longer "Connecting...." while accessing Pale Moon forum.

Postby adesh » Mon Jun 12, 2017 4:22 pm

Moonchild wrote:it will keep the text in the status bar until it times out.

Need some clarification regarding that - since domain is pointing to 127.0.0.1, shouldn't the request time-out immediately. When I fire the exact request in my terminal, response is immediate, i.e connection refused.

Code: Select all

curl: (7) Failed to connect to pagead2.googlesyndication.com port 443: Connection refused

Octopuss
Lunatic
Lunatic
Posts: 290
Joined: Mon Jan 26, 2015 1:58 pm

Re: Longer "Connecting...." while accessing Pale Moon forum.  Topic is solved

Postby Octopuss » Wed Jun 14, 2017 8:17 pm

The forum is always noticeably slower for me if I don't block ads. Solution: I donated another €10 and kept Adblock active.


Return to “Forum and website”

Who is online

Users browsing this forum: AOL Reader [RSS], Moz [Crawler] and 1 guest