SDK-based extensions patched to run in Pale Moon 27

General discussion, compatibility and contributed extensions.

Moderators: FranklinDM, Lootyhoof

User avatar
JustOff
Moon Magic practitioner
Moon Magic practitioner
Posts: 2083
Joined: 2015-09-03, 19:47
Location: UA
Contact:

SDK-based extensions patched to run in Pale Moon 27

Post by JustOff » 2016-11-22, 20:51

As I promised before, here is the set of SDK-based extensions patched to run in Pale Moon 27, created due to lack of suitable alternatives.

According to the official position of the Pale Moon development team, such patching should be considered as hacking, and they cannot and will not provide any guarantees that anything will work or keep working; nor will they provide any support for anyone running an SDK extension that has been hacked to make it to run with the toolkit modules. That includes all support, also for general browser use, because SDK-sourced extensions may break the browser if forced to run.

Don't try to install all from the list or the extension you never used before. Please, use these addons only as last resort measure! Better ask the developer of the original version to provide non SDK-based solution.

Also please note that I can't promise any support or updates or create patches for any other SDK-based extensions, except ones that I personally use or consider extremely useful.
Here are the add-ons I made in a spare time. That was fun!

If you have any questions or problems regarding the migration of my extensions to GitHub, feel free to contact me through a PM.

GreenGeek

Re: SDK-based extensions patched to run in Pale Moon 27

Post by GreenGeek » 2016-11-22, 23:50

Nothing there but readme as far as I can tell.

User avatar
JustOff
Moon Magic practitioner
Moon Magic practitioner
Posts: 2083
Joined: 2015-09-03, 19:47
Location: UA
Contact:

Re: SDK-based extensions patched to run in Pale Moon 27

Post by JustOff » 2016-11-23, 00:04

GreenGeek wrote:Nothing there but readme as far as I can tell.
Have you tried to read this readme? :roll:
Here are the add-ons I made in a spare time. That was fun!

If you have any questions or problems regarding the migration of my extensions to GitHub, feel free to contact me through a PM.

GreenGeek

Re: SDK-based extensions patched to run in Pale Moon 27

Post by GreenGeek » 2016-11-23, 01:57

That table wasn't there before!!! :mrgreen:

Munkenmo

Re: SDK-based extensions patched to run in Pale Moon 27

Post by Munkenmo » 2016-11-23, 02:36

Were these patches difficult to implement? If not do you have a guide anywhere?

I'm holding off 27 until there's some form of compatibility with RES

User avatar
JustOff
Moon Magic practitioner
Moon Magic practitioner
Posts: 2083
Joined: 2015-09-03, 19:47
Location: UA
Contact:

Re: SDK-based extensions patched to run in Pale Moon 27

Post by JustOff » 2016-11-23, 12:40

Unfortunately there is no common solution and possibility to force SDK-based extension to run in Pale Moon 27 depends of actual API used in particular addon.

Extensions who add buttons to the toolbar or items to the context menu is unlikely can be adapted at all, because new SDK can handle only Australis UI, while old one can't be run under new browser core.

Anyway, you should not rely on this hacking way considering the warnings mentioned above.
Here are the add-ons I made in a spare time. That was fun!

If you have any questions or problems regarding the migration of my extensions to GitHub, feel free to contact me through a PM.

User avatar
0strodamus
Fanatic
Fanatic
Posts: 122
Joined: 2014-11-19, 19:48
Location: US

Re: SDK-based extensions patched to run in Pale Moon 27

Post by 0strodamus » 2016-11-24, 01:03

@JustOff: Thanks very much for the Pale Moon 27 extensions AddBookmarkHere2, Cookies Exterminator, and Decentraleyes! :clap:
archlinux | OpenRC | TOMOYO Linux | Xfce

"In his house at R'lyeh dead Cthulhu waits dreaming."

Falna
Lunatic
Lunatic
Posts: 369
Joined: 2015-08-23, 17:56
Location: UK / France

Re: SDK-based extensions patched to run in Pale Moon 27

Post by Falna » 2016-11-24, 02:59

Thanks from me too - good to have Decentraleyes and I don't care about cookies working again. Extra impressive that you've been able to fix them as well as your input on localization!

DoctorM
Fanatic
Fanatic
Posts: 123
Joined: 2014-07-31, 18:19
Location: USA

Re: SDK-based extensions patched to run in Pale Moon 27

Post by DoctorM » 2016-11-24, 05:41

Thank you. I was worried I'd never see Reload Plus again. It's an addon that seems fairly unique in what it does. :thumbup:

User avatar
ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2412
Joined: 2012-06-28, 01:20

Re: SDK-based extensions patched to run in Pale Moon 27

Post by ron_1 » 2016-11-24, 21:22

@JustOff : Decentrayleyes is now up to version 1.3.6.

User avatar
JustOff
Moon Magic practitioner
Moon Magic practitioner
Posts: 2083
Joined: 2015-09-03, 19:47
Location: UA
Contact:

Re: SDK-based extensions patched to run in Pale Moon 27

Post by JustOff » 2016-11-24, 22:27

helloimustbegoing wrote:@JustOff : Decentrayleyes is now up to version 1.3.6.
Amen 8-)
Here are the add-ons I made in a spare time. That was fun!

If you have any questions or problems regarding the migration of my extensions to GitHub, feel free to contact me through a PM.

dark_moon

Re: SDK-based extensions patched to run in Pale Moon 27

Post by dark_moon » 2016-11-24, 22:36

JustOff wrote:
helloimustbegoing wrote:@JustOff : Decentrayleyes is now up to version 1.3.6.
Amen 8-)
On https://github.com/Synzvato/decentraleyes/releases i only found Decentraleyes.v1.3.6-firefox.xpi
Or is this release for Pale Moon too?
And also the about:addons doesn't show up a update. Same for https://addons.palemoon.org/

User avatar
JustOff
Moon Magic practitioner
Moon Magic practitioner
Posts: 2083
Joined: 2015-09-03, 19:47
Location: UA
Contact:

Re: SDK-based extensions patched to run in Pale Moon 27

Post by JustOff » 2016-11-24, 22:50

dark_moon wrote:Or is this release for Pale Moon too?
Amen means that I'll look at this in a spare time (or may be not, see 1st post) :ugeek:
Here are the add-ons I made in a spare time. That was fun!

If you have any questions or problems regarding the migration of my extensions to GitHub, feel free to contact me through a PM.

dark_moon

Re: SDK-based extensions patched to run in Pale Moon 27

Post by dark_moon » 2016-11-24, 22:57

Alright :mrgreen: :thumbup:

Luna Tic

Re: SDK-based extensions patched to run in Pale Moon 27

Post by Luna Tic » 2016-11-24, 23:01

JustOff, a question for you. Probably totally silly, but I don't know much about extensions.
Seems like it is no big deal for you to make these (jetpack?) extensions work for PM. Would it be possible (not necessarily for you, but in general, technically) to create a special addon that would make other extensions work with PM? What I mean is that there would be this addon, something like greasemonkey, and then you could plug into it the other extensions that used to work, but don't work any more. Would this "addonmonkey" be possible and would it work? Even if it would be considered a hack and not be supported.

User avatar
JustOff
Moon Magic practitioner
Moon Magic practitioner
Posts: 2083
Joined: 2015-09-03, 19:47
Location: UA
Contact:

Re: SDK-based extensions patched to run in Pale Moon 27

Post by JustOff » 2016-11-24, 23:09

Luna Tic wrote:Would it be possible (not necessarily for you, but in general, technically) to create a special addon that would make other extensions work with PM?
Unfortunately it's impossible, the reason was explained above.
Here are the add-ons I made in a spare time. That was fun!

If you have any questions or problems regarding the migration of my extensions to GitHub, feel free to contact me through a PM.

Luna Tic

Re: SDK-based extensions patched to run in Pale Moon 27

Post by Luna Tic » 2016-11-24, 23:16

Right, my bad. Sorry, I missed that post somehow.
Seems like, if I understand your post correctly, the problem is with Australis. What about addons that don't do much with the UI? Like Decentraleyes.

idcac
Hobby Astronomer
Hobby Astronomer
Posts: 18
Joined: 2015-12-30, 12:41
Location: Zagreb

Re: SDK-based extensions patched to run in Pale Moon 27

Post by idcac » 2016-11-25, 13:09

The official version of I don't care about cookies works again.
https://addons.palemoon.org/extensions/ ... t-cookies/

Thanks to Off JustOff, I couldn't have done it without him!

User avatar
JustOff
Moon Magic practitioner
Moon Magic practitioner
Posts: 2083
Joined: 2015-09-03, 19:47
Location: UA
Contact:

Re: SDK-based extensions patched to run in Pale Moon 27

Post by JustOff » 2016-11-25, 13:16

idcac wrote:The official version of I don't care about cookies works again.
You are welcome! But don't forget to ask Matt A Tobin to update your addon's page with corresponding warnings.
Here are the add-ons I made in a spare time. That was fun!

If you have any questions or problems regarding the migration of my extensions to GitHub, feel free to contact me through a PM.

Kanaev

Re: SDK-based extensions patched to run in Pale Moon 27

Post by Kanaev » 2016-11-27, 22:29

Hello, can you please make this https://addons.mozilla.org/en-US/firefo ... zoom-plus/ work on PM27?

Locked