Ver 27 reported outdated, no Adblock after downgrade

Users and developers helping users with generic and technical Pale Moon issues on all operating systems.
Please direct questions that are Mac or Linux-specific (dealing with installation and OS integration) to the appropriate Linux or Mac board.

Moderator: trava90

Forum rules
This board is for technical/general usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions that are specific for Linux and Mac to the dedicated boards for those operating systems.
Technical issues and questions not related to the Pale Moon browser should be posted in other boards!
Please keep off-topic and general discussion out of this board, thank you!
Locked
wsurfer0

Ver 27 reported outdated, no Adblock after downgrade

Post by wsurfer0 » 2016-11-24, 17:02

Operating system: Win 8.1 64-bit
Browser version: 26.5.0
32-bit or 64-bit?: 64
Installed add-ons: new tab homepage
Installed plugins: flash

Up until now, everything was working. Today I upgraded to version 27 - first the Google interface turned into the old version (black ribbon on top, etc.) and then several websites said "Your browser is outdated" or similar. So I say f-it, and reinstall version 26.5.0. However, and this is my problem, Adblock Latitude is suddenly no longer compatible and I can't find older versions anywhere.

Could someone please give a link, without Adblock for me it's like I don't have a browser at all. Thanks in advance.

PS I didn't post this in the add-ons section because I'm also interested in why a newer version would produce said problems when the older one did not?

User avatar
Sajadi
Board Warrior
Board Warrior
Posts: 1101
Joined: 2013-04-19, 00:46

Re: Ver 27 reported outdated, no Adblock after downgrade

Post by Sajadi » 2016-11-24, 20:49

The only reason why you got the outdated message is because Google has not recognized the user agent.

There was no reason to downgrade. Follow the instructions to make that message disappear:

viewtopic.php?f=24&t=6004

Downgrading after upgrading seems to be able to screw things up, as version 27 is very different from 26 and downgrading can create incompatibilities.

Anyway, the link here should fix your adblock issue:

https://addons.palemoon.org/extensions/ ... -latitude/

Toonces

Re: Ver 27 reported outdated, no Adblock after downgrade

Post by Toonces » 2016-11-24, 21:46

I'm in the same boat as wsurfer0-- after becoming extremely frustrated with all the bugs in PM27 I upgraded to 26.5.0 (big Kudos to the PM team for making the older versions readily available) and am now missing Adblock Latitude. Unfortunately, the link provided above only supplies the incompatible version. Can someone please point us to a viable link to the previous version of ABL that will work with PM 26? Many thanks for any help anyone can provide-- I'm now kicking myself around the block for having "upgraded" to 27 in the first place and just want a functioning browser again.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 27871
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: Ver 27 reported outdated, no Adblock after downgrade

Post by Moonchild » 2016-11-24, 22:00

ftp://archive:get@ftp2.palemoon.org/extensions/ABL/

grab 3.0.3.1 for 26.5.0
Tobin was a bit eager to remove the 3.0 version from the public with it being incompatible; and the addons site does not yet have an option to show older versions (that will be done later)

I'll grab the XPIs from the addons site and drop all of them on the archive FTP, just in case people need them for as long as we don't have a "previous versions" option yet in our interface
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 27871
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: Ver 27 reported outdated, no Adblock after downgrade

Post by Moonchild » 2016-11-24, 22:10

Also, "outdated" messages are likely websites that require "Firefox Compatibility" mode in options for User Agent Mode (Options -> Advanced -> tab "General")
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

Toonces

Re: Ver 27 reported outdated, no Adblock after downgrade

Post by Toonces » 2016-11-25, 04:40

Many, many thanks, Moonchild! All is right in my world again. :-)

Some of the sites I frequent are so laden with ads that it's infuriating to navigate them without an ad blocker so even though 26.5 had been working fine for me in the past the loss of ABL had significantly compromised its usability. I very much appreciate your quick response and fix. Was also able to solve the same problem on my 80 year old mom's computer, so she sends her thanks as well.

rbruce1314
Moonbather
Moonbather
Posts: 52
Joined: 2016-04-02, 09:06

Re: Ver 27 reported outdated, no Adblock after downgrade

Post by rbruce1314 » 2016-11-25, 07:56

I too can't live without adblock. Looking over the various threads here, I tried going to addons and hitting the 'update' gear wheel. It did update to v3.5 as promised - but still didn't appear on the toolbar or in the 'customize' box. I had already changed the user agent compatibility to 'Firefox' as instructed elsewhere but no joy - no adblock.

But, being a control freak and very wary, right back to when FIrefox started messing about (I no longer use it at all - I still have v41!!), I never upgrade but always do a fresh install into a new folder - having previously saved my profile to an external drive! So for me a revert to PM26 was a doddle. Back comes adblock, back comes youtube downloading etc. - the only negative is the missing contacts dropdown in Outlook.com

Sorry if this is not helpful to those already committed, but it may stop some others getting VERY frustrated...........

Afterthought: if, like me, you do full image backups regularly (with Macrium or the like) you can go back to the backup before you upgraded to 27 and recover your v26 profile from there (it's in users/*(name)*/AppData/Roaming in the folder 'Moonchild Productions').
It may be a fiddle (sometimes you have to 'show hidden files and folders' to view 'roaming') but if it gets you back to where you want to be then Hey!........

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 27871
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: Ver 27 reported outdated, no Adblock after downgrade

Post by Moonchild » 2016-11-25, 10:20

rbruce1314 wrote:I too can't live without adblock. Looking over the various threads here, I tried going to addons and hitting the 'update' gear wheel. It did update to v3.5 as promised - but still didn't appear on the toolbar or in the 'customize' box. I had already changed the user agent compatibility to 'Firefox' as instructed elsewhere but no joy - no adblock.
And if you had paid attention instead of (maybe?) panicking and reinstalling v26, you would have seen it required a browser restart... ;)
ABL 3.0 is a bootstrapped add-on, and 3.5 is a more traditional overlay add-on which requires a restart (because it's the only proper way to make sure ad blocking is completely initialized and loaded before the first page comes up, never leaking anything to ad networks)
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

rbruce1314
Moonbather
Moonbather
Posts: 52
Joined: 2016-04-02, 09:06

Re: Ver 27 reported outdated, no Adblock after downgrade

Post by rbruce1314 » 2016-11-25, 10:48

Moonchild wrote: And if you had paid attention instead of (maybe?) panicking and reinstalling v26, you would have seen it required a browser restart... ;)
No I didn't (panic) :thumbdown: . I'm not that stupid! :wave: Not only was there a prompt to do just that, it is something I've ALWAYS done as a matter of course, not only with browsers - surprising how many (apparent) problems it solves. :)

So basic in my case that I didn't even bother to mention it, it was that obvious....... :idea:
Sorry if that misled you..... :|

Hey, Moonchild, I know you guys are under a lot of pressure this week, :roll: but there's no reason to suggest that WE, the users, are panicking!! :(

Anyway, as I said upthread, there were several reasons for going back (most of them listed up there) and adblock was only one of them. ;)

And anyway,anyway, I thought I'd tried to make it clear that PM27 was a fresh install so that I have BOTH currently installed, each with its own profile. So once the initial problems are resolved it's a case of simply clicking on the other desktop shortcut to use 27. :)

User avatar
Pale Ale
Hobby Astronomer
Hobby Astronomer
Posts: 15
Joined: 2016-11-23, 16:57

Re: Ver 27 reported outdated, no Adblock after downgrade

Post by Pale Ale » 2016-11-25, 15:50

I'm not having any browser compatibility problems (yet) although I did make a vanilla clean install of v27. My v27 is in the default 'Gecko Compatibility' mode and I'm not getting any problems in any mail sites.

I think it could be that v27 often needs a clean install, rather than auto-upgrading on some systems.

wsurfer0

Re: Ver 27 reported outdated, no Adblock after downgrade

Post by wsurfer0 » 2016-11-25, 19:15

Hello, OP here. In the end I kept PM 26.5.0 and installed and old version of Adblock Plus. However, thank you Moonchild for the link for older versions of Latitude, it seems others were looking for that as well.

Also, I noticed that v26.5 installs with FF Compatibility turned on by default, is that not the case with v27?

Tweakbl

Re: Ver 27 reported outdated, no Adblock after downgrade

Post by Tweakbl » 2016-11-26, 19:15

I will post as well. I rolled back to Version: 26.5.0 (x64) as well.

I use Adblock Latitude as well. On a machine that has been running Palemoon for a couple years. So appreciate the shout out about which specific version to use from the Archive. :) I was in the archive today, rolling back to V26, and found the list there, but was actually unsure which .xpi to use, until I remember I seen Moonchild talking about that here last night. (I had seen the issue with V27 last night or night before when I got the update, and needed time to research what the issue was on my rig)

I am on Win 10 x64 version 1607 (OS Build 14393.447). The only other Palemoon issues I have had (26 and 25) were Palemoon would close with a error unexpectedly when I was playing WOW on my Main Monitor and had Palemoon open on my second Monitor. Usually when playing Flash vids. The fix for this was just to not watch the vid and close the tab.

But with Version 27. Palemoon will do a lock up of sorts, still exit-able, if I minimize then maximize, it will "refresh" and update. For example. I will be in Game on my Main Monitor. Chatting in Facebook on my Second Monitor. And go between the two. Randomly Palemoon will lock up. And when you try to type in Palemoon's Facebook window......it will do so, one letter at a time like its S-l-o-w-i-n-g down all the way to a lock up to where you would miss messages responses, until you Min then Max the window. Minimize then Maximize fixes it temporarily. And its not just on Facebook this happens.

Rolling back to a 26.0 version seems to have corrected it. For me. I Will watch to see if 27 versions get corrected in future and update as needed :)

PS- Thanks again for all the work put into PM. Its currently the only native browser that maintains the look and feel I have come to like. (Tabs on Bottom etc etc.)

rbruce1314
Moonbather
Moonbather
Posts: 52
Joined: 2016-04-02, 09:06

Re: Ver 27 reported outdated, no Adblock after downgrade

Post by rbruce1314 » 2016-11-30, 10:25

Had high hopes with the 27.0.1 upgrade...... but still no joy! Adblock Latitude 3.5 is installed but even after resetting 1) it, 2) the browser, and 3) the whole PC it still won't display. Any way forward on this one - any other ideas at all??

rbruce1314
Moonbather
Moonbather
Posts: 52
Joined: 2016-04-02, 09:06

Re: Ver 27 reported outdated, no Adblock after downgrade

Post by rbruce1314 » 2016-12-03, 11:24

27.0.2 - and Nearly There! Adblock Latitude icon is there now - - - but in the Status bar only! Now if someone can point me to putting it back on the address bar I'll be really happy.......... coz I can't work how to do it this time (I could before but options now seem to be restricted)

Help anyone??

User avatar
Gandalfdjh
Fanatic
Fanatic
Posts: 125
Joined: 2014-05-04, 14:00
Location: United States
Contact:

Re: Ver 27 reported outdated, no Adblock after downgrade

Post by Gandalfdjh » 2016-12-03, 14:56

I do believe that ABL has been updated (4.0.0)
Image1911 remains the service pistol for all ages!
"Speak softly and carry a big stick; you will go far." — Theodore Roosevelt

User avatar
ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2262
Joined: 2012-06-28, 01:20

Re: Ver 27 reported outdated, no Adblock after downgrade

Post by ron_1 » 2016-12-03, 18:09

rbruce1314 wrote:
27.0.2 - and Nearly There! Adblock Latitude icon is there now - - - but in the Status bar only! Now if someone can point me to putting it back on the address bar I'll be really happy.
On the menu bar, go to View >> Toolbars >> Customize. Then simply drag the icon to wherever you want it.
Gandalfdjh wrote:
I do believe that ABL has been updated (4.0.0)
Yes, it can be downloaded from here:
https://addons.palemoon.org/extensions/adblock-latitude/

rbruce1314
Moonbather
Moonbather
Posts: 52
Joined: 2016-04-02, 09:06

Re: Ver 27 reported outdated, no Adblock after downgrade

Post by rbruce1314 » 2016-12-04, 10:53

Yup - installed 4.0 and it automatically appeared in the address bar! Thanks all!


(in answer to 'helloimustbegoing' that was the point with 3.5 as I tried to explain - the red icon was missing completely from the 'customize' box, so I just couldn't do what you suggested! Fortunately 3.0 has solved it without me doing a thing!!)

looper

Re: Ver 27 reported outdated, no Adblock after downgrade

Post by looper » 2016-12-09, 21:54

rbruce1314 wrote:Yup - installed 4.0 and it automatically appeared in the address bar! Thanks all!


(in answer to 'helloimustbegoing' that was the point with 3.5 as I tried to explain - the red icon was missing completely from the 'customize' box, so I just couldn't do what you suggested! Fortunately 3.0 has solved it without me doing a thing!!)
On my v27+ setup, on multiple profiles, the ABL red icon is auto installed at the bottom far left of the status bar. When you do your customize, you just drag it from there to wherever you want.

On a related point, the FF add-on Disconnect icon is auto-added up beside the Home icon, which is very confusing. Not where I would've expected it to be at all.

Locked