[Solved] PM x86 (still) remains in processes after closing

For discussions specific to the Portable version of the browser.

Moderator: satrow

cattolicboy

[Solved] PM x86 (still) remains in processes after closing

Unread postby cattolicboy » Mon, 12 Jan 2015, 22:23

Hello, I'm new on the forum, but an old and happy user of palemoon.
Since those two topics (http://forum.palemoon.org/viewtopic.php?f=14&t=3263&hilit=closing and http://forum.palemoon.org/viewtopic.php?f=14&t=2206) are marked "locked", I have opened a new one, but with similar issue.
Till today I have used palemoon portable x64, but I want to change to x86 because of compatibility issue with roboform (I was using the lite add-on with limited options).
The problem with the x86 version of our favourite browser, is that the process stay in the task manager after closing: the only way is to force the closing from there.
No problem at all with the x64 version, and I have tried both the x86 versions with my full profile (all add-ons), that a clean profile ...same problem.
My running system is Win7 x64, amd processor, 16gb ram, ati radeon hd 3870 graphic and eset smart security firewall/antivirus (but this is not the problem).
Please, any suggestion?
Thanks!

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 23021
Joined: Sun, 28 Aug 2011, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: PM x86 (still) remains in processes after closing

Unread postby Moonchild » Mon, 12 Jan 2015, 22:32

The first thing that comes to mind is that it might be a plugin (that is loaded in x86 but not x64 because not many are 64-bit compatible). These plugins are often installed system-wide and would be loaded even in a clean profile.
Please check your addons manager, plugins tab, and see what's listed there? Disable them and close the browser, see if it solves the issue?
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

cattolicboy

Re: PM x86 (still) remains in processes after closing

Unread postby cattolicboy » Mon, 12 Jan 2015, 22:54

Thanks, for the quick reply, that was fast!
For "clean profile" I meant a fresh profile extracted from the zip file.
Anyway, I just checked and no add-ons are installed. I've also tried to disable the plugins, but no luck, the process is still in the task manager.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 23021
Joined: Sun, 28 Aug 2011, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: PM x86 (still) remains in processes after closing

Unread postby Moonchild » Tue, 13 Jan 2015, 01:18

Okay, well another suggestion would be to explicitly exclude Pale Moon from eset if possible. You've obviously already tried some thing in that respect, but just "disabling" it won't always provide anything conclusive since oftentimes security software "hooks" into running processes which may prevent them from shutting down properly, even if you've switched it off at the system level (in some cases only uninstalling would stop these monitoring drivers from hooking into processes...).

Something like this is difficult to troubleshoot and find the exact cause of, unfortunately.
have you also tried explicitly exiting the browser from the menu (instead of closing the window)?
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

cattolicboy

Re: PM x86 (still) remains in processes after closing

Unread postby cattolicboy » Tue, 13 Jan 2015, 09:34

First of all, thanks Moonchild for your kind help and suggestions.
However, none of your tips has worked, but I've tried other things:
1) I've disabled completely the eset suite ...problem still there
2) I've runned PM over a virtual machine ...problem seems to be solved
3) Then I have tried to disabling one by one every program that are running on my system and at the end I found the responsible of the hook!
The culprit was Direct Folders, a program for managing windows and shortcuts.
So now, after get rid of DF, PM is closing properly ...problem solved!
:coffee:

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 23021
Joined: Sun, 28 Aug 2011, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: PM x86 (still) remains in processes after closing

Unread postby Moonchild » Tue, 13 Jan 2015, 11:34

Sorry you had to go through all that to find the culprit, but good to know it got solved! :)
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne


Return to “Pale Moon Portable”

Who is online

Users browsing this forum: No registered users and 1 guest