java 6.0 old version problems

For discussions specific to the Portable version of the browser.
Locked
maometto1

java 6.0 old version problems

Post by maometto1 » 2014-02-22, 10:04

Hello,
i downloaded JAVA 6.0 (old version).

But now the problem is JAVA is not enabled in my Portable Palemoon version 11.0

I already set "enable java" in Palemoon SECURITY option and also i set "mozilla family" in java browser control settings but later when i check java settings (after borwser reboot) it happens "mozilla family" is not checked in options.

Any suggests to solve all this ?

I DO NOT WANT TO UPDATE JAVA TO LATEST VERSION NO WAY.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 26191
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: java 6.0 old version problems

Post by Moonchild » 2014-02-22, 10:53

You will have to put the java plugin dll into the Portable browser manually.
Copy the appropriate plugin files to Lib\Java\bin\new_plugin in the portable browser.
The java plugin when installed on your desktop will not be picked up by the portable because it is a portable. If you need interaction with your desktop, install the regular (non-portable) version instead.

ALSO: VERSION 11.0 IS VERY OLD AND NOT SAFE TO USE. UPGRADE TO THE CURRENT VERSION.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

maometto1

Re: java 6.0 old version problems

Post by maometto1 » 2014-02-22, 16:58

i read your explanation but i cannot find any directory named ----------> Lib\Java\bin\new_plugin
because in my palemoon portable browser there isn't.

Also which are plugin files i must export from Java directory to my portable browser directory ?
I have only found plugin.jar

maometto1

Re: java 6.0 old version problems

Post by maometto1 » 2014-02-24, 17:24

any news ?

mgagnonlv
Lunatic
Lunatic
Posts: 266
Joined: 2013-03-05, 02:06
Location: Canada

Re: java 6.0 old version problems

Post by mgagnonlv » 2014-02-24, 19:14

You have several issues here, many of them related to the age of your software. I know that current versions of Java are picked up by current versions of Pale Moon Portable. In other words, Pale Moon Portable "sees" that I have Java installed on my computer, reads it and uses it.

1. Issue 1: 32 or 64 bits?
Java 6 is most likely 32-bits. Are you using Pale Moon (32-bit) or Pale Moon 64 (64-bit)? If you are using Pale Moon 64, you need to also install Java 64-bit (or Java-64 as they call it).

2. Age of these versions.
Java is, in itself, a good entry door for potential viruses and other hacks, which is why they already are at SE7-update 51. But if you think that version 6 is any safer, forget it! If you have a local, safe application that uses Java 6 and can't work with Java 7, it is possible to enable Java 7 by default and Java 6 for one specific application. This is done either through the Java control panel or in the specific application that calls Java.

One such "too old" problem I have witnessed with Firefox is that the old browser (a.k.a. Pale Moon v. 11) is configured to use the old Java (Java 6); however, when it goes to check the table of incompatibilities and vulnerabilities, it checks with the current table... which bans Java 6 and older updates of Java 7. I have witnessed that with Firefox, but I assume it would be similar with Pale Moon.

Solution: As Moonchild said, update!
If you want to be extra-safe, first create a copy of your Pale Moon profile so you could go back and get back your bookmarks and such. If you have any specific reason NOT to update, please state them. We might have 1-2 solutions to suggest you.
Michel Gagnon
Montréal (Québec, Canada)

maometto1

Re: java 6.0 old version problems

Post by maometto1 » 2014-03-16, 08:18

1) i have 32 bits pc with my portable palemoon 11 (32 bits)
2) my java version is 6.0

BUT WHERE IS JAVA FILE I HAVE TO EXPORT TO PORTABLE PALEMOON PATH ?

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 26191
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: java 6.0 old version problems

Post by Moonchild » 2014-03-16, 09:13

1) I have a user with with terribly outdated software
2) The user does not respect the time and effort people show by completely ignoring explanations and answers
3) The user refuses to update and expects further support to be given on obsolete software

WHAT DO I DO WITH THIS USER?

;)

Jokes aside: I'm not going to give any further support on this browser/plugin combination. If anyone else feels the calling to help someone be vulnerable on the web with obsolete java and obsolete browser, they are free to do so, but out of principle I won't. This combination screams "abuse me" for drive-by java downloads and identity theft, since PM 11 does not have protection for many potential modern exploits, and a computer won't take much use to become a botnet participant.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

jumba

Re: java 6.0 old version problems

Post by jumba » 2014-03-16, 09:43

maometto1 wrote:1) i have 32 bits pc with my portable palemoon 11 (32 bits)
2) my java version is 6.0

BUT WHERE IS JAVA FILE I HAVE TO EXPORT TO PORTABLE PALEMOON PATH ?
May I ask, where do you need such a out dated and insecure combination, and why can't you update?

Now, It feels like Mc said:
Moonchild wrote:.. to help someone be vulnerable on the web with obsolete java and obsolete browser ..
Or even could be: :thumbdown:
.. to help someone OTHER be vulnerable on the web with obsolete java and obsolete browser ..

maometto1

Re: java 6.0 old version problems

Post by maometto1 » 2014-03-21, 04:54

the problem is not my old palemoon version but my old java version !!

Anyway, i have got last palemoon portable version but i have same problem like before.

So,for the last time, tell me how do i export java.dll file to palemoon portable folder.

maometto1

Re: java 6.0 old version problems

Post by maometto1 » 2014-03-26, 16:56

i updated to palemoon portable 20.1 version but same problems.......

Locked