Problem loading page-URL not valid

For discussions specific to the Portable version of the browser.

Moderator: satrow

LegitimateGrapes
Moonbather
Moonbather
Posts: 56
Joined: 2015-04-24, 05:26
Location: Grape farm

Re: Problem loading page-URL not valid

Unread post by LegitimateGrapes » 2016-02-28, 08:33

So I guess something from the Windows 7 updates affected portable pale moon? This only became a problem for me after I did windows update.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24469
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Problem loading page-URL not valid

Unread post by Moonchild » 2016-02-28, 21:36

I'm on Windows 7 myself, and I don't have a problem running the portable versions of Pale Moon (I do this all the time for try builds)...

Can you please try the following and see if it makes any difference:
  1. Download the zip packed version of Pale Moon for your architecture.
  2. In the portable, go into Bin\Palemoon, and delete all files and folders there
  3. Unzip the downloaded archive, which will create a "palemoon" folder with the application files in it.
  4. Copy all the files and folders that are in this palemoon folder to the portable Bin\Palemoon folder
  5. run palemoon-portable.exe -purgecaches (purgecaches is only needed once to make sure nothing bad in terms of scripting or styles is in the startup cache)
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

freefrog

Re: Problem loading page-URL not valid

Unread post by freefrog » 2016-02-28, 22:33

Moonchild if I follow these steps, then the problem is gone for me.

coffeebreak
Board Warrior
Board Warrior
Posts: 1823
Joined: 2015-09-26, 04:51
Location: U.S.

Re: Problem loading page-URL not valid

Unread post by coffeebreak » 2016-02-28, 22:39

Same here, I can now access all those internal pages normally.

User avatar
1210_bex
Lunatic
Lunatic
Posts: 308
Joined: 2013-10-09, 04:09
Location: USA

Re: Problem loading page-URL not valid

Unread post by 1210_bex » 2016-02-29, 06:05

It took me a little while to understand the procedure, but once I did, it all works fine now. So it seems it now works for all three of us who have complained here about the problem.

That leads to 2 questions:
1. Why does Moonchild not have any problem running on Windows 7 without this workaround, but the three of us require it?
2. What does it take to have the Portable code changed so we don't have to go through this every time we update to a newer version of Portable, or a user who has not read this thread downloads Portable to his Windows 7 computer?


Harry

LunaPallooza

Re: Problem loading page-URL not valid

Unread post by LunaPallooza » 2016-03-01, 23:30

Confirmed, that worked for me as well.
1210_bex - That leads to 2 questions:
1. Why does Moonchild not have any problem running on Windows 7 without this workaround, but the three of us require it?
2. What does it take to have the Portable code changed so we don't have to go through this every time we update to a newer version of Portable, or a user who has not read this thread downloads Portable to his Windows 7 computer?
1 - Based on the # of views re/ this topic, probably many others that it doesn't work for either, but good question. Also, I hadn't tried the Portable version before the latest round of MS updates, so can't comment on that, but reviewing the updates I installed, doesn't really look like anything in there would have affected it.
2 - MC seems to indicate it's not something in the Portable code, but rather in our OS's. Either way, perhaps a Sticky up top or a link or note from the main Portable download page might be useful?

Another question re/ this workaround - I noticed that most of the files from the Zip pack that were copied over are much larger than those just replaced for the Portable files ...
does using the Zip Pack files & folders of the installed version leave any additional traces on a host computer compared to the Portable version?

I realize & understand that it's not necessarily designed to avoid this, and its primary purpose is just simply portability (which is Great). But those who use it from a USB stick, in a work environment, friend's place, cafe, while traveling, etc. may be curious about security & privacy, esp. if accessing financial sites, etc.

I would assume there's nothing useful left behind ... just looking for verification.
Thanks for this workaround MC.

freefrog

Re: Problem loading page-URL not valid

Unread post by freefrog » 2016-03-16, 15:35

Moonchild wrote:I'm on Windows 7 myself, and I don't have a problem running the portable versions of Pale Moon (I do this all the time for try builds)...

Can you please try the following and see if it makes any difference:
  1. Download the zip packed version of Pale Moon for your architecture.
  2. In the portable, go into Bin\Palemoon, and delete all files and folders there
  3. Unzip the downloaded archive, which will create a "palemoon" folder with the application files in it.
  4. Copy all the files and folders that are in this palemoon folder to the portable Bin\Palemoon folder
  5. run palemoon-portable.exe -purgecaches (purgecaches is only needed once to make sure nothing bad in terms of scripting or styles is in the startup cache)
I can confirm that replacing the executable files with the not packed version from the zip file fixes the problem.

Probably some conflict with a recent MS patch and the packer used to compress them.

Ghost

Re: Problem loading page-URL not valid

Unread post by Ghost » 2016-03-17, 14:30

Hello,

Same problem here with Win7. It looks like the compressed version of browsercomps.dllmoonshell.exe (64bits) from Palemoon-Portable-26.1.1.win64 was faulty. After moving the one from the zipped version of palemoon-26.1.1.win64 it works now.

Thanks for the workaround and for all your dedication and amazing work moonchild :angel:
Last edited by Ghost on 2016-03-18, 08:27, edited 1 time in total.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24469
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Problem loading page-URL not valid

Unread post by Moonchild » 2016-03-17, 22:05

"moonshell.exe"? Please explain. That should not be in the browser. If it is, then that's not right.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

Ghost

Re: Problem loading page-URL not valid

Unread post by Ghost » 2016-03-18, 04:38

Moonchild wrote:"moonshell.exe"? Please explain. That should not be in the browser. If it is, then that's not right.
oh my bad it is palemoon.exe of course :oops:
Original name palemoon.exe
Internal name Pale Moon
File version 26.1.1.5896
PE header basic information
Target machine x64
Compilation timestamp 2016-02-22 18:53:00


Next, after extended tests with a fresh installation and no other running instances under win7 it looks like it is not related to the .exe file but to the compressed version of \Bin\Palemoon\browser\components\browsercomps.dll

You just need to replace this single file with the one from palemoon-26.1.1.win64.zip as workaround.

Older versions are affected too so it is maybe related to some security update...

coffeebreak
Board Warrior
Board Warrior
Posts: 1823
Joined: 2015-09-26, 04:51
Location: U.S.

Re: Problem loading page-URL not valid

Unread post by coffeebreak » 2016-03-18, 12:22

Ghost wrote:...after extended tests with a fresh installation and no other running instances under win7 it looks like it is not related to the .exe file but to the compressed version of \Bin\Palemoon\browser\components\browsercomps.dll

You just need to replace this single file with the one from palemoon-26.1.1.win64.zip as workaround.

Can confirm this also works with palemoon-26.1.1.win32.
Last edited by coffeebreak on 2016-03-18, 14:58, edited 1 time in total.

freefrog

Re: Problem loading page-URL not valid

Unread post by freefrog » 2016-03-18, 12:51

You can just decompress the browsercomps.dll with UPX. Just do "upx -d browsercomps.dll" and it also works.
So Moonchild, just do not use UPX compression for this file in next version and problem should be solved.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24469
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Problem loading page-URL not valid

Unread post by Moonchild » 2016-03-18, 19:53

It's a strange thing though, because it works just fine on any system I tried it on, as well as the fact that i've used this exact same compression technique for a looooong time already, same compressor version and method.

But indeed, a simple solution is not applying compression to that particular dll.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

Herman Strange

Re: Problem loading page-URL not valid

Unread post by Herman Strange » 2016-03-19, 01:26

This problem just started on my system today, subsequent to loading a large number (97 I believe it was) of Windows Updates. Will do the .dll fix, but wanted to pass this on as a possible source of the problem.

(quick followup) interestingly enough, the one from 26.1.1.win64.zip didn't resolve the error for me - I'm running 26.1.1x64 at the moment. However, I found a much older version (3/13/2015, looks to be from 25.3.0) that was uncompressed (? 277KB instead of 66KB) and tried it - problem resolved. Wanted to pass that on also in case it was any help.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24469
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Problem loading page-URL not valid

Unread post by Moonchild » 2016-03-19, 12:24

Please don't mix and match dlls from different versions. That's asking for things to break. You're lucky it started at all XD

The dll in the .zip packed version should not be compressed so if it was still 66KB then I think you made a small error unpacking it.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

tor11
Apollo supporter
Apollo supporter
Posts: 30
Joined: 2015-10-27, 15:47
Location: Europe

Re: Problem loading page-URL not valid

Unread post by tor11 » 2016-03-19, 14:06

I am very curious what windows update is causing this. Interesting.

Herman Strange

Re: Problem loading page-URL not valid

Unread post by Herman Strange » 2016-03-19, 15:54

Moonchild wrote:Please don't mix and match dlls from different versions. That's asking for things to break. You're lucky it started at all XD
Yes, I was surprised it did - was only for a quick test.
Moonchild wrote:The dll in the .zip packed version should not be compressed so if it was still 66KB then I think you made a small error unpacking it.
Aha - just caught this, referring to the .dll from the "full version" .zip? Can do that, thanks.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24469
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Problem loading page-URL not valid

Unread post by Moonchild » 2016-03-19, 16:21

Yes, the "full version" zip :) Not a portable.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

Locked