Debian・Ubuntu パッケージで 27.4.0 が誤って提供されました・対処方法

日本語での議論

Moderator: satrow

balloon
Moonbather
Moonbather
Posts: 59
Joined: Wed, 27 Jan 2016, 09:34

Debian・Ubuntu パッケージで 27.4.0 が誤って提供されました・対処方法

Unread postby balloon » Tue, 11 Jul 2017, 03:28

元情報(英語):
viewtopic.php?f=37&t=11466&start=100#p117055

Debian・Ubuntu 向けパッケージ( opensuse.org サーバから提供)で、
日本時間 2017年7月10日〜11日 に正式公開されていない開発途上状態のバージョン 27.4.0 が
誤ってビルド・更新されてしまっています。
これは 7月11日 までに 27.3.0 へ戻されました。
これは Linux 公式パッケージ、また Windows など他の配布では影響ありません。

しかし、バージョンを戻すためには手動で作業を要します。
一番簡単な方法は、一度削除し、再度インストールしなおす方法です。
この方法は apt の代わりに apt-get や aptitude でも行えます。
Debian GNU/Linux など、sudo を有効にしていない場合は su で root 権限にして実行して下さい。

Code: Select all

sudo apt remove palemoon
sudo apt install palemoon

,またはバージョンを直接指定する方法もあります。
こちらは apt 以外のコマンドでは、形式が異なる場合があります。

Code: Select all

sudo apt install palemoon=27.3.0~repack-1

27.4.0 のままだと後のパッケージ更新で悪影響が発生し、
また意図しない不具合に遭遇する場合がありますので、戻していただく事をおすすめします。

balloon
Moonbather
Moonbather
Posts: 59
Joined: Wed, 27 Jan 2016, 09:34

Re: Debian・Ubuntu パッケージで 27.4.0 が誤って提供されました・対処方法

Unread postby balloon » Tue, 11 Jul 2017, 11:29

MX Linux (MX-16.1 など) では独自に Pale Moon を更新していますが、同じ問題が発生しているようです。(メンテナーは同じ人です)
同じ方法で 27.3.0 へ戻して下さい。

balloon
Moonbather
Moonbather
Posts: 59
Joined: Wed, 27 Jan 2016, 09:34

Re: Debian・Ubuntu パッケージで 27.4.0 が誤って提供されました・対処方法

Unread postby balloon » Wed, 12 Jul 2017, 23:27

27.4.0 が正式に公開されました。こちらを反映したバージョンは 27.4.0~repack-2 となっています。
(誤って公開されたバージョンは 27.4.0~repack-1)
そのため、現在は普通にパッケージ更新する事で正式な 27.4.0 を得られる状態になっています。
もしこの投稿に今気がついた場合、上の投稿は行わず、単にパッケージ更新で構いません。


Return to “Japanese (日本)”

Who is online

Users browsing this forum: No registered users and 3 guests