v27 Compatibility Checking Tool

Pale Moon releases and site news
(read-only)
User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22155
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

v27 Compatibility Checking Tool

Unread postby Moonchild » Tue, 18 Oct 2016, 10:57

As we've mentioned before, the upcoming version 27 will no longer support so-called Jetpack/SDK extensions for technical reasons.

Several people have asked for help how to know which of their extensions are SDK extensions. Unfortunately it's not that simple to do manually (especially if you use many extensions in your browser) and it involves having to crack open the extension files and having a look inside of them, etc., which many people would not be comfortable with.
Another option is to grab the public beta from http://www.palemoon.org/WIP/ because its add-on manager will indicate incompatible extensions. That, too, however, is inconvenient and will require you to run the pre-release version on your working profile (which has its own pitfalls because some files are migrated to new versions when you run the beta and can't be converted back).

The Solution

I've created a Compatibility Checker tool (Windows only, sorry Linux folks!) that will check your default Pale Moon profile and indicate which of your extensions are SDK extensions, so you can look into finding alternatives for them before v27 is released, or at the very least know what will no longer work in Pale Moon 27 and later.

Mind you, this tool was made quickly and isn't very polished. It is also not able to always extract the display name of extensions from extension files because of the different ways that people have written the install.rdf file. Special characters in names (like accented characters or non-latin character sets) will not display properly either. It is a simple tool for convenience sake for this new milestone.

Instructions for use

  1. The tool comes as a simple, single .exe file. Just download it to a location of your choice and run it.
  2. Once the tool loads, you will be presented with a straightforward interface. Most people will only need to click the "Check" button.
  3. After clicking "Check", the list on the right will populate with the names of all your extensions.
  4. When the tool is done checking your extensions (it will say "Done!" at the bottom), check the list. If an extension is marked with {SDK} in front of its name, then it will not be compatible with Pale Moon v27!

If you have multiple Pale Moon profiles or have the profile stored in a non-standard location, you can click the "Select Another Profile" button to pop up a folder picker to browse to a different profile folder to check. You should select the root folder of your profile (usually has a number of random characters and then the given name or .default appended).
pmecc1.png


Download it!

You can download the .exe directly from our storage FTP server: ftp://publicbeta:get@ftp2.palemoon.org/tools/CompatChecker.exe

Alternatively, if FTP is problematic for some reason, you can get the file from the following mirrors: [US] [EU]

The file size is 1,136,792 Bytes (1.1 MB) and it is, as usual, code-signed to verify it's original and unaltered. (Signer: Markus Straver)
Some antivirus suites may still complain because of the way this tool was built (using a rapid development suite).
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

Return to “Announcements”

Who is online

Users browsing this forum: Blogtrotter [RSS] and 49 guests