Mozilla Sync 1.1 Servers are now Offline (Sync Errors)

Pale Moon releases and site news
(read-only)
Locked
User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 6927
Joined: 2012-10-09, 19:37
Location: Sector 001

Mozilla Sync 1.1 Servers are now Offline (Sync Errors)

Post by New Tobin Paradigm » 2015-10-05, 07:53

Some time ago, you may have read that Mozilla was eventually going to shut down their "old" sync servers once the transition to Firefox Accounts (Sync 1.5) was complete. This has now happened. As a result, any users who might still be using Mozilla's infrastructure for Sync will be getting the following message:
Sync encountered an errror while syncing: Unknown error. Sync will automatically retry this action.
How do I know if my Sync error is caused by the loss of Mozilla's Sync 1.1 infrastructure?

Luckily, we have already outlined all you need to know to be able to tell if your profile's Sync settings are still using Mozilla's servers and how to transition to the Pale Moon Sync service.

Please check out: viewtopic.php?f=1&t=7286
Image
- This program cannot be run in DOS mode. -
https://binaryoutcast.com/ | Freenode #binaryoutcast | http://thereisonlyxul.org/

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 26142
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Mozilla Sync 1.1 Servers are now Offline (Sync Errors)

Post by Moonchild » 2015-10-07, 09:53

Additional note: it seems a casualty of Mozilla doing this has been the 12-character authentication (J-PAKE) service for linking devices. I'll be looking at putting a key exchange server in production soon to remedy this.

In the meantime, you will have to enter your Pale Moon Sync user name, password and recovery key on the new device.

EDIT: Confirmed by a Mozilla employee that the key exchange server was shut down as well as the storage servers @Mozilla, since it was apparently only used by Sync 1.1 on their infra (even though it could have been used by other services). It was not obvious from their communication that this would happen, or I'd have put more effort into getting this up before their Sync shutdown.

Note that updating this will not be possible except with a new release of the browser, especially for Android. We may yet need 25.7.3, after all ;)
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

Locked