Pale Moon 15.0 smoothscroll settings not working

Users and developers helping users with technical Pale Moon issues. Please direct questions about the Linux version to the appropriate Linux board.

Moderator: Indalecio

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!

Pale Moon 15.0 smoothscroll settings not working

Postby Evil Moo » Mon Aug 27, 2012 6:38 pm

I have just updated to version 15 of Pale Moon (32-bit) and for some reason I'm finding that the built in smooth scrolling options are seemingly stuck to the default timing values despite displaying as the custom values that I have chosen. This is particularly noticeable for me as I have the timings set very low (40 ms) and the default is about 10 times that, which I am finding difficult to live with.

I have so far tried changing the timing values to something else, starting the browser in safe mode, and installing the update again from the installer (rather than using the check for updates functionality in the about window) in an attempt to fix the issue, but all to no effect.

Any advice in fixing this would be appreciated. Thanks for your time.
User avatar
Evil Moo
Moon lover
Moon lover
 
Posts: 65
Joined: Sat Mar 17, 2012 6:20 pm
Location: Sitting in a dark room.

Re: Pale Moon 15.0 smoothscroll settings not working

Postby Blacklab » Tue Aug 28, 2012 12:58 am

Regret "smooth scrolling" options not my specialist subject - not sure what time zone your "dark room" located in - it's the small hours of night over here..... but I am sure Moonchild himself or one of the other more tech savvy forum members will sort you out when they are back online later this morning! (Moderator please delete this post when OBE = "overtaken by events") :D
Blacklab
Lunatic
Lunatic
 
Posts: 724
Joined: Fri Jun 08, 2012 12:14 pm
Location: Scotland UK

Re: Pale Moon 15.0 smoothscroll settings not working

Postby Moonchild » Tue Aug 28, 2012 9:05 am

I'm investigating what the issue might be, and will post an update when I've had time to go through the wake of this new release which is always very busy. Possibly, the Mozilla team has renamed the parameters controlling the smooth scrolling, which has slipped under the radar in that case because of the focus on the overall engine implementation for 15.0.
Please do not send me private messages for anything that could also be posted in the public boards.
User avatar
Moonchild
Pale Moon guru
Pale Moon guru
 
Posts: 7775
Joined: Sun Aug 28, 2011 5:27 pm
Location: Sweden

Re: Pale Moon 15.0 smoothscroll settings not working

Postby Moonchild » Tue Aug 28, 2012 9:31 am

I was right, some parameters got renamed and this slipped my attention (because it wasn't just renamed but a new one was added). This impacts mousewheel scrolling only.

To adjust your speeds, you need to adjust the following parameters in about:config
Code: Select all
general.smoothScroll.mouseWheel : true or false for enable/disable
general.smoothScroll.mouseWheel.durationMinMS for lower limit
general.smoothScroll.mouseWheel.durationMaxMS for higher limit

The preferences window controls smoothScroll.pixels.* instead which was previously used for the mousewheel, but not anymore (probably because of different methods needed for Android in Firefox)

I'll add this to the known issues list, and will put it on the items to fix for 15.1
Please do not send me private messages for anything that could also be posted in the public boards.
User avatar
Moonchild
Pale Moon guru
Pale Moon guru
 
Posts: 7775
Joined: Sun Aug 28, 2011 5:27 pm
Location: Sweden

Re: Pale Moon 15.0 smoothscroll settings not working

Postby Evil Moo » Tue Aug 28, 2012 4:49 pm

Thanks a lot for the workaround, smooth scrolling is now bearable for me once more. :)
User avatar
Evil Moo
Moon lover
Moon lover
 
Posts: 65
Joined: Sat Mar 17, 2012 6:20 pm
Location: Sitting in a dark room.


Return to Community support

Who is online

Users browsing this forum: Bing [Bot], fei-fw, Google Feedfetcher, MaXimus, Sob__ and 9 guests